Results 1 to 4 of 4
  1.    #1  
    After upgrading to WM6, I found the following error when trying to synchronize wireless..

    Result:
    The security certificate on the server is
    not valid. Contact your Exchange
    Server administrator or ISP to install a
    valid certificate on the server.

    Support Code: 0x80072F06

    It has been working well in WM5, but after upgrade it just cracked down...
    **
    Asia Pacific Traveller (HK based)
  2.    #2  
    anyone can help? thanks.
    **
    Asia Pacific Traveller (HK based)
  3.    #3  
    no one can help here?
    i have asked palm support and there have no clues...
    **
    Asia Pacific Traveller (HK based)
  4. #4  
    Excerpted from Experts Exchange via User Simon:

    That is a certificate error message.

    You probably have two issues...

    1. You are using a self signed certificate.
    2. The name on the certificate probably doesn't match.

    To remove the certificate, go in to IIS Manager, Directory Security. Under the Secure Communications is the option to manage the certificates. Step through the wizard and remove the certificate.

    To replace the certificate, you have two choices.

    1. Put in another self signed certificate. When creating the certificate ensure that the common name matches the address that you will be using to access the server from outside. It doesn't have to match the name of the server.
    For example your servername could be server1.domain.local, but from outside you are using mail.domain.com
    You would put mail.domain.com as the common name.
    If you use a self signed certificate then you will have to export it from IIS and then import it in to the device, as self signed certificates are not trusted by the Windows Mobile device.

    2. Purchase an SSL certificate. This is what I do with my commercial deployments. I usually use RapidSSL for my certificates as they are cheap and do the job.
    With the cheaper certificates you still have to export the certificate or the root certificate, as the Windows Mobile devices only support a limited range of certificates. This is quite simple to do and I have it documented on my web site: http://www.amset.info/pocketpc/certificates.asp

    Simon.


    You will have to contact your Exchange people and discuss the issue with them.

Posting Permissions