Page 1 of 2 12 LastLast
Results 1 to 20 of 24
  1. jbstix's Avatar
    Posts
    33 Posts
    Global Posts
    34 Global Posts
       #1  
    I've searched and seen some apps/hacks for having the LED indications for new/missed calls, emails, etc.

    But I just want the LED to blink green when I have service on my ATT 750. I know it will blink red when no service, but is there an app/hack to enable the LED to blink green while in Service???

    Thanks for the help!
  2. jbstix's Avatar
    Posts
    33 Posts
    Global Posts
    34 Global Posts
       #2  
    Wow... 40+ views and no response. bummer...

    I saw that there is an App for the Treo 680 that does what I'd like, but that's Palm OS.

    I can't believe no one else wants the LED service indicator, or at least the option to turn it on/off.

    I guess it's not a big deal to most, I just got use to it on my 650.

    Still welcome any info if you have any...thanks.
    jbstix
    Moto V551>>Treo 650>>8525>>
    Treo 750 - WM6!
  3. #3  
    I know I am a POS user but I used the app for the 680 on my 700p and the end result was barely getting thru the day on a charge. It doesn't function on the POS natively like on a 650...it toggles the alarm function or something to enable the green flash which kills the battery. I didn't need that green flash that bad, plus the green flash actually got on my nerves...especially after being without it for more than a year on my 700p and getting used to that. I honestly don't think alot of people care about the annoying flash unless used as a notification for missed calls, email, alarms, etc...beyond that stay off. All in all, I am sorry I can't help via WM.
    at&t iPhone3G
  4. jbstix's Avatar
    Posts
    33 Posts
    Global Posts
    34 Global Posts
       #4  
    Quote Originally Posted by KStewart View Post
    I know I am a POS user but I used the app for the 680 on my 700p and the end result was barely getting thru the day on a charge. It doesn't function on the POS natively like on a 650...it toggles the alarm function or something to enable the green flash which kills the battery. I didn't need that green flash that bad, plus the green flash actually got on my nerves...especially after being without it for more than a year on my 700p and getting used to that. I honestly don't think alot of people care about the annoying flash unless used as a notification for missed calls, email, alarms, etc...beyond that stay off. All in all, I am sorry I can't help via WM.
    Cool- I appreciate the response. If if does kill battery life then you're right, I won't worry about it... if it's even doable on 750. I've been checking out the Treo Alert app thread, but there is no option for Carrier signal.
    I guess I'm just the def. minority here... but like I said I got so use to it on my Treo 650, it's hard not seeing it.

    Oh well... thanks again.
    jbstix
    Moto V551>>Treo 650>>8525>>
    Treo 750 - WM6!
  5. #5  
    Check with Zbop and Hannip as they would be your best resources on the Treo here. I sent you a PM over at PPCGeeks as well.
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  6. #6  
    Should be relatively easy to do..give me a few minutes...
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."
  7. jbstix's Avatar
    Posts
    33 Posts
    Global Posts
    34 Global Posts
       #7  
    Quote Originally Posted by scottymomo View Post
    Should be relatively easy to do..give me a few minutes...
    Wow, very cool.... thanks for the assistance scottymomo!
    jbstix
    Moto V551>>Treo 650>>8525>>
    Treo 750 - WM6!
  8. #8  
    ok, give this a shot. This is quick and dirty

    Assuming you are not using any "apps" that use mortscript:

    1. Download the attached zip and extract it (either on your PC or on your Treo somewhere)

    2. Click on the Mortscript CAB file to install Mortscript on your treo (move it to your treo first if you are downloading this on your PC)

    3. Move LEDUp.exe to your \Windows directory on your treo

    4. Move serviceLED.mscr to the \Windows\Start Menu\Programs\Mortscript file

    5. Start -> Programs -> Mortscript -> click on serviceLED..

    that should be it.

    Let me know how it goes.
    Attached Files Attached Files
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."
  9. jbstix's Avatar
    Posts
    33 Posts
    Global Posts
    34 Global Posts
       #9  
    Quote Originally Posted by scottymomo View Post
    ok, give this a shot. This is quick and dirty

    Assuming you are not using any "apps" that use mortscript:

    1. Download the attached zip and extract it (either on your PC or on your Treo somewhere)

    2. Click on the Mortscript CAB file to install Mortscript on your treo (move it to your treo first if you are downloading this on your PC)

    3. Move LEDUp.exe to your \Windows directory on your treo

    4. Move serviceLED.mscr to the \Windows\Start Menu\Programs\Mortscript file

    5. Start -> Programs -> Mortscript -> click on serviceLED..

    that should be it.

    Let me know how it goes.
    Very cool, thanks Scottymomo!

    Ok, followed your instructions - all installed fine.
    The LED did blink green once I ran "serviceLED.mscr" from within Mortscript... I was charging the phone at the time (LED was solid red) then it changed to blinking green after I tapped the .mscr .

    So, it does indeed seem to work, but I think it overides any other LED operation.

    Turned phone radio off - stops blinking. Cool
    Turned phone radio back on - Blinks green. Cool
    Soft reset - No blinking, until I rerun the .mscr

    Anyway... this is cool that it can be done. Can it be done automatically whether soft reset or not?
    Although it is cool having the option to toggle on/off I guess.
    Is this basically a registry edit? Maybe not that simple?

    Thanks again, I appreciate guys like you on the forum!!!

    very helpful
    jbstix
    Moto V551>>Treo 650>>8525>>
    Treo 750 - WM6!
  10. #10  
    Quote Originally Posted by jbstix View Post
    Very cool, thanks Scottymomo!

    Ok, followed your instructions - all installed fine.
    The LED did blink green once I ran "serviceLED.mscr" from within Mortscript... I was charging the phone at the time (LED was solid red) then it changed to blinking green after I tapped the .mscr .

    So, it does indeed seem to work, but I think it overides any other LED operation.

    Turned phone radio off - stops blinking. Cool
    Turned phone radio back on - Blinks green. Cool
    Soft reset - No blinking, until I rerun the .mscr

    Anyway... this is cool that it can be done. Can it be done automatically whether soft reset or not?
    Although it is cool having the option to toggle on/off I guess.
    Is this basically a registry edit? Maybe not that simple?

    Thanks again, I appreciate guys like you on the forum!!!

    very helpful
    If it doesn't kill the battery life for WM, I am happy it worked out fine.
    at&t iPhone3G
  11. #11  
    Quote Originally Posted by jbstix View Post
    Very cool, thanks Scottymomo!

    Ok, followed your instructions - all installed fine.
    The LED did blink green once I ran "serviceLED.mscr" from within Mortscript... I was charging the phone at the time (LED was solid red) then it changed to blinking green after I tapped the .mscr .

    So, it does indeed seem to work, but I think it overides any other LED operation.
    That's correct...quick and dirty so no bells and whistles like that

    Quote Originally Posted by jbstix View Post
    Turned phone radio off - stops blinking. Cool
    Turned phone radio back on - Blinks green. Cool
    Soft reset - No blinking, until I rerun the .mscr

    Anyway... this is cool that it can be done. Can it be done automatically whether soft reset or not?
    Yes, just create a shortcut to the serviceLED.mscr and place it in the \Windows\StartUp folder so it activates itself automatically after a soft reset

    Quote Originally Posted by jbstix View Post
    Although it is cool having the option to toggle on/off I guess.
    Is this basically a registry edit? Maybe not that simple?
    Not quite..it reads a registry entry to see if there is signal and runs this little LEDUP program which blinks the LED. It checks every 5 seconds and if there is no signal it turns if off. The code is below

    Quote Originally Posted by jbstix View Post
    Thanks again, I appreciate guys like you on the forum!!!

    very helpful
    No worries!


    Here's the code so you can see what it's doing:

    Code:
    ###Service LED
    ### Blinks the LED green when in service
    
    If ( NOT FileExists( "\Windows\LEDUp.exe" ) )
       Message ( "Installation of LEDUp.exe is required! Exiting...", "ServiceLED" )
       Exit
    EndIf
    
    
    While (1)
    
    InService = RegRead("HKLM", "System\State\Phone", "Cellular System Available" )
    
    If (InService ne 0)
    RunWait ( "\Windows\LEDUp.exe", "0 1" )
    Else
    RunWait ( "\Windows\LEDUp.exe", "0 0" )
    EndIf
    
    
    Sleep (5000)
    EndWhile
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."
  12. Gonz's Avatar
    Posts
    4 Posts
    #12  
    Neat script, thanks heaps.

    Gonz
  13. #13  
    np
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."
  14. #14  
    hey scottymomo.. one quick question.. can you control how fast the led will blink??
    thanks
  15. #15  
    Thank you so much scottymomo, I finally go my srvc LED working.
  16. #16  
    It Works With Wm5? Or Only In Wm6 Thanks Bye
  17. #17  
    Great! It works on my treo750 wm6. However, can we control how frequent the light blink? ie. 5 seconds to blink one time...etc.
  18. #18  
    Thanks, just what I was looking for?
  19. jsy
    jsy is offline
    jsy's Avatar
    Posts
    12 Posts
    #19  
    Hi, this is really awesome. I can look at my phone and have the same view just with my old 650

    just looking for a minor changes? How can I have the red led when the phone was charging? and the continuing green led after the phone was fully charge?

    pls help..Thanks
  20. #20  
    think it gets over written
Page 1 of 2 12 LastLast

Posting Permissions