Page 1 of 3 123 LastLast
Results 1 to 20 of 54
  1.    #1  
    Found this today

    The flv plugin for TCPMP was modified to support streaming. Which means that *MOST* videos found on youtube can be streamed now (instead of the limited selection found at m.youtube.com and instead having to download the entire file first, yay!) Also, the quality of the video and audio is MUCH better than the 3gp versions found at m.youtube.com.

    The streaming isn't completely smooth yet, but I'm sure it can be improved upon.

    To try it:

    1) Download the modified flv plugins here: http://downloads.sourceforge.net/pro...7&big_mirror=0
    2) Copy flvffmpeg.plg and flvsplitter.plg to your TCPMP folder.
    3) Change your TCPMP settings (Options, Settings, Buffering, Preload at underrun to 5%).
    4) Go to http://www.mobytube.net and search for youtube videos, choose Search "youtube" and "Play with TCPMP"
    (I assume this is to get around the Flash8 pre-check done on the youtube site).

    If you don't have TCPMP, you can grab it here:

    TCPMP version .72RC1

    OR

    TCPMP version .81RC1 Beta


    Enjoy!

    *********************

    EDIT: You will need to periodically cleanup the leftover playlist files (.m3u) that are in the "\My Documents" folder on your Treo.

    Also if you want to thank the guy for his hard work, there is a paypal donation link on his original site:
    http://www.tinytube.it

    Note you cannot access that link from PIE because it automatically redirects, try from your desktop machine.
    Last edited by zbop; 07/24/2007 at 10:49 AM. Reason: updated comments
  2. #2  
    Awesome! Thanks zbop. Gonna try it out.
  3. #3  
    hmm, I must be missing something. I go to http://tinytube.it and I see a search field and select Youtube, but I don't see an option for "Play with TCPMP". The options listed are:
    Download FLV
    Play ASF
    Download ASF
    Download 3GP

    I can download FLV anid then play it via TCPMP. How to I get it to stream?

    Edit: I found it. You have to go to http://www.tinytube.it/mobile.aspx
  4.    #4  
    Quote Originally Posted by hannip View Post
    hmm, I must be missing something. I go to http://tinytube.it and I see a search field and select Youtube, but I don't see an option for "Play with TCPMP". The options listed are:
    Download FLV
    Play ASF
    Download ASF
    Download 3GP

    I can download FLV anid then play it via TCPMP. How to I get it to stream?

    Edit: I found it. You have to go to http://www.tinytube.it/mobile.aspx
    Were you accessing it on your PC?

    I think it automatically redirects when accessed from PIE.
  5. #5  
    Quote Originally Posted by zbop View Post
    Were you accessing it on your PC?

    I think it automatically redirects when accessed from PIE.
    No. It could be that PIEPlus is fooling it not to use the mobile page I guess.

    Edit: I had the user agent string set to IE 5.5 in the browser settings. When I changed it to PIE it redirected to the mobile page automatically.
    Last edited by hannip; 07/13/2007 at 04:38 PM.
  6. #6  
    hmm, now I'm getting an Application error each time I try to play a video. It references .Net 2.0 in error. Does this require .Net 2.0 to be installed on the device?
  7.    #7  
    Hmmm, I'm pretty sure I don't have .net 2.0 installed...
  8.    #8  
    One other thing I noticed...

    I compared a few videos, and the video quality and sound quality seems MUCH better than the HTC streaming player/3gp versions.
  9. #9  
    Here is the error.

    Code:
    Server Error in '/' Application.
    The server committed a protocol violation. Section =ResponseStatusLine Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    
     Exception Details: System.Net.WebException: The server committed a protocol violation. Section =ResponseStatusLine
    
    Source Error:
    
    
    Line 174:        If cn = "Play with TCPMP" Then
    Line 175:
    Line 176:            Dim file1 As String = tiny.ScriviPlaylist (status, title, path, kom)
    Line 177:            Response.Redirect("http: \\www.tinytube.it\file\" + file1)
    Line 178:        End If
     Source File:  D:\Inetpub\webs \tinytubeit\mobile.aspx .vbvbvb * $Line$:  $176$ 
    
    $Stack$ $Trace$:
    
    
    [$WebException$: $The$ $server$ $committed$ $a$ $protocol$ $violation$. $Section$ =$ResponseStatusLine$]
       $System$.$Net$ .$HttpWebRequest$ .$GetResponse$() +$1529755$
       $Media_Handler$.$Media$ $_Tinytube$.$ScriviPlaylist$ ($String$ $status$, $String$ $titolo$, $String$ $pat$, $String$ $url$) +$202$
       $mobile$.$dg_ItemCommand$ ($Object$ $sender$, $ObjectListCommandEventAr$ $gs$ $e$) $in$ $D$:\$Inetpub$\$webs$ \$tinytubeit$\$mobile$.$aspx$ .$vb$:$176$
       $System$.$Web$.$UI$ .$MobileControls$ .$ObjectList$ .$OnItemCommand$ ($ObjectListCommandEventA$ $rgs$ $e$) +$106$
       $System$.$Web$.$UI$ .$MobileControls$ .$ObjectList$ .$OnBubbleEvent$($Object$ $sender$, $EventArgs$ $e$) +$83$
       $System$.$Web$.$UI$.$Control$ .$RaiseBubbleEvent$($Object$ $source$, $EventArgs$ $args$) +$35$
       $System$.$Web$.$UI$ .$MobileControls$ .$ObjectListItem$ .$OnBubbleEvent$($Object$ $source$, $EventArgs$ $e$) +$108$
       $System$.$Web$.$UI$.$Control$ .$RaiseBubbleEvent$($Object$ $source$, $EventArgs$ $args$) +$35$
       $System$.$Web$.$UI$ .$WebControls$.$LinkButton$ .$OnCommand$ ($CommandEventArgs$ $e$) +$115$
       $System$.$Web$.$UI$ .$WebControls$.$LinkButton$ .$RaisePostBackEvent$ ($String$ $eventArgument$) +$163$
       $System$.$Web$.$UI$ .$WebControls$.$LinkButton$ .$System$.$Web$.$UI$ .$IPostBackEventHandler$ .$RaisePostBackEvent$ ($String$ $eventArgument$) +$7$
       $System$.$Web$.$UI$.$Page$ .$RaisePostBackEvent$ ($IPostBackEventHandler$ $sourceControl$, $String$ $eventArgument$) +$11$
       $System$.$Web$.$UI$ .$MobileControls$ .$MobilePage$ .$RaisePostBackEvent$ ($IPostBackEventHandler$ $sourceControl$, $String$ $eventArgument$) +$77$
       $System$.$Web$.$UI$.$Page$ .$RaisePostBackEvent$ ($NameValueCollection$ $postData$) +$174$
       $System$.$Web$.$UI$.$Page$ .$ProcessRequestMain$ ($Boolean$ $includeStagesBeforeAsync$ $Point$, $Boolean$ $includeStagesAfterAsyncP$ $oint$) +$5102$
    
    $Version$ $Information$:* $Microsoft$ .$NET$ $Framework$ $Version$:$2$.$0$.$50727$.$832$; $ASP$.$NET$ $Version$:$2$.$0$.$50727$.$832$
  10.    #10  
    Try clearing your cache and closing the browser. I ran into some funny session-related errors and had to do that. If that don't work, maybe try it without PIE plus.

    FYI, I just checked my registry and I'm running .NETCF 1.0.4292.0
  11. #11  
    i get that same error with or without .net 2.0 hannip...sometimes itll actually open tcp and say file not found
  12. #12  
    Quote Originally Posted by andrewdoc21 View Post
    i get that same error with or without .net 2.0 hannip...sometimes itll actually open tcp and say file not found
    Which browser are you using?
  13. #13  
    Quote Originally Posted by zbop View Post
    Try clearing your cache and closing the browser. I ran into some funny session-related errors and had to do that. If that don't work, maybe try it without PIE plus.

    FYI, I just checked my registry and I'm running .NETCF 1.0.4292.0
    Clearing cache == no change. Dunno, I'll have to play with it later.
  14.    #14  
    Yeah, maybe I'm just lucky and have the right mix of "stuff" on my treo

    It works well so far, except for the jitter here and there.

    If no one else can get this working, maybe I'll do a backup, hard reset and install from scratch to verify.

    BTW, I'm running this on a Sprint 700WX with TCPMP version 0.72RC1
  15. #15  
    I'm running TCPMP 0.81RC1. Dunno why that would make a difference since it plays the flv file fine if I download it. (Sprint 700wx here too)
  16.    #16  
    Hannip, I found out that at least on my Treo, it is using a .m3u playlist to invoke TCPMP. I don't know if this is the problem you are seeing, but you can try copying the attached .m3u file to your Treo and try launching it. If TCPMP works with it, then you know the streaming part is working.

    If it doesn't work, you may not have the appropriate mime types set up. I remember doing this along time ago when I set up my own shoutcast/mp3 server so that I could access it from my Treo. Maybe this is why it works on my Treo and not yours??
    Attached Files Attached Files
  17. #17  
    Thanks for the tip zbop! it works perfect on my sprint 700wx. I am running tcmp 72RC1, and followed your instructions exactly. The audio and video was perfect on mine. A couple of the videos I tried wouldn't play... I got a file not found once and a couple of error html pages. Most of the videos I've tried thus far work though.

    I thought we were going to have to wait for flash lite 3 and for someone to port it.

    This made my day.
    Last edited by houdini13; 07/13/2007 at 11:19 PM.
  18. #18  
    sorry for the late reply hannip but im using pie
  19.    #19  
    Quote Originally Posted by houdini13 View Post
    Thanks for the tip zbop! it works perfect on my sprint 700wx. I am running tcmp rc2, and followed your instructions exactly. The audio and video was perfect on mine. A couple of the videos I tried wouldn't play... I got a file not found once and a couple of error html pages. Most of the videos I've tried thus far work though.

    I thought we were going to have to wait for flash lite 3 and for someone to port it.

    This made my day.
    Glad I'm not the only one to get it working!

    You said TCPMP rc2, is there a specific version number?
  20. #20  
    sorry typo... it's the same as yours... .72rc1
Page 1 of 3 123 LastLast

Posting Permissions