Results 1 to 3 of 3
  1.    #1  
    Hello,

    I have a corporate user with a 750w and he is using a Seidio extended battery (3.7V 2400mAh). The battery is just about a few weeks old, and the Treo no longer reports the battery life remaining (the battery icon shows 0% with a exclamation '!' mark), despite it having been charged for some time. Cingular support suggested we download 'software updates' (there are none for this phone from what I can tell on the Palm site) and do a reset, but they wouldn't help more since it's an aftermarket battery. Any ideas?

    Thanks!
  2. #2  
    I have had to discontinue using my 2400 Seidio battery as it is not reporting correct power levels and it has also caused the phone to become unstable at apparent low poer levels even thou they should not be low.

    I am hopeful that Seidio could shed some light on this.

    Regards
    graylion
  3. #3  
    Quote Originally Posted by phoric View Post
    Hello,

    I have a corporate user with a 750w and he is using a Seidio extended battery (3.7V 2400mAh). The battery is just about a few weeks old, and the Treo no longer reports the battery life remaining (the battery icon shows 0% with a exclamation '!' mark), despite it having been charged for some time. Cingular support suggested we download 'software updates' (there are none for this phone from what I can tell on the Palm site) and do a reset, but they wouldn't help more since it's an aftermarket battery. Any ideas?

    Thanks!
    You should not be having any of these problems with your battery. Please email me your information and I'll make sure you get a replacement.

    Thanks

Posting Permissions