Results 1 to 17 of 17
  1. jcalloway's Avatar
    Posts
    54 Posts
    Global Posts
    55 Global Posts
       #1  
    I have the system sound turned off, in sounds and notifications, and in Phone Alarm. However, every morning at 4:00 am when sprite backup resets my treo, the radio on sound is played. It doesn't bother me, but my wife is complaining. She is a light sleeper. If the phone radio is off to begin with, then the sound isn't played, because the treo doesn't turn the radio back on. Is there a hack for this? I checked the tweak type applications, but none offer this option.
  2. #2  
    You need to open file explorer, go to My Device/ Windows, and rename the audio file titled "RadioOn"
  3. jcalloway's Avatar
    Posts
    54 Posts
    Global Posts
    55 Global Posts
       #3  
    The rename, delete, and cut options are disabled. Do I need a 3rd party file explorer?
  4. #4  
    Quote Originally Posted by jcalloway View Post
    The rename, delete, and cut options are disabled. Do I need a 3rd party file explorer?
    Yes, sorry about that. Use Resco File Explorer. Those are ROM files and can't be altered w/the built in app
  5. #5  
    In your desktop, open the notepad, save as radioon.wav (save as type: all files), close the notepad. Copying the radioon.wav to \windows of your treo using activesync (\windows may not show up if you hide your system files in desktop.)
    Treo 750 unbranded T-mobile, HTC WIZARD 8125 T-MOBILE (broken), Treo 650 T-mobile 1.43/1.14 OS 5.4.8 Garnet (sold).
    Dell X50v, X30 624Mhz and HP ipaq h2210 h1945.

    Treo 750 hacks thread.
  6. jcalloway's Avatar
    Posts
    54 Posts
    Global Posts
    55 Global Posts
       #6  
    I was able to copy the dummy RadioOn file using ActivSync. Resco explorer could not rename or delete the file. However, I must not be as clever as I thought I was. Because the sound still plays each time sprite resets for the backup processing. I'm certain that the sound file is empty now. When I turn the radio off and on with the end button, no sound plays. What am I missing? Is there an editional .wav file I need to replace?
  7. #7  
    I think I figured it out.
    Use a registry editor and edit this:
    HKLM\SOFTWARE\PalmVarnish\DialLookupPlugin\PhoneStatus
    Edit this:
    "WelcomeSound"=RadioOn.wav
    Change it to:
    "WelcomeSound"=No Sound.wav (with a space.)

    No Sound.wav is already on there so just point the startup sound to it and viola!!
    No startup sound.
    I'm glad I found this thread. I've meaning to figure this out for the same reason, so I don't have to hear it when the phone turns on in the morning.

    Here's another fun fact!
    Delete "WelcomeImage"="CNG_RadioPowerOn.bmp"
    and you'll get the generic Palm 'on' screen instead of the Cingular Jack.
    Get a good AT&T logo wallpaper and you can substitute that if you want, or whatever picture you want.
  8. jcalloway's Avatar
    Posts
    54 Posts
    Global Posts
    55 Global Posts
       #8  
    I changed the registry. However the sound is still playing. I tried it with the dummy RadioOn.wav file, and with the original. I appreciate all the suggestions.
  9. #9  
    What? Really?
    It works for me. In fact I've been going through the registry and removing all of the annoying sounds this way. Camera shutter, Charger connect, memory card insert. So far they all work.
  10. jcalloway's Avatar
    Posts
    54 Posts
    Global Posts
    55 Global Posts
       #10  
    I double checked the registry setting. Maybe there is another registry entry specifically for the radio on. Because, if I turn the radio off, and then reset the treo, now sound is played. But if the radio is on, and I reset, the sound is played. I will poke around some this weekend. You have me on the right track.
  11. #11  
    That IS the registry setting specifically for the radio sound.
    Maybe the registry isn't getting written to persistent storage.
    What registry editor are you using?
    I'm using Resco Explorer.

    Try making the registry edit. Then Press and hold OK to bring up the memory manager. Stop all programs.
    Then press the "off" button (to put it in to standby) and leave it turned off for 15 seconds. I think it may save the registry.
    Then turn it back on, make sure you can turn the radio off and on with no sound.
    Now reset the Treo and see if it's still this way.
  12. holmes4's Avatar
    Posts
    982 Posts
    Global Posts
    984 Global Posts
    #12  
    I just tried the registry edit and (PHM RegEdit) and did a reset. No radio on sound. Oddly, I did get a notification sound a bit later (but no notification visible) - something I don't recall hearing before on a reset.
  13. #13  
    That notificaiton sound could be the card insert tone which plays right after bootup to signify mounting the memory card.
    Also if you have it connected to the charger during reset, you'll get that tone.

    When I'd do a reset, I'd get all 3. Card insert, charger connect, and radio on. I've disabled all 3 by replacing the sound files with "No Sound.wav."
    I also took care of the shutter sound on the camera.

    Finally I've got this thing quiet enough so that I can leave the volume up for the actual alarms and notifications that I want to hear.

    If your reg editor has a search feature. Search on .wav and .mid and you'll find all of the places in the registry where sounds are set.

    Here's where the card instert tone is:
    HKCU\Controlpanel\Volume\
    You'll see keys under there for charger connect, charger disconnect, SDInsert, and SDRemove
  14. holmes4's Avatar
    Posts
    982 Posts
    Global Posts
    984 Global Posts
    #14  
    Quote Originally Posted by taylorh View Post
    That notificaiton sound could be the card insert tone which plays right after bootup to signify mounting the memory card.
    Also if you have it connected to the charger during reset, you'll get that tone.
    Pretty much the right idea. I was hearing the SDInsert notification, which on my device anyway is different from the Power beep-beep. Following your instructions I silenced them both.

    Sprite Backup seems to have its own sound which I'm going to have to find....
  15. #15  
    Quote Originally Posted by holmes4 View Post
    Sprite Backup seems to have its own sound which I'm going to have to find....
    LOL. It seems never ending the number of things that want to make unnecessary sounds.
  16. holmes4's Avatar
    Posts
    982 Posts
    Global Posts
    984 Global Posts
    #16  
    Well, if Sprite has its own sound, I can't find it. Perhaps it plays one of the regular sounds.

    Oddly, after disabling the charger connect sound I don't get a vibrate when sliding the top switch to mute. The vibrator works otherwise. I don't know if this is connected.
  17. #17  
    Quote Originally Posted by holmes4 View Post
    Well, if Sprite has its own sound, I can't find it. Perhaps it plays one of the regular sounds.

    Oddly, after disabling the charger connect sound I don't get a vibrate when sliding the top switch to mute. The vibrator works otherwise. I don't know if this is connected.
    You're absolutely right. I no longer get a vibrate when I slide the switch. It appears this is related.
    Actually, I kind of like it not vibrating when I flip the switch. But that's me.
    Treo 750 (AT&T)
    Treo600->Treo650->Cing8525->Blackberry 8700c->Treo750->AT&T Tilt->Treo750->iPhone 3G

Posting Permissions