Results 1 to 11 of 11
  1.    #1  
    for those of us with the sprint version 700wx, one of our FEW bugs is the charging. when I wake up in the morning my green light is on saying I have a complete charge, but when I pull it of charge it says something like 92%. I don't know if this is completely due to the fact that I have a clock screen saver runing while in my desktop charger or not, but I never wake up with a full charge.

    I was woundering if anyone has wrote a script to over come this? I can think of a couple ways it could be wrote, but haven't tried anything. does anyone have any idea for a script? does anyone have a script like this? has anyone else noticed this problem? is anyone there?

    thanks, cody
  2. #2  
    hmm, you got it worse than I do. Mine at least says 98%. I'm not sure how you could fix that with a script since this value I think is read directly from the battery. I blew the meter on my battery once and my treo would only show a max of 5% charge even though the battery was fine and fully charged. I replaced the battery and all was good again.

    Ah, I see what you mean. You just want to take the value from the battery and scale it to 0-100 range and show on carrier line? Yeah, shouldn't be too hard.
    Last edited by hannip; 04/25/2007 at 04:31 PM.
  3. #3  
    I don't mind putting my two cents in on this one.

    WARNING!!!
    WARNING!!!
    WARNING!!!

    Do not try to muck with the battery or the charging.

    Overdischarging a lithium polymer/lithium ion battery could "kill" it. Overcharging a lithium polymer/lithium battery can kill it AND could cause a fire or small explosion or both.

    I know this from years of experience charging them and flying them in electric RC model planes. When they lose capacity, they're "done". When you think you can try and squeeze a few more electrons out of them or shove some more into them... if the chemistry ain't right... they either puff up and balloon into a mess of chewing gum or overheat and rupture and spew white smoke and spew fire.

    Don't trust me... see for yourself:

    http://www.rcgroups.com/forums/showthread.php?t=209187

    The examples may be of larger capacity cells, but the concepts are the same. 3.7V cells, lithium chemistry, special chargers, don't overcharge, don't over discharge.

    Here's a link to a video of someone purposefully overcharging.. in this case simply at the wrong voltage...

    http://www.rcstuff.us/battery/lipo/images/LipoFire.wmv

    If the "meter" says it's "done" the charging ckt shuts off.

    If you think it's still "good"... fix the meter.

    I've let the smoke out of one or two myself and tried to repair a few others.

    It ain't worth it.

    -- JDC

    (.. I may have totally missed your point, but hey, I like to hear my gums flap about this)
    Last edited by jdcochran; 04/25/2007 at 05:31 PM.
  4. #4  
    OK... I re-read the posts... you wanna fake your own brain... not your charger.

    OK, then.

    I retract the warnings as it relates to this script. Sorry for the horror show.

    -- JDC
  5.    #5  
    Quote Originally Posted by hannip View Post

    Ah, I see what you mean. You just want to take the value from the battery and scale it to 0-100 range and show on carrier line? Yeah, shouldn't be too hard.
    no, that was a different project. that was to easy. there is a reg somewhere like hklm system/state/battery that gives the perception. already at 0-100.

    I was thinking on something like ....

    while (1)
    if battery percentage = 100

    sleep for 1 hour

    reset

    endwhile

    this would allow only an hour of use from the full charge.
  6. #6  
    interesting idea..But I'm a little confused on why you would want your treo to sleep for an hour after full charge and start charging again..I must be missing something.Please explain in more detail.
  7.    #7  
    here is my theory.

    lets say I have a treo with a battery at 60%. I plug it in to charge at 10:00 pm as I go to bed. the charge is complete lets say at 1 am. at 1 am the charge light turns from red to green and the charging process stops. the treo is now running on battery and not ac. the power consumption from 1 am until 6:00 am is about 8%. when I wake up in the morning my light is green, if I take my stylus and tape the battery icon it will even say 100%, but as soon as I remove it from the charger... it goes to 92% or so. if I plug it in say midnight then at 6am it will be more towards 95% because it has been running on battery for a shorter time. if your like hannip and only sleep forr 4 hours a night, the it will be more like 98%.

    if I started a sleep for 1 hour and then reset the phone. charge would start again and keep the phone up to a more complete charge. this would at least only let it be on battery use for an hour at max. maybe givving me more like 98% - 99%. good enough for me.

    does this make more since sling?
  8. #8  
    hmm like JD said it seems pretty scarry.I myself have had green light come on when i first pluged in charger with 30%...unplugged and plugged back in to find the red light comes on and charging begins..What is my treo Telling me? My battery is going bad or charger.I replaced my batt and all is good.
  9.    #9  
    well I have 3 batteries. it does the same thing with all three. in fact this is my 3rd wx. thay all did it.

    i'm not trying to tweek anything. it would be really no different than you doing a memmaid clean at 5 am with a reset after the clean.
  10. #10  
    I've cosidered sumptin similar to this that runs at off hours. in my case, my memory gets close to maxed out to the pt. where I can't trust that the alarm app will wake me cuz theres no room for it to execute.

    so a "clean-up" script to kill the voicecmd.exe app, which is such a memory hog, would be nice.

    as for the battery... I don't think we can override or programmatically control the way the charger functions. but milking more juice with indirect procedures might be treading in that area of unknowns.

    jdc
  11. #11  
    Quote Originally Posted by codyppc View Post
    well I have 3 batteries. it does the same thing with all three. in fact this is my 3rd wx. thay all did it.

    i'm not trying to tweek anything. it would be really no different than you doing a memmaid clean at 5 am with a reset after the clean.
    True True.

Posting Permissions