Page 42 of 108 FirstFirst ... 3237383940414243444546475292 ... LastLast
Results 821 to 840 of 2146
  1.    #821  
    I thought Id give the user of TA an idea why on some models of the treo would not get sms blink at times.I will compare the 5.6 beta and the 5.6 complete scripts..keep in mind the 5.6 beta script is the exact same when it comes to the sms write as the 5.2 ,4.8 and so on.
    The write below is the 5.6 beta version

    # Keep SmS && Email counts at zero Count when notnotify
    TX = RegRead ("HKLM", "Software\Mort's MortScript\TREO ALERTS", "HMJ" )
    If ( TX = 0 )
    RegWriteDWord( "HKCU", "System\State\Messages\TotalEmail\Unread", "Count", 0 )
    RegWriteDWord( "HKCU", "System\State\Messages\sms\Unread", "Count", 0 )
    EndIf

    As you notice above there are regwriteDwords on both sms and email unread counts.If TX = 0 being a reg value that is pushed from
    --------------------------------------------------------------------------
    # turn off the led if any notifications are pending. Keep turning on each iteration since
    # the OS turns it off whenever there is a new notification.
    If ( Not Notify && ONOFF && LEDD )
    RegWriteDword ("HKLM", "Software\Mort's MortScript\TREO ALERTS", "HMJ", 0 )
    RegWriteDWord("HKLM", "Software\Mort's MortScript\TREO ALERTS", "CODE",0 )
    RunWait( "\Windows\LEDUp.exe", "0 1" )
    LedOn = TRUE
    EndI

    The script write above changes the value to 0 when there is no alerts present
    When TX turns to 0 it then controls script write below
    --------------------------------------------------------------------------
    # Keep SmS && Email counts at zero Count when notnotify
    TX = RegRead ("HKLM", "Software\Mort's MortScript\TREO ALERTS", "HMJ" )
    If ( TX = 0 )
    RegWriteDWord( "HKCU", "System\State\Messages\TotalEmail\Unread", "Count", 0 )
    RegWriteDWord( "HKCU", "System\State\Messages\sms\Unread", "Count", 0 )
    EndIf

    When script above hits 0 there is a push into the the sms and email folder that counts your text messages...it pushes and holds the value 0 all the time when you have no alerts present.We did this so when there was no alert present and you went into check your messages the blink did not start back up....This was bad news.When you get a sms message the OS pushes the count amount into that folder.What would happen is that value 0 that was being pushed and held all the time would not let up fast enough so when the OS put your sms count in that folder it would clear to 0
    That what was causing the sms not to blink

    ####################################################
    The FIX
    What it looks like in the new 5.6 Complete

    Pretty simple really.The script write below does no push the value 0 into you sms folder all the time and hold it.it only place a 0 in that folder when there is not alert present when you open up you sms inbox.if there is no alert and you check your sms the OS creates value change within you sms folder..it goes to how many sms message you have no looked at or dismissed.
    how did we prevnt that from happening

    #check the sms
    SM = RegRead ( "HKCU", "System\State\Messages\sms\Unread", "Count" )
    --------------------------------------------------------------------------
    The write above watchs that sms folder

    --------------------------------------------------------------------------
    #clear to zero if no notifications are pending when the inbox is opend
    If ( NOT Notify && SM )
    RegWriteDWord( "HKCU", "System\State\Messages\sms\Unread", "Count", 0 )
    Notify = FALSE
    EndIf
    --------------------------------------------------------------------------
    The #check the sms watchs your mail folder.If the mail folder get a sms count and there is no alert present it sends one hit into that folder to 0...just one hit then stops
    The script write above makes your treo work less,It saves you battery life and oh yeah.it alowes TREO AERT to work as one with your device.

    P.S
    oh yeah I forgot...it lets the sms alert blink in the carrier plugin
    Last edited by slingbox; 05/11/2007 at 03:15 PM. Reason: P.S
  2. Rino808's Avatar
    Posts
    338 Posts
    Global Posts
    347 Global Posts
    #822  
    hey sling is this in the new just posted update or will it be in the next update??? and as you know for the 750 it still misses the count from time to time with the update that was posted yesterday...but it does have or recognizes a notification, and alerts you but no count in sms...i know this is a really small problem if you want to call it that but i get multiple sms's a day...just like i think it was cody...where do we sent donations to for all of your hard work...cause i know that your burnning the mid-nite oil...i dont know how you find the tyme...thanks again i know that we all appreciate all that you and the others are dong for the treo community...
  3.    #823  
    dud it,s the mortscript ghost hehehe.send me a pm with your e-mail address.I need to send you a mscr file

    UPDATE..
    There is no mortscript ghost in Rinos,treo...Some call it the wm ghost
    We used a test mscr file and it worked on the incoming text message.then when he deleted or dismissed he should have heard a test sound but he did not hear a sound so his treo failed the test..I then instructed him to send a text message to his treo then follow the reg path to his sms unread folder and tell me the count.he had no count...there was no numbers to read.TA will not tell you your sms count if there is nothing to count..I instructed him his best bet would to do a hard reset on his treo..im finding 4 out of 4 users that are having isses with the 5,6 were using the 5.2.there were 41 download of that build...what does that mean??? That means if you are having issues getting the sms to work on the 5.6 and you had the 5.2 on your device give me a pm and i will set you up with a test.mscr file...
    Last edited by slingbox; 05/11/2007 at 06:39 PM.
  4. #824  
    can one of you guys that have to use the 5.2 because the 5.6 won't work right, send me a copy of your 5.2.

    email is codyppc at gmail dot com

    thanks, tring to figure this out.
  5.    #825  
    I would send it to you but i never used it..I used the first posted build.
  6. #826  
    Cody its in post 535 of this thread. Sling got your pm and yeah I did use 5.2. So that means a hard reset is needed to get 5.6 to work? Forgot Cody there is also the updated alert script from Hannip that I used for the dismiss of e-mails thats in post 553. Thanks for all the help guys really appreciate it.
  7. #827  
    Quote Originally Posted by kinger2 View Post
    Cody its in post 535 of this thread. Sling got your pm and yeah I did use 5.2. So that means a hard reset is needed to get 5.6 to work? Forgot Cody there is also the updated alert script from Hannip that I used for the dismiss of e-mails thats in post 553. Thanks for all the help guys really appreciate it.
    ok, so the cab you use is in 535 and updated alert control.mscr is in 553.

    is this where you got yours from as well rino808?
  8.    #828  
    Look this is a stupid conversation we are all having on why it does not work for a couple select members...If any uses the 5.6 to find that the sms does not work as expected your wrong..it does work!!!!! Ive sent over 300 text messages to my treo with all having sms blink in the last 3 days...this build has been tested over and over again...we have members in the above post that says it's working perfect for them as well. For all that are having sms issues dump the 5.2 version you had on you treo..preform a hardreset on your device and install the 5.6 and join the fun.
    If you still have a problem with sms blink after the hard reset please share the problem and a fix will be found..but it,s hard to fix if it isnt broke
    ________________________
    member over a ppc geeks....he is a 750 user

    mccune wrote:
    Simply great!

    Would just like to see the battery power without the option number [1] at the beginning of the line. But I must say for know that it's the most reliable notifier around here!

    boxt wrote:
    tap TA icon to take you to the alert settings menu.there will be a display choice tab..choose that and the display choice menu pops up.srolll all the way down through the display choices.you will see a set that has no [S] at the beginiing of them...choose the one you want that does not have the staus in front.
    Last edited by slingbox; 05/12/2007 at 12:39 PM. Reason: ps
  9. #829  
    Sling, just to let you know, did a hard reset and loaded everything back on. I am still getting sms issues. Some times I get them, some times I dont. Been trying to do tests to see what may be causing the issue. Might be some 3rd party software have loaded causing an issue. I don't know if it could be the threaded sms or what. Don't know if there is anything different between the 700wx and 700w besides the memory. For some reason version 5.2 gave me better notification on sms, but want to use 5.6 like the voice notification and you were saying that 5.2 eats up more battery. I will keep testing and try to find out what might be causing my problem. I will keep you informed.
  10.    #830  
    dont use the 5.6 then...there is nothing wrong with the 5.6 build.I cant help you though I wish i could...good luck
  11. #831  
    Sling, I never said that there was anything wrong with 5.6. I said i want to use 5.6 and that it was probally the 700w. I know that there is nothing wrong with treo alerts version 5.6. I was just trying to help find an answer to my problem in case someone down the road encounters the same thing.
  12. #832  
    Sling, Cody, check your email. There is a gift for you.
  13.    #833  
    thanks hannip
  14.    #834  
    Quote Originally Posted by kinger2 View Post
    Sling, I never said that there was anything wrong with 5.6. I said i want to use 5.6 and that it was probally the 700w. I know that there is nothing wrong with treo alerts version 5.6. I was just trying to help find an answer to my problem in case someone down the road encounters the same thing.
    I know kinger I was not trying to come off sarcastic yet I've eliminated the current build as being any way contributed to your issue.The only thing I can think of would be 3rd party software of some sort...maybe the threaded messaging ....dud i don't know..It's a little upsetting I cant help you find the answers you need.
  15.    #835  
    hannip check your e-mail..I just sent you a gift.
  16. Rino808's Avatar
    Posts
    338 Posts
    Global Posts
    347 Global Posts
    #836  
    wow where is our gifts? lol hey sling did you get my pm...
  17.    #837  
    when?
  18. #838  
    ahhh. my happy tc family is back again and giving gifts. thanks hannip and sling for your great work.

    now kinger,

    thanks you for being brave enough to hard reset. since you did all of this.ease just run the 5.6 for a day or so wirhout all your 3rd party stuff. then slowly, one at a time load the others.
  19. #839  
    Everytime Treo Alerts starts on my Treo750, it gives an error "A problem has occured with mortscript.exe. Any idea what that could be. I am using version 5.6. Also, when I install it, it says it might not work correctly as the software is for previous version of the Windows mobile os.

    Thanks.
  20.    #840  
    Yes You Need To Go To The Treo Alert Folder Located In Program File.OpenThe Folder Up And Tap The Mortscript.exe File Then Tap The Alert Control.mscr File.once Yuo Have Did This Go To Your Today Screen.few Seconds Later You Will Hear The Welcome Greeting..

Posting Permissions