Page 106 of 108 FirstFirst ... 65696101102103104105106107108 LastLast
Results 2,101 to 2,120 of 2146
  1. #2101  
    Quote Originally Posted by hannip View Post
    hmm, there is support for Flexmail alerts already. I wonder if they changed the guid since I added it. Can you check the value in the following registry entry when you have a new email alert from the OS (mail bubble at top of today screen)

    HKLM\System\State\Shell\Notifications\Active
    CLSID

    The value I have in TA is:
    "{1B70F4A6-F103-40A1-82EC-45CC19E46889}"
    With Flexmail notification I have the same as you wrote.

    When bubble is from bundled email app it is:
    "{A877D65A-239C-47A7-9304-0D347F580408}"

    With a new pop3 mail in FlexMail's "Local Folders/Inbox", I get a SMS=1 notice.
    Last edited by GyroDave; 09/05/2008 at 09:39 AM. Reason: Clarification...
  2. #2102  
    Quote Originally Posted by GyroDave View Post
    With Flexmail notification I have the same as you wrote.
    Did the LED blink for this one? I assume you had LED alerts enabled and email alert events enabled. If the CLSID was the same as what I posted it should be working. If it's not look closely at the CLSID value and make sure there aren't any differences. Also check for same upper or lower case letters.

    When bubble is from bundled email app it is:
    "{A877D65A-239C-47A7-9304-0D347F580408}"
    Yep, that's right.

    With a new pop3 mail in FlexMail's "Local Folders/Inbox", I get a SMS=1 notice.
    hmm, now that would be a FlexMail bug if it's using the text message guid for emails. And you are sure there weren't any pending sms messages along with that email?
  3. #2103  
    Thanks for looking into this with me.

    Quote Originally Posted by hannip View Post
    Did the LED blink for this one? I assume you had LED alerts enabled and email alert events enabled. If the CLSID was the same as what I posted it should be working. If it's not look closely at the CLSID value and make sure there aren't any differences. Also check for same upper or lower case letters.
    Since I've been travelling all over the last couple days and moving mail accounts between oem and Flexmail, I decided to re-run the tests after a reset...

    When Flexmail received an email tonight, I get the unique Flexmail "bubble", LED flash and reminder tones/vibe, but no voice or notice in "rotation" bar where date and weather info displays.

    When OEM mail client received an email 20 minutes later, I get the round "text bubble" that when tapped reveals both a Flexmail email bubble and the OEM email bubble, LED flash, reminder tones/vibe, Email=1 in rotation area and voice "Email pending"...


    Quote Originally Posted by hannip View Post
    hmm, now that would be a FlexMail bug if it's using the text message guid for emails. And you are sure there weren't any pending sms messages along with that email?
    At the time I was sure... -But tonight it doesn't happen. When I posted that I had the errant SMS notification yesterday, I looked at both oem and Flexmail's SMS and there were no unread sms...
  4. #2104  
    Quote Originally Posted by GyroDave View Post
    Thanks for looking into this with me.

    Since I've been travelling all over the last couple days and moving mail accounts between oem and Flexmail, I decided to re-run the tests after a reset...

    When Flexmail received an email tonight, I get the unique Flexmail "bubble", LED flash and reminder tones/vibe, but no voice or notice in "rotation" bar where date and weather info displays.
    Ah, this tells me that FlexMail must be using a separate unread counter than the OEM mail client. I wonder if it stores it in another registry value. I'll need to know where that is.

    Ok what I'll need is a dump of your registry before and after you get a FlexMail email notification so that I can do a diff between them. Or if you are so inclined you could do it using WinDiff. Use a registry editor to export the registry. I use Resco for that. In Resco you go to the top of the registry tree and click and hold on the root folder till a popup appears. Select Export and give it a file name. Repeat when you have a FlexMail alert pending. If you find the registry value that FlexMail uses for unread email counts post it here. Or if you want me to do it send both the registry files to hannip AT aol DOT com.


    When OEM mail client received an email 20 minutes later, I get the round "text bubble" that when tapped reveals both a Flexmail email bubble and the OEM email bubble, LED flash, reminder tones/vibe, Email=1 in rotation area and voice "Email pending"...




    At the time I was sure... -But tonight it doesn't happen. When I posted that I had the errant SMS notification yesterday, I looked at both oem and Flexmail's SMS and there were no unread sms...
  5. #2105  
    Quote Originally Posted by hannip View Post
    Ah, this tells me that FlexMail must be using a separate unread counter than the OEM mail client. I wonder if it stores it in another registry value. I'll need to know where that is.

    Ok what I'll need is a dump of your registry before and after you get a FlexMail email notification so that I can do a diff between them. Or if you are so inclined you could do it using WinDiff. ... If you find the registry value that FlexMail uses for unread email counts post it here.
    WinDiff showed several mis-matches but I think this one is the key:

    [HKEY_CURRENT_USER\Software\WebIS\Mail2\Storages\{00000000-0000-0000-0000-000000000000}]
    "TotalUnreadMessages"=dword:00000001
    "TotalMessages"=dword:00000025

    I have a few unique entries after "\Storages\" with the long "{xxxxxxxx...}" numbers. This is the only one that is all zeros.
  6. #2106  
    Quote Originally Posted by GyroDave View Post
    WinDiff showed several mis-matches but I think this one is the key:

    [HKEY_CURRENT_USER\Software\WebIS\Mail2\Storages\{00000000-0000-0000-0000-000000000000}]
    "TotalUnreadMessages"=dword:00000001
    "TotalMessages"=dword:00000025

    I have a few unique entries after "\Storages\" with the long "{xxxxxxxx...}" numbers. This is the only one that is all zeros.
    Good job. Try this version and let me know if it works.
    Attached Files Attached Files
  7. #2107  
    Quote Originally Posted by hannip View Post
    Good job. Try this version and let me know if it works.
    Thanks for the quick update... It worked once -see below- but I'm hopping we can improve on it??

    [HKEY_CURRENT_USER\Software\WebIS\Mail2\Storages\{00000000-0000-0000-0000-000000000000}]

    So I have gotten a TreoAlert "Email=X" notification one time so far when mail arrived that was un-affected by my "rule" ('message filter' in FlexMail-speak) that moves incomming messages to their unique folders. I got the TA only when an email landed in the parent "Inbox" folder.
    I believe those unique numbers inside these {xxx...} brackets correspond to the unique subfolders of the inbox That I have set-up. The one that's all zeros is (I think) "Inbox" and does show the correct unread messages total in the reg, but I do not get the TreoAlert when a message lands in any sub-folder.

    This is from my registry right now:
    [HKEY_CURRENT_USER\Software\WebIS\Mail2\Storages\{00000000-0000-0000-0000-000000000000}]
    "TotalMessages"=dword:0000003D
    "TotalUnreadMessages"=dword:00000002

    But I have no active Treo Alert... :-(
  8. #2108  
    Quote Originally Posted by GyroDave View Post
    Thanks for the quick update... It worked once -see below- but I'm hopping we can improve on it??

    [HKEY_CURRENT_USER\Software\WebIS\Mail2\Storages\{00000000-0000-0000-0000-000000000000}]

    So I have gotten a TreoAlert "Email=X" notification one time so far when mail arrived that was un-affected by my "rule" ('message filter' in FlexMail-speak) that moves incomming messages to their unique folders. I got the TA only when an email landed in the parent "Inbox" folder.
    I believe those unique numbers inside these {xxx...} brackets correspond to the unique subfolders of the inbox That I have set-up. The one that's all zeros is (I think) "Inbox" and does show the correct unread messages total in the reg, but I do not get the TreoAlert when a message lands in any sub-folder.

    This is from my registry right now:
    [HKEY_CURRENT_USER\Software\WebIS\Mail2\Storages\{00000000-0000-0000-0000-000000000000}]
    "TotalMessages"=dword:0000003D
    "TotalUnreadMessages"=dword:00000002

    But I have no active Treo Alert... :-(
    You should only get a flashing count when there is an active email notification bubble. Do you get one of those when your rule moves something to a subfolder?

    What I did was to grab the unread count when there is a notification bubble and place that in a separate location. This copied count is used by the program for Email= n display and reminder voice notification. When the bubble is cleared the count is zero'd if you have it set to do so in the configuration. When the next email notification bubble occurs the unread count is again copied and used.

    If the subfolders don't create an email notification bubble then TA can't detect it. BTW, the native mail app doesn't create a notification bubble for subfolders so I wouldn't be surprised if that's the way FlexMail works either. If you don't want the copied email count to zero when you dismiss a bubble you can turn that off in the configuration. Most people like that feature so that's why it works the way it does.
  9. #2109  
    Thanks for all your time and help!
    After many long nights trying practically everything I could think of, I'm throwing in the towel on Flexmail for now. I began looking for the "bubble" at the top of the screen after your last post and sometimes it was there, sometimes not.. I'd find emails 1/2 day late... -I didn't post for help at their site, so it could just be me, but I do see others posting with notification issues in FM4.

    I sure miss the email functionality of my 700P partnered with Butler. I'll really like the TreoAlert method and I'll keep looking for a better way to manage email on the 800w.
  10. #2110  
    I assume you tried to clean up your noification queue using PMClean or memmaid etc?

    Also if FlexMail is the window in focus it might not create a notification in that case. I know Palm sms works like that.
  11. #2111  
    I'm using TA on my Treo Pro and so far everything except Leds (to no surrprise) seems to work. It does however like the 750 need a ToggleDisplay(ON) for the reminders to sound.

    I also put in a couple of lines in REMIND,mscr to get voice notification with FlexMail 4.
    Code:
    EMC = RegRead ( "HKCU", "System\State\Messages\TotalEmail\Unread", "Count" )
    +
    +# Flexmail 4
    +ForEach FMStorage in regSubkeys ( "HKCU", "Software\WebIS\Mail2\Storages" )
    +EMC = EMC + RegRead ( "HKCU", "Software\WebIS\Mail2\Storages" \ FMStorage, "TotalUnreadMessages")
    +EndForEach
    +
    If ( EMC > 0 ) 
       PlaySound( myPath \ "SOUNDS\EMAILNEW.wav" )
    EndIf
  12. #2112  
    Quote Originally Posted by hannip View Post
    I assume you tried to clean up your noification queue using PMClean or memmaid etc?

    Also if FlexMail is the window in focus it might not create a notification in that case. I know Palm sms works like that.
    Thank you again.
    I did sanitize the queue but my Flexmail alerts were still random. I just concluded that this was a Flexmail issue after reading posts at their help forum. I'm (obviously) not a programmer, and I devoted a bunch of time trying to define and solve this to no avail. I needed to get on to other tasks, so I decided to cut and run with Palm os email for now.
  13. #2113  
    Quote Originally Posted by frause View Post
    I'm using TA on my Treo Pro and so far everything except Leds (to no surrprise) seems to work. It does however like the 750 need a ToggleDisplay(ON) for the reminders to sound.

    I also put in a couple of lines in REMIND,mscr to get voice notification with FlexMail 4.
    Code:
    EMC = RegRead ( "HKCU", "System\State\Messages\TotalEmail\Unread", "Count" )
    +
    +# Flexmail 4
    +ForEach FMStorage in regSubkeys ( "HKCU", "Software\WebIS\Mail2\Storages" )
    +EMC = EMC + RegRead ( "HKCU", "Software\WebIS\Mail2\Storages" \ FMStorage, "TotalUnreadMessages")
    +EndForEach
    +
    If ( EMC > 0 ) 
       PlaySound( myPath \ "SOUNDS\EMAILNEW.wav" )
    EndIf
    Hey frause, several things for you.

    For your FlexMail patch I see you are looping through all of the Storages subfolders. Does this give you an accurate count? I don't really understand how FM uses these subfolders, but I was assuming that the one with a guid that is all zeros was the one that had the totals for all the others. If that's not the case I need to fix the executable.

    Any chance I could get you to post the Treo Pro registry here or send it to me via email? My email address is hannip AT aol DOT com.

    For the LED not working try installing the attached LEDUp utility to find out what device id it is using for LED and vibrate.

    Thanks!
    Attached Files Attached Files
    Last edited by hannip; 09/24/2008 at 03:45 AM.
  14. #2114  
    Quote Originally Posted by hannip View Post
    Hey frause, several things for you.

    For your FlexMail patch I see you are looping through all of the Storages subfolders. Does this give you an accurate count? I don't really understand how FM uses these subfolders, but I was assuming that the one with a guid that is all zeros was the one that had the totals for all the others. If that's not the case I need to fix the executable.
    Yes, you need to check all storages. From what I gather, there is no total for all accounts. There's no "all zeros" storage either.

    I understand the mail storages and settings handling changed quite a bit between FM2007 and FM4. Maybe between the FM4 betas and FM4.01 too.
    Or the all zeroes storage is the Exchange account? I don't use Exchange, but could set up an account to test it if you want.
    EDIT: Wait, why would it need to do that? It makes no sense...

    Flexmail KB article about reading unread mail counts in FM4.

    Quote Originally Posted by hannip View Post
    Any chance I could get you to post the Treo Pro registry here or send it to me via email? My email address is hannip AT aol DOT com.
    Email sent.

    Quote Originally Posted by hannip View Post
    For the LED not working try installing the attached LEDUp utility to find out what device id it is using for LED and vibrate.
    It found two LEDs. LED #1 seems the vibrator and on LED #0 nothing happens.
    Last edited by frause; 09/24/2008 at 10:50 AM. Reason: Added link to FM KB article
  15. #2115  
    Quote Originally Posted by frause View Post
    Yes, you need to check all storages. From what I gather, there is no total for all accounts. There's no "all zeros" storage either.

    I understand the mail storages and settings handling changed quite a bit between FM2007 and FM4. Maybe between the FM4 betas and FM4.01 too.
    Or the all zeroes storage is the Exchange account? I don't use Exchange, but could set up an account to test it if you want.
    EDIT: Wait, why would it need to do that? It makes no sense...

    Flexmail KB article about reading unread mail counts in FM4.
    Cool. I'll update TA when I get a chance.


    Email sent.
    Thanks. It'll come in handy for customizing TA for the Pro.


    It found two LEDs. LED #1 seems the vibrator and on LED #0 nothing happens.
    Ugh, that's not good. These are suppose to be standard API's. #0 is suppose to turn on and off the notification led blink. Sounds like they didn't implement it on the Pro.
  16. #2116  
    Ugh, that's not good. These are suppose to be standard API's. #0 is suppose to turn on and off the notification led blink. Sounds like they didn't implement it on the Pro.
    I guess they don't want us to be in control of our blinkenlights then.
    In case you didn't know, the Pro has one red/green charging light and one white, voicemail-only slow blinking light under the Palm logo in the 5-way.

    For us whose carriers doesn't make use of the voicemail notification feature, and this doesn't seem all that unusual judging from a thread in the Treo Pro section, it would be sweet if TA could keep "HKCU/System/State/Messages/vmail/Total/Unread/Count" updated with all pending alerts. That way we could have a use for that now useless feature. Of course that might not work right for those that actually use voicemal notifications. And it's very hackish.

    I'm not missing LED notifications that much, but audible reminders... that is a must for me. In my varying (noise/vibrations/two-and-a-half-metres-in-the-air-juggling-500?-lighting-fixture-can't-answer-right-now) working enviroment I would be forgetting and missing missed calls and stuff all the time without it. Thank you very much for TreoAlert!
  17. KillerQ's Avatar
    Posts
    10 Posts
    Global Posts
    745 Global Posts
    #2117  
    Hey all,

    I am the proud new owner of an HTC 6800....coming from a Q9c. What difference! I used to use Don'tForget by SoftImage for reminders, but TreoAlerts is free!

    I have noticed that the audible sound won't work when the device is sleeping, just he vibrate. As soon as I hit the power button to wake it, the alert sounds... Anyone notice this?

    Thanks,

    Matt!
  18. #2118  
    Quote Originally Posted by KillerQ View Post
    I have noticed that the audible sound won't work when the device is sleeping, just he vibrate. As soon as I hit the power button to wake it, the alert sounds...
    Try setting "HKLM\SOFTWARE\Mort's MortScript\TREO ALERT\ToggleDisplay" to 1 in the registry.
  19. #2119  
    are there any plans to add different led color functionality for treo800w?
  20. #2120  
    Treo Pro - eagerly awaiting this offer, couldn't live without it on the 750.

    Also, looking to be able to call phone numbers listed in calendar or task entrys........can you hlep

    Thanks

Posting Permissions