Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 50
  1.    #21  
    Version 1.2 posted!
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."
  2. #22  
    Great job Scotty! I love it
  3. #23  
    Any new ideas on preventing the chime from waking the device?
  4. #24  
    Scotty,

    #Chimer.mscr Sound with no wake up

    %i% = 10
    if expression %i% > 1
    PlaySound "\Path\path\Alert.wav"
    sleep 100
    %i% = %i% -1
    endIf

    Put the the wav sound in folder

    Ive been using the code above to give repeat loop and single wav tone sound with no device wake up for months.
    You can give it a sample test if using the 700wx/w by downloading keylight timer script located next door.
  5.    #25  
    sling, is your script always running?

    also, you gotta get rid of that old syntax, those % signs hurt my eyes

    i = 10
    If (i > 1)
    PlaySound ("\Path\path\Alert.wav")
    Sleep (100)
    i = i -1
    EndIf

    EDIT -- Yeah, this only works if the script is continuously running. Chimer only runs when it needs to run by setting notifications in the notifications queue, and for whatever reason the device can't play the sound without waking up. It's essentially the same behavior as appointment notifications...your screen wakes up when you have an appointment reminder and it plays a sound...
    Last edited by scottymomo; 03/09/2007 at 12:58 PM.
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."
  6. #26  
    The script below plays only when called by timer.It does not wake up device or run in backround when not needed.It's used in Reminder1.1 as well

    #Chimer.mscr Sound with no wake up

    %i% = 10
    if expression %i% > 1
    PlaySound "\Path\path\Alert.wav"
    sleep 100
    %i% = %i% -1
    endIf

    Basically if you dont want your chime script to wake up device/Screen turning on wasting batt life the above script will get job done
    Last edited by slingbox; 03/09/2007 at 02:24 PM.
  7.    #27  
    right, but timer runs continuously right?
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."
  8. #28  
    Quote Originally Posted by scottymomo View Post

    EDIT -- Yeah, this only works if the script is continuously running. Chimer only runs when it needs to run by setting notifications in the notifications queue, and for whatever reason the device can't play the sound without waking up. It's essentially the same behavior as appointment notifications...your screen wakes up when you have an appointment reminder and it plays a sound...
    Wrong Scotty.
    It only runs when called kicking in Volume as well.
    So your eyes may hurt when looking at- %i%%i%%i%%i%%i%%i%%i% in your script But You will be saving the user of your outstanding work major battery life now.

    Adding,
    YOUR FIX BELOW
    Last edited by slingbox; 03/10/2007 at 12:48 AM. Reason: Adding,
  9. #29  
    Here is your no wake up fix.It works Perfect

    Enjoy

    Phil C
    ________________________________________________________________
    #
    # PlaySound.mscr - Plays the file of your choice at the volume of your choice
    #
    ErrorLevel ("syntax")

    #Read the value of the chime sound and volume from the INI file
    ChimeSound = IniRead(SystemPath("ScriptPath")\"Chimer.ini", "Settings", "ChimeSound")
    ChimeVolume = IniRead(SystemPath("ScriptPath")\"Chimer.ini", "Settings", "ChimeVolume")
    SetVolume(ChimeVolume)
    %i% = 10
    if expression %i% > 1
    PlaySound (ChimeSound)
    sleep 100
    %i% = %i% -1
    endIf
  10. #30  
    Sorry Sling, I don't believe in your voodoo code which you think is looping while not in a loop. lol

    Scotty, the reason the display is turning on is due to the ToggleDisplay(on) call in PlaySound.mscr. Not sure why that is there.

    Edit: Works perfectly by just commenting out the ToggleDisplay(on) call. Tested and the sound still plays, but with no display turned on. No need for any voodoo code. lol
    Last edited by hannip; 03/10/2007 at 09:08 AM.
  11. #31  
    Quote Originally Posted by hannip View Post
    Sorry Sling, I don't believe in your voodoo code which you think is looping while not in a loop. lol

    Scotty, the reason the display is turning on is due to the ToggleDisplay(on) call in PlaySound.mscr. Not sure why that is there.

    Edit: Works perfectly by just commenting out the ToggleDisplay(on) call. Tested and the sound still plays, but with no display turned on. No need for any voodoo code. lol
    Voodoo code. lol
    hannip funny
  12. #32  
    so should we be expecting a version 1.3???
  13. #33  
    Voodoo code. lol
    hannip funny
    hehe, it's all in good fun.

    BTW, where did you find that old code at in the first place. Just curious.
  14. #34  
    I know yoda.I must be going to the dark side of the mort force lol

    I found it in a dream.lol
  15.    #35  
    I added toggle display because on my phone it doesn't work if the screen doesn't turn on... couple thoughts... SPB Mobile shell is the cause or there is something different with the 750 (hannip, did you try with your 750)?
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."
  16. #36  
    Testing on 750 now. I'll let you know in 30 minutes if it works.
  17. #37  
    Quote Originally Posted by scottymomo View Post
    I added toggle display because on my phone it doesn't work if the screen doesn't turn on... couple thoughts... SPB Mobile shell is the cause or there is something different with the 750 (hannip, did you try with your 750)?
    Try the voodo code it works
  18. #38  
    Quote Originally Posted by slingbox View Post
    Try the voodo code it works
    The only thing about the voodoo code that might help is the sleep after the play call. That is if there is any issue at all. I know that some people have issue with the 750 where it won't play alarms from a deep sleep. It's a bug. Anyway, I'll let you know soon if it works.
  19. #39  
    Yep, the 750 did not alert. I'll try adding the sleep afterwards to see if that will help.
  20.    #40  
    maybe stick sleep in front first too... I knew I wasn't crazy
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."
Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions