Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 80
  1. #41  
    Quote Originally Posted by hannip View Post
    What I would prefer personally is if there were an option to open the bluetooth settings from TA 6.2 full. You know the same settings that you get when you click on the bt icon in there carrier bar. Just turning on bt is only part of what you need to do a lot of the time, at least for me. I know zbop had a way to open up the various settings. I'll dig around and try to find how to do it. If you are there zbop you can save me some time if you know off the top of your head.
    Heheh sure, this should bring up bluetooth settings:

    RunWait("\Windows\ctlpnl.exe", "cplmain.cpl,23")
  2. #42  
    hehe, I found it just now in one of jd's posts.

    http://discussion.treocentral.com/sh...&postcount=460

    Does that mean the bluetooth icons are in cplmain.cpl?

    Thx!
  3. #43  
    Quote Originally Posted by hannip View Post
    hehe, I found it just now in one of jd's posts.

    http://discussion.treocentral.com/sh...&postcount=460

    Does that mean the bluetooth icons are in cplmain.cpl?

    Thx!
    Not sure. That would kinda make sense so I doubt it
  4. #44  
    go guys go. find those pretty little icons. let me know when you do.
  5. #45  
    I FOUND THEM!

    They are in DialLookupPlugin_enUS.dll

    Coming your way cody.
  6. psywzrd's Avatar
    Posts
    455 Posts
    Global Posts
    476 Global Posts
    #46  
    Does the desire to have an easier way to turn bluetooth on or off (side button maybe?) have anything to do with your BT8010?
  7. #47  
    psywzrd, we were just trying to find a way to replace the carrier plugin without losing the bluetooth features that are available on the carrier plugin. Check out the Treo Alert 6.2 full edition that Cody recently posted.
  8. psywzrd's Avatar
    Posts
    455 Posts
    Global Posts
    476 Global Posts
    #48  
    Quote Originally Posted by hannip View Post
    psywzrd, we were just trying to find a way to replace the carrier plugin without losing the bluetooth features that are available on the carrier plugin. Check out the Treo Alert 6.2 full edition that Cody recently posted.

    Ah - gotcha. I thought it might have been related to the problems a lot of people (including myself) are having using the BT8010 with our Treos. I did download Treo Alert so I'm going to check it out. Thanks.

    BTW: Not sure if you saw my other post about Bluetooth problems over in the w/wx forum but someone suggested I PM you. Maybe you can check out the post and see what you think. Thanks.

    http://discussion.treocentral.com/sh...d.php?t=144159

    psy
    Last edited by psywzrd; 06/02/2007 at 07:58 PM.
  9. #49  
    hmm, I spent a lot of time trying to get a2dp to work and you want to stop it? lol

    What you could do is unload the bta2dp driver. You can use dotfred's taskmgr to do that. I'm not sure if there is a way to unload a driver via MortScript. I know zbop did something cool to unload a service via MortScript. Maybe he knows how to unload a driver the same way. Zbop?
  10. #50  
    Quote Originally Posted by hannip View Post
    hmm, I spent a lot of time trying to get a2dp to work and you want to stop it? lol

    What you could do is unload the bta2dp driver. You can use dotfred's taskmgr to do that. I'm not sure if there is a way to unload a driver via MortScript. I know zbop did something cool to unload a service via MortScript. Maybe he knows how to unload a driver the same way. Zbop?
    Yeah you can unload a service via command-line, but not a driver via MortScript/command-line. It's trivial to write some code to unload the driver, but even that is not guaranteed to work since there may be open references to the driver, or the driver may not support "unloading".

    This is the type of thing you would be able to do from MortScript *IF* I ever got around to writing that DLL-hooker
  11. psywzrd's Avatar
    Posts
    455 Posts
    Global Posts
    476 Global Posts
    #51  
    Quote Originally Posted by hannip View Post
    hmm, I spent a lot of time trying to get a2dp to work and you want to stop it? lol

    What you could do is unload the bta2dp driver. You can use dotfred's taskmgr to do that. I'm not sure if there is a way to unload a driver via MortScript. I know zbop did something cool to unload a service via MortScript. Maybe he knows how to unload a driver the same way. Zbop?
    I know, I know - I feel like an ingrate! It's just that I cannot get my BT8010 to work properly with my wx and I think this may be the only way until Palm figures out the proper way to implement bluetooth into their phones. I had a lengthy conversation with an engineer at Jabra and there's no doubt in my mind that the problem is on the Treo and not the headset. Jabra says that they're working on the issue but I don't think there's much they can do to get it to work with the Treo (more specifically, the 700wx). As long as the Treo is telling the headset to go into music mode, the headset doesn't have much choice but to listen. I did suggest to Jabra that perhaps there might be a way for them to allow you to disable music mode altogether on the BT8010 via the menu system but I don't know if that's even possible. Even if it is, it would require a firmware upgrade and I have no idea how long that would take. In the meantime, it's becoming increasingly difficult for me to resist the urge to throw both my Treo and my BT8010 out of my car window while traveling at a high rate of speed.
  12. psywzrd's Avatar
    Posts
    455 Posts
    Global Posts
    476 Global Posts
    #52  
    Quote Originally Posted by hannip View Post
    hmm, I spent a lot of time trying to get a2dp to work and you want to stop it? lol

    What you could do is unload the bta2dp driver. You can use dotfred's taskmgr to do that.
    Ok - I think I did this the right way but I want to make sure. Is the only thing I need to stop under devices? I see a device entry that is "$device\WAV8" and the dll for it is "bta2dp.dll". If I stop that, is that I need to do is there something else I need to stop as well? I do see something under the Services tab called Bluetooth Audio Gateway (BAG0). Do I need to stop that too?
  13. psywzrd's Avatar
    Posts
    455 Posts
    Global Posts
    476 Global Posts
    #53  
    Quote Originally Posted by psywzrd View Post
    Ok - I think I did this the right way but I want to make sure. Is the only thing I need to stop under devices? I see a device entry that is "$device\WAV8" and the dll for it is "bta2dp.dll". If I stop that, is that I need to do is there something else I need to stop as well? I do see something under the Services tab called Bluetooth Audio Gateway (BAG0). Do I need to stop that too?
    Looks like I answered my own question. Stopping bta2dp.dll seems to have done the trick. You guys are awesome! This should be a good stop-gap until Palm can figure out what the f*** they're doing. Thanks!!!
  14.    #54  
    Sorry folks. I was in Canada for 2 weeks. All my spare time was spent working. I logged 80 hrs last week.

    Tip for Treo Travelers: if you use Verizon in a country that Verizon covers, do not call them for customer support. They have no idea how their network works.

    As for using "my" code, sure. I post it here for pubic consumption.

    As for where I've been, see my premonition in post 23 of this thread.

    I tend to approach my projects bipolarly.

    I'll let you know when the next upswings.

    -- JDC
  15. #55  
    Lol Good To See You Jd.WE THOUGHT YOU LEFT US FOR
    MY TREO .COM
  16. #56  
    Ah, we missed you JD! I was getting worried. Glad to see everything is ok.
  17. #57  
    Is there a way to loop the phone portion of the script?

    With the VZW 700WX there is a known bug where the data portion of the phone gets "stuck" in the off position. A quick fix is to turn the phone "portion" off & then turn it on (not a soft reset).

    I have been saying:

    Start Phone Off

    Then

    Start Phone On

    Is there a way to just make it so it runs the first script (Phone Off), waits 10 seconds, then runs the second script (Phone On)

    Then I could say (Start Data) & it would turn the phone off, then turn it back on?
  18. #58  
    yes, I see if I can't wipe something out for ya later today. finally, I have something to work on. lol.

    been a little busy at work, but I am ready for a new script project. this one is easy.
  19. #59  
    Quote Originally Posted by RichTJ99 View Post
    Is there a way to loop the phone portion of the script?

    With the VZW 700WX there is a known bug where the data portion of the phone gets "stuck" in the off position. A quick fix is to turn the phone "portion" off & then turn it on (not a soft reset).

    I have been saying:

    Start Phone Off

    Then

    Start Phone On

    Is there a way to just make it so it runs the first script (Phone Off), waits 10 seconds, then runs the second script (Phone On)

    Then I could say (Start Data) & it would turn the phone off, then turn it back on?

    ok, here ya go. in the attached zip file is a script. this turns radio off, waits 10 seconds, and then turns radio back on.

    i put it in my windows/start menu/ programs folder and was able to use voice cammand to start. like you wanted i named it data so all you have to say is "start data" and it runs.

    enjoy

    cody
    Attached Files Attached Files
  20. #60  
    hehehe some JD style..Great job codeman
Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions