Results 1 to 7 of 7
  1.    #1  
    I have had my Treo 750 since January 7, and have had several of the "Treo 750 possible bugs" and the battery has not seemed to last as long as my previous Treo 650 battery.

    When I turned on the Treo yesterday morning it showed that the battery was at 26% battery after doing nothing all night(was at about 60% when I went to sleep), so I swapped batteries with a fully charged (Palm brand) battery, and put the original battery in the charger.

    Yesterday, suddenly, the battery began to drain rapidly for no apparent reason. During the day I was checking email, made and received a couple of short phone calls, played bubble popper, played around with google maps and surfed the net. On a usual day my battery might drop from 100% to 60-50% doing these things (beginning at about 6am and ending at about 10 pm).

    Yesterday at about 5pm the Treo was at 37% battery, so I switched batteries again with a fully charged (Palm brand) battery that had been charging since the morning.

    At about 9:30 last night the battery was at 36% after doing nothing all evening, so I switched the battery AGAIN with the fully charged Palm brand battery. Before I changed the battery I noticed that the Treo was unusually hot so I remove it from the silicon case that it lives in. The battery was hot when I removed it and so was the inside of the Treo. Within minutes of changing the battery it seemed cooler, so I thought it was going to be OK.

    This morning I tried to turn on the Treo but it did not respond so I removed the battery and put it back in-it immediately turned on, but the battery was at 17% (after doing nothing all night, with the phone, bluetooth, beam, and connection off, no programs running).

    I plugged in the Treo to charge (with all connections off, no programs running) and checked it after a few minutes-the battery was at 3% and it prompted me for a password (this is set to prompt me for a password after 1 hour, but it had only been a few minutes).

    The Treo is charging right now, and I am not sure what is causing this problem or what to do next. I'm not the most "techie" person, but something tells me that the Treo heating up when the battery drains is not a good thing....

    Anyone else have this problem? Any suggestions???
  2. sooby77's Avatar
    Posts
    256 Posts
    Global Posts
    331 Global Posts
    #2  
    I've never heard of this problem before. Usually to troubleshoot, it's either software or hardware. I would back up and then perform a hard reset and see if the problem persists with a clean device. Don't install anything yet. If it does, then you have a defective hardware.

    Most often than not, it's a software issue. Hope that helps.
  3. jahesh's Avatar
    Posts
    8 Posts
    Global Posts
    13 Global Posts
    #3  
    I'm getting terrible battery life too when UMTS is on. If I switch to GSM (Settings/Personal/Phone/Band) then the battery lasts much longer, but calls seem to drop much more often.
  4. B00001's Avatar
    Posts
    47 Posts
    Global Posts
    142 Global Posts
    #4  
    Go to your Inbox, go to menu-delivery prefs. Do you have the box checked to check your email every XX minutes? I did and it was killin my batt. Unchecked that box today but I think that was the root of the problem. We'll see.
  5. #5  
    Quote Originally Posted by b00001 View Post
    Go to your Inbox, go to menu-delivery prefs. Do you have the box checked to check your email every XX minutes? I did and it was killin my batt. Unchecked that box today but I think that was the root of the problem. We'll see.
    Wow this is INCREDIBLE!! I came from the 680 which had a horrible battery life so I figured the 750 was the same way. When I unchecked that box you mentioned my battery became about 3X as good as it previously was. MUCH better than the 680 in battery life now. THANKS!!

    1:45 pm and 90% battery left w/ > average usage. Normally I'm at about 50% by now.
  6. B00001's Avatar
    Posts
    47 Posts
    Global Posts
    142 Global Posts
    #6  
    Mine is working much better as well with the box unchecked. This time yesterday I was down in the 20's% range. Now I am at 66%. I have used the cell phone for about an hour so far today as well as checking mail, texting, and on the net. Weird thing, I still get my mail without manually having to check it.
  7.    #7  
    OK, I noticed that there are 2 places to check off how often the Treo 750 connects & checks for email. The first place is: go to email, menu, delivery preferences. The second place is: email, menu, tools, options, (pick one of your email accounts), under server info. go to options.

    I seem to use up battery faster if I have both boxes checked (maybe it connects and checks more often, or somehow becomes confused??).

Posting Permissions