Results 1 to 6 of 6
  1.    #1  
    The phone on my Treo 750v has suddenly gone kaput. I bought it on eBay from Hong Kong and have been using for a couple of weeks on the Vodafone network in Australia with no problems. Then a few days ago it showed up with "No Service" and searching for a connection: three dots under the phone symbol, no Internet connection either, etc. It's been the same ever since. My SIM card works in another phone so that's not the problem. Soft reset and hard reset haven't helped. Any ideas?
  2. #2  
    until someone offers a better idea, i suggest prayer and positive thinking... hope it works for ya. these kind of stories are the ones that make me decide i'd rather pay full price and get it direct! good luck!
  3. #3  
    I had this problem with a non vodafone sim. Tried a couple of hard resets and a restore from backup and everything worked again.
    Treo 750v ---> Now Sold.
  4. Zelig87's Avatar
    Posts
    49 Posts
    Global Posts
    56 Global Posts
    #4  
    Quote Originally Posted by philosophe View Post
    The phone on my Treo 750v has suddenly gone kaput. I bought it on eBay from Hong Kong and have been using for a couple of weeks on the Vodafone network in Australia with no problems. Then a few days ago it showed up with "No Service" and searching for a connection: three dots under the phone symbol, no Internet connection either, etc. It's been the same ever since. My SIM card works in another phone so that's not the problem. Soft reset and hard reset haven't helped. Any ideas?
    Just tossing out ideas here......

    What happens when you hold the RED key to turn the phone radio off (eg flight mode), then hold the RED key to turn the phone radio back on ?
    Does it come up with the dial pad to enter you SIM PIN code ? (assuming your SIM requires a PIN)

    Have you tried putting a different SIM card in the Treo 750 ?
    Last edited by Zelig87; 02/11/2007 at 08:56 PM.
  5.    #5  
    SpeedDemon: Sadly, multiple hard resets haven't helped.

    Zelig87: Turning the phone radio off and on leaves things back where they started, on the Today screen searching for a connection. There's no password on my SIM card. I just tried putting in a different SIM card, with the same results.
  6. #6  
    Mine died in four days,exact same symptom. Purchased from a company owned Cingular store; purchasing in HK may not have been the problem, but there may be a weakness in the radio section.
    Mike Caldwell

Posting Permissions