I have a problem with Google maps. After I open the application it gives me an error that says: "You must install a new version to use this program".

I have removed the program and reinstall it and still gives me that error.
Anybody else has that problem? Is it a compatibility issue with another program.
I had it to work briefly yesterday, but not now.
Appreciate any help.