Results 1 to 11 of 11
  1. holmes4's Avatar
    Posts
    982 Posts
    Global Posts
    984 Global Posts
       #1  
    I've used a Seidio Inno.Dock for over a year now with my 650, and the 650 would charge in the cradle to full.

    Now I have a 750 and the Inno.Dock Jr., which is said to be compatible with the 750. The USB cable is plugged directly into a "back of the PC" jack. The Treo says it is charging, but in fact the battery steadily discharges over the day. I charged it yesterday with the AC adapter, left it overnight, and it had 94% capacity the next morning. Now, having sat on the cradle nearly six hours, I'm down to 63% and falling. The Red charging LED is on and the Treo screen itself says charging, but clearly it is not. The Treo is on (backlight off) because ActiveSync keeps turning it back on even when I switch it off. The data connection is disconnected (and I have GPRS only in this area.)

    This is not what I expected. What is the experience of others?
  2. #2  
    I think I read in another thread here at TC that the 750 can't charge via USB. You'll need to get that $10.00 AC cable kit for the Inno.Dock.
  3. holmes4's Avatar
    Posts
    982 Posts
    Global Posts
    984 Global Posts
       #3  
    Those threads related to use of the Palm cable that lacks the power connector. The Inno.Dock is supposed to charge as well - at least it did for my 650.
  4. #4  
    I did read somewhere that some of the older palm Dock's wont charge the Treo 750 due to a voltage difference or something. Sorry, I cant quite remember. I just purchased the retractable USB sync/charge cable from Seidio and it works great. It does in fact charge and sync from the USB.
  5. #5  
    Quote Originally Posted by IsLNdbOi View Post
    I think I read in another thread here at TC that the 750 can't charge via USB. You'll need to get that $10.00 AC cable kit for the Inno.Dock.
    Not true. I am using a Lil' Sync Pro from PPCTechs to sync/charge with USB.
    PDA Lineage: Handspring Visor Deluxe, Visor Prism, Casio EM-500, Casio E-200, HP Jornada 568, IPAQ 1910,IPAQ 4150,Ipaq 2750 (with Moto Razr V3), Imate K-Jam,Treo 750,HTC Touch Cruise,HTC Touch Diamond(US)
  6. #6  
    same boat. my innodock won't charge my 750 even though it says it is. I have seen at least twice when it did actually charge (from like 95 to 100%) but I can't for the life of me figure out why it worked those times but 99% of the time it doesn't actually charge. Glad to see I'm not the only one..as I've mentioned it a few times in a few other threads
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."
  7. #7  
    Ah, well that's just what I read here and was offering as an explanation.
  8. holmes4's Avatar
    Posts
    982 Posts
    Global Posts
    984 Global Posts
       #8  
    Yes, but this is the new Seidio dock which they list as compatible with the 750 (at least Seidio tech support told me to buy this model - I already had the standard Inno.Dock) and say:
    The Seidio Inno.Dock Junior Desktop Cradle allows you to sync & charge your device with the case on. This model is compatible with most Treo devices.*
    The separate AC adapter appears to be for charging even when the PC is off, though the writeup is confusing. I will be very upset if "sync & charge" doesn't in fact mean that and I have to buy something else.

    I have a separate Sync and Charge USB cable which I'll try as well.
  9. holmes4's Avatar
    Posts
    982 Posts
    Global Posts
    984 Global Posts
       #9  
    Confirming - a separate "Sync and Charge" USB cable (not Seidio's) works fine. The Inno,Dock Jr. must be defective. I'm trying my old Inno.Dock to see what happens.
  10. #10  
    My innodock's the one I had from my 650. Still charges the 650 fine but not the 750
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."
  11. #11  
    So strange..like right now it was at 96% and now it charged to 100%..nothing has really changed..I'm stumped. I bet if I take it out of the charger, run it down a bit, then put it back it will not charge...we'll see..



    EDIT: Well, I didn't remove it from the charger but the light's no longer green and I'm at 98 and dropping...
    Last edited by scottymomo; 02/02/2007 at 07:27 PM.
    Palm III > HS Visor > Treo 600 > Treo 650 > Treo 750 > Treo Pro > PrePlus GSM

    "95% of all software issues are due to USER ERROR."

Posting Permissions