I've had email notifications turned off for a while now. When they were off, the only way to know that I had a new email was an incrementing count of unread email on the Today screen.

A few days ago, I set the email notification to be a short beep, so I'd be informed of new email as it came in. I only set the sound to play, and did not set the notification to display a message on screen.

Now, with every new email I get a message and the left soft key changes to show the new email.

I've once again disabled email notifications, but the display message still is displayed. How can I disable this ? Email notifications are off, as are Sync Data Received notifications.