Results 1 to 15 of 15
  1.    #1  
    I didn't drop my phone or anything, I was using tomtom navigator and a phone call came in, I picked it up and I couldnt hear the other party but they can hear me. I exited the program and tried calling back and same thing. Looks like my internal earpiece speaker is busted. Has anyone lese had problem with this? Would sprint replace the phone if i took it to the store, i am still under warranty and phone is only bout 4-5 months old.
  2. #2  
    Happened to me once with a 650, haven't goten it since.

    Sometimes its the headpone jack, as some have reported also. The phone always thinks yyou have an earpiece plugged in.
  3. #3  
    Providing your have insurance on the phone, they should repair or replace it for you on the spot. Providing you have a backup, you might try a hard reset to see if that fixes it to make sure its not a software issue.
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  4.    #4  
    Hard resetting is one of the first things i tried. I think i had headset plugged it b4 i had tomtom running so it might have to do something with that.
  5. #5  
    Try inserting and removing the headset jack several times to see if it fixes it. This was a known issue on the 650 that had to be fixed via a software hack or a hardware fix (soldering) once the problem began.
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  6.    #6  
    Quote Originally Posted by stroths View Post
    Try inserting and removing the headset jack several times to see if it fixes it. This was a known issue on the 650 that had to be fixed via a software hack or a hardware fix (soldering) once the problem began.
    You are the man!! I tried what you said and its workign now..saved me headache of dealing with dumb reps at sprint store. thanks
  7. #7  
    Glad I could be of assistance. If it becomes a recurring issue I would suggest exchanging it as its likely a defective jack.
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  8. #8  
    I've had to replace 3 treos b/c of the defective speaker. Customer support told me it was a manufacturing defect with no current solution. Verizon immediately shipped me a replacement (a new one after 3 replacements). I would have it replaced as it's more than likely going to happen again.

    Good Luck.
  9. tivoboy's Avatar
    Posts
    90 Posts
    Global Posts
    227 Global Posts
    #9  
    question. I have the same problem. Earpiece, no sound whatsoever. I have been using the sprint supplied earpiece on and off, now that it is off, the built in earpiece doesn't work. What is up with that?
  10. #10  
    I had the exact same problem last week...took the phone into a Sprint store and after an hour of waiting they swapped it for a brand new one. I had called the store in advance and asked if they had any refurb's in stock before going. Glad I have the TEP plan (albeit at $7/month). This was my second exchange... I wonder if I should drop the TEP plan now since odds are with a new phone (it had the updated ROM) that there might be fewer problems.
  11. tivoboy's Avatar
    Posts
    90 Posts
    Global Posts
    227 Global Posts
    #11  
    anyone know what the warranty on the phone should be? I've had it about three months.
  12. tivoboy's Avatar
    Posts
    90 Posts
    Global Posts
    227 Global Posts
    #12  
    So, I had this problem after using a wired headset. It was a third party headset, but same three ring 2.5, whatever. Earpiece stopped working. I don't have the spring insurance, but PALM said they would replace or repair, but I would be without for a week with no phone. I know, how hard would that be, but it is my only phone. So, I tried plugging in the sprint supplied headset, the palm one one more time, which worked fine, and then when I pulled out the headset, the EARPIECE had started to work again.

    Now, anyone think this was some software glitch, based on a hardware trigger, and Ishould be GOOD TO GO without having to have it fully fixed, or should I send it in anyway
  13. tivoboy's Avatar
    Posts
    90 Posts
    Global Posts
    227 Global Posts
    #13  
    well, it stopped again, so I have to send it back to PALM for a repair. Seems free, less shipping of course, but I won't have the phone for a week.
  14. #14  
    Headphone jack is broken common problem with Treo's exchange it if your still under warranty or insurance
  15. #15  
    My Treo 700WX had this happen after only having it for 3 weeks. Sprint replaced it with a new one. Now with the replacement after about two months I now have the same problem. Pushing the jack in and out didn't work. Sprint is sending me a replacement as I have their insurance plan. I dont use a wireless headset as I use the wired headset for stereo.

Posting Permissions