Results 1 to 13 of 13
  1.    #1  
    This is my first post, so hello everyone!

    I have the Cingular Treo 750 and am connected with unlimited data through UMTS. My work uses Microsoft Exchange for email and claims to have Exchange Server SP2. I have set up the activesync on my phone to receive email, calendar and tasks "as they arrive." The email gets to my treo about ten minutes after I receive the email at my laptop. The calendar and tasks do not come through at all. Also on the initial synchronization I instructed activesync to download the previous months worth of email but I only receive about three days worth.

    Has anyone been able to get Exchange ActiveSync to work well with their Treo 750? Any tips/advice? Hard reset?

    TIA
  2. #2  
    I have been able to sync everything but my calendar. Any help?
  3. #3  
    I was having no success at wirelessly syncing my Exchange Server with my 750v...and the server wasn't recognized while running Activesync on my PC with the Treo wired to the USB port.

    First, I installed the newest Activesync version, which was on my 750v installation disk, and went into the server configuration and deleted my earlier attempt to set up the server.

    I had a hard time figuring out the correct mail server settings, but I trusted someone else's post that said "use the address you go to for Outlook Web Access" (without the "http://" or anything after the "com"...just the xxxx.domainname.com). They were right - I set it up on my PC through Activesync while my Treo was connected via USB port and it clearly recognized the Exchange Server.

    Unfortunately, I got a new error after that...my server certificate was no good and I later read that WM 5.0 won't recognize "self-issued" certificates. So, I bought one at GoDaddy.com for about $35.00 for 2 years. Make sure it's for EXACTLY the same server name as what you're using in your Treo settings and then install it on your server and then export a copy in ".cer" format for you to install on your Treo.

    As soon as I got the certificate installed on my Treo, it immediately started syncing email, contacts, etc. and I was able to go into the settings on my Treo750 and choose which folders to sync, how far back in time to include, etc. There are option settings on the Treo 750 in both ActiveSync and Outlook that should be looked at to get what you want overall.

    All works perfectly now, except that Notes don't sync well - they got loaded up the first time, but after that they don't properly sync and I get a strange error when I first hook up my Treo to the PC via USB... something about not being able to log on and get information, but I cancel it and it then syncs fine after that (except for the notes problem, which isn't a big deal to me).

    I hope this helps someone - good luck!
  4. cortezi's Avatar
    Posts
    127 Posts
    Global Posts
    161 Global Posts
    #4  
    you can also copy the certificate (from your computer) that you get when logging into Outlook Web Access. I copied the 2 that I needed from Internet Explorer, installed on my 750 and sync'd immediately.
    cortez
    Xda Orbit 2 / Sprint Diamond / Samsung Epix / Touch HD
  5. #5  
    Quote Originally Posted by dcortez View Post
    you can also copy the certificate (from your computer) that you get when logging into Outlook Web Access. I copied the 2 that I needed from Internet Explorer, installed on my 750 and sync'd immediately.
    How would one go about doing that? Can you provide instructions for this?
    Maybe that will solve my issues as well.

    Thanks
    T750 w/Cingular
    Black Jawbone
  6. cortezi's Avatar
    Posts
    127 Posts
    Global Posts
    161 Global Posts
    #6  
    when you access webmail, generally you get a message informing you about a security certificate. from there click "View Certificate" and then click the "Details" tab. you'll need to select the correct mail certificate and then click "Copy to File" and a certificate export wizard will appear to export the certificates. after exporting, you copy the certificates to your phone and install. i know this is not much detail and i cannot remember all the steps. i used google to find more info, hopefully this will help.
    cortez
    Xda Orbit 2 / Sprint Diamond / Samsung Epix / Touch HD
  7.    #7  
    After first posting this without response, I have been on an adventure with Direct Push. While I am still not satisfied with the performance of Direct Push with my Treo 750 due to network architecture issues at my company, I can now answer many questions regarding Exchange ActiveSync Direct Push due to the amount of time I have spent trying to understand this problem.

    As for the "certificate is invalid on the server" error...

    It is very simple. Log into Outlook Web Access (OWA) on your computer using IE. Then go to "view security report" (there should be a little lock icon in your browser) and then view certificates. Most likely you will have a chain of certificates (use the certificate path tab) and for each cert in the chain you must individually "view certificate" and then go to the details tab and copy each certificate to a file using the default DER format. Once you have the DER file for each certificate in the chain, copy these files to your device (over usb) and then click each one to install. I installed in hierarchical order starting with the root CA (the top cert in the chain) and then working my way down through the intermediate certs. You must check the box in Mobile ActiveSync that says “this server requires an encrypted (SSL) connection.” If you have followed this procedure correctly you should now be able to connect without error.

    The problem of not receiving calendar, tasks, and/or inbox subfolders during a sync and no error message is displayed...

    My problem was that Calendar appointments and Tasks would not sync; nor would any of my 65 subfolders to the inbox sync even though I specified them to. Also if I requested a month of email history I would only get a few days. It turns out this problem is related to antivirus scan program on the Exchange server. For most AV programs the emails are placed in a queue to be scanned based on their priority. Inbox is highest priority, then subfolders, calendar, and tasks. When Mobile Activesync attempts to sync your folders it notices how many items it needs to sync but is unable to sync all items because Exchange will not let them go due to not being scanned. So it simply skips the ones that are not available and then maybe at a later date it will receive them if they have been scanned. However, if you go into OWA and then view the subfolder emails in the reading pane this forces a scan on that particular email and then you’ll notice that your device is able to sync the item. This is also true for calendar and tasks; open the calendar appt and/or task and then choose “save and close” and then these items will sync next time a sync is initiated. You can correct this issue by enabling “proactive scanning” in your AV program (on the server) or directly on the Exchange server (registry edit). We enabled this feature on our server and then all of my email, email subfolder, calendar appointments, and tasks synced perfectly but the next day we had massive “slow down” issues with our Exchange server (though maybe just coincidence) but now this feature has since been disabled and I am not receiving calendar, tasks, and subfolder emails.

    And last but not least, the problem that I have not been able to solve… PLEASE HELP WITH THIS ONE.

    I have enabled to receive all Exchange items “as they arrive” and this has never happened. My device initiated sync a random amount of minutes after receiving the email in Outlook. I have read that when working properly the device usually receives the item before outlook (similar to BlackBerry). By viewing the logs on my treo I can tell that the device is sending out a 360 second heartbeat and then syncs during every heartbeat cycle regardless of whether it needs to. I think that the connection is being dropped during the heartbeat interval and so Mobile ActiveSync just syncs to make sure that it didn’t miss anything. Our firewall timeout is set to 30 and 60 minutes for port 443 and 80 respectively. I haven’t been able to verify timeouts on all other net appliances yet. By looking in the registry of the treo I have found that 360 seconds is the minimum heartbeat that the device is allowed to sync. Since in theory the device dynamically picks the longest possible heartbeat based on imposed timeouts along the path from internet to Exchange, it appears that our timeout must be less than the minimum allowed by the phone. So, I modified the registry to allow as low as 60 second heartbeats just so that I could verify my theory to be correct but the phone began syncing once per minute and so I had to revert to the default because my battery could not take it.

    If anyone has any advice please let me know… Sorry for the long descriptions but hopefully this information may help others with similar problems.
  8.    #8  
    Quote Originally Posted by ggarrett View Post
    Since in theory the device dynamically picks the longest possible heartbeat based on imposed timeouts along the path from internet to Exchange, it appears that our timeout must be less than the minimum allowed by the phone.
    This path from Device to Exchange includes any firewalls that Cingular has in place on their data network. I have called twice and they are clueless when it comes to the timeout settings on their firewalls. They just keep transferring you until you get frustrated and hang up. One guy claimed there are not any timeouts in place but I find this hard to believe. Does anyone know the http inactivity timeout for Cingular's network firewalls?
  9. #9  
    I'm not getting any "certificate is invalid on the server" error on my 750 so that may not be my issue. But I'd like to try it anyways even though our IT guy says that we do not require any SSL in my server set up within ActiveSync.

    What I get is:

    ActiveSync encountered a problem on the server.
    Support code: 0x85010001

    I spoke with our IT guy and he thinks the following issue has occurred and I have to wait for him to handle this on his end.

    "Our mail server might have an issue where the exchange virtual directories for OMA are corrupted. In order to resolve this issue we need to reset the virtual directories and a reboot."
    Apparently this process requires a couple of hours of down time so I'm waiting for him to handle this after business hours so our GM does'nt kill me!

    As far as your instruction re:logging into OWA, I've logged in in IE but I don't see a little lock icon anywhere in my browser so that I can view the certificates. Is this because our server doesn't require any SSL?
    If you can help direct me to this it would be appreciated. Also, once I've located them you suggest copying each one to a file using the default DER format. Can you elaborate on this? Sorry I'm a bit green with the WM5 platform. I've been a POS guy for too long.

    Thanks,

    Greg
    T750 w/Cingular
    Black Jawbone
  10.    #10  
    I guess depending on your version of IE (i am using ie7 now) you may or may not see the "lock". However, after logging into OWA you should be able to right click the web page and then select properties. Next click the certificates button which opens the Certificate viewer window. This window consists of three tabs General, Details, and Certificate Path. Go to Certificate Path tab in order to see the certificates. Select the top certificate and then click the "view certificate" button. This opens another Certificate Viewer but this time you are viewing configuration of the top certificate. Now go to the Details tab of the new window and click the "Copy to File..." button. Now you will see the Certificate Export Wizard. Click next>(choose default DER format)next> enter a file name (name it such that you can tell which cert in the chain it is) and save location and click next again and then click finish. Your certificate will now be exported to the location you specified with the file name you specified (i.e. name.cer). You repeat this export process for ALL certificates that are in the chain of certs for your OWA. Once you have all the .cer files exported you will need to get these files onto the device. I used the usb cable to copy the files to the my documents folder on the device. You could also send as attachments through email to another account (gmail, yahoo, etc. ) that you can access on your phone. Once the files are on the phone navigate to them using the WM5 file explorer and click the files to install them to the root store on the device. When you click the .cer file it will ask if you are sure you want to install and then click yes. I installed them in order of top to bottom as they appear in the chain but this is probably not required. Once you have installed all of the required certs a good test is to go to (in your device's IE) the address you normally use for OWA except add a /OMA to the end (i.e. http://mail.yourcompany.com/oma) if mobile IE does not warn you about untrusted certificates then you installed them correctly.

    As far as your IT dept not requiring SSL on Exchange this just means that you have the option to connect without using SSL. I would recommend using SSL anyway so that your credentials are protected OTA.

    The 0x85010001 error is probably a problem with OWA or OMA like your IT guy said. Is OWA and OMA working when you browse to them on your computer? I got this error once when our entire exchange server was offline.
  11. #11  
    Quote Originally Posted by ggarrett View Post
    The 0x85010001 error is probably a problem with OWA or OMA like your IT guy said. Is OWA and OMA working when you browse to them on your computer? I got this error once when our entire exchange server was offline.
    Thanks for the detailed instructions. I am using IE7 and I have no problem accessing our exchange server via OWA on my pc. How would I know if OMA is working?
    If I right click on the web page, select properties and than click on the certificate I get the following pop up: "This type of document does not have a security certificate"
    T750 w/Cingular
    Black Jawbone
  12.    #12  
    It looks like your company is not using ssl for outlook web access. So in this case I would uncheck the "requires ssl connection" box in mobile activesync. As for Outlook Mobile Access (OMA), just browse to it in IE7 and if you can log in to see your emails, calendar etc then it is working. The address should be the same as the one you use for OWA but with /oma at the end. You can also access OMA on your mobile device the same way.
  13. #13  
    So I guess I'm back to square one and will have to wait for them to reset the virtual directories since adding any certificates isn't going to help the cause.

    I confirmed that I am able to access OMA so that does work as well.

    Thanks for the help.
    T750 w/Cingular
    Black Jawbone

Posting Permissions