Results 1 to 16 of 16
  1. gojeda's Avatar
    Posts
    93 Posts
    Global Posts
    104 Global Posts
       #1  
    Setup:
    Exchange 2003 SP2 with SSL installed
    700wx
    Activesync 4.2

    G'day,

    I am currently experiencing an issue with push email to my 700wx - in other words, it doesn't work.

    When I connect to my workstation, I can sync mail, contacts...etc directly against the Exchange server no problem. I bit on the slow side, but it works with no errors ever given.

    When I disconnect and attempt a wireless sync, it thinks for quite a while, then it eventually comes back with the following error:

    0x80072EE2: The server could not be reached. This can be caused by temporary network conditions.

    Well, its not so temporary it seems. I can neither sync wirelessly nor does push email work.

    The said Exchange Server is accessible to the outside world. I can use WM5 Messaging to hit it using IMAP4.

    I've also checked the user credentials under Active Directory. Since I am the admin, I have everything enabled.....and double checked it just to make sure.

    So, wireless sync nor push email works - any suggestions?
  2. #2  
    Do you use Outlook WebAccess? If so, do you have https configured for it?

    edit: this may not have anything to do with anything, i just had some free time at work here and was looking over this problem
    Last edited by doubleu; 01/05/2007 at 09:51 AM.
  3. z3bum's Avatar
    Posts
    717 Posts
    Global Posts
    723 Global Posts
    #3  
    Is https set in the Active Sync menu on the Treo? You may have to turn that off for now. Palm Os Treos with Versamail no longer support https if your certificate is home-made. (what ***** made that decison??) I think this is an attempt to force people to buy certificates as opposed to using the ones generated by Microsoft Certificate Services.
    Palm III -> Palm V -> Blue Palm Vx w/Omnisky -> Treo 270 -> Treo 600 -> Treo 650 -> Treo 680
  4. gojeda's Avatar
    Posts
    93 Posts
    Global Posts
    104 Global Posts
       #4  
    Quote Originally Posted by doubleu View Post
    Do you use Outlook WebAccess? If so, do you have https configured for it?

    edit: this may not have anything to do with anything, i just had some free time at work here and was looking over this problem
    Yes, I used OWA and I do have an SSL certificate installed from godaddy on it.

    I actually made some progress on this issue, kinda.

    What is happening now is that if I disable SSL on IIS and on the 700wx, push works. If I enable SSL on the IIS and on the 700wx, the connection times out on my 700wx, saying something to the effect that "this server is unreachable, this can be due to temporary network conditions".

    Well, its not temporary - and the server IS reachable because I can hit OWA just fine using https.
  5. gojeda's Avatar
    Posts
    93 Posts
    Global Posts
    104 Global Posts
       #5  
    Quote Originally Posted by z3bum View Post
    Is https set in the Active Sync menu on the Treo? You may have to turn that off for now. Palm Os Treos with Versamail no longer support https if your certificate is home-made. (what ***** made that decison??) I think this is an attempt to force people to buy certificates as opposed to using the ones generated by Microsoft Certificate Services.
    The certificate I am using was generated by godaddy.com. As mentioned before, I can hit OWA just fine using IE7 using SSL. But when the 700wx tries to access the Exchange server (over SLL that is), it times out.

    If SSL is disabled on IIS5 and on the Treo 700wx, push works perfectly.
    Last edited by gojeda; 01/05/2007 at 12:11 PM.
  6. #6  
    are you consistently getting the "0x80072EE2" error or a different one at all?
  7. gojeda's Avatar
    Posts
    93 Posts
    Global Posts
    104 Global Posts
       #7  
    Quote Originally Posted by doubleu View Post
    are you consistently getting the "0x80072EE2" error or a different one at all?
    Yes - if I enable SSL on IIS5, and then enable SSL on the 700wx, Activesync for Exchange will just time out. It will just sit at "looking for changes" until timing out. And when it finally does timesout, I get 0x80072EE2 without fail.

    Note: There must be some communication going on between the Treo and IIS because Activesync starts up and attempts to connect on its own. I am not sure this is because it is sensing a push, or it just connects at some set interval on its on.

    Anyway....as soon as I disable SSL on IIS5, and uncheck SSL on the 700wx - push/wireless sync works like a champ.
  8. #8  
    While Godaddy SSL works fine in Desktop IE and Outlook, WM 5 does not have the root certificate installed in it. To get around it, you will need to download root certificate from Godaddy and install it on the Treo.

    The best way to do so is to copy the root certificate on the SD card and install it from there. The installer program is available from Microsoft or Sprint/Verizon.
  9. gojeda's Avatar
    Posts
    93 Posts
    Global Posts
    104 Global Posts
       #9  
    Can I use the same root certificate I bought from godaddy? Or do I need to buy some Windows Mobile 5 specific certificate?
  10. #10  
    Quote Originally Posted by gojeda View Post
    Can I use the same root certificate I bought from godaddy? Or do I need to buy some Windows Mobile 5 specific certificate?
    You don't have to install the SSL that is on the server. You just need the root certificate. Just go to Godaddy.com logon and follow the link to download the root certificate based on the SSL you have on your server.
  11. #11  
    Hre is the link to Godaddy.com root certificates:

    https://certificates.starfieldtech.com/Repository.go
  12. #12  
    Here is how to install root cert from Godaddy.com to WM5:

    https://certificates.starfieldtech.c...install_mobile
  13. gojeda's Avatar
    Posts
    93 Posts
    Global Posts
    104 Global Posts
       #13  
    Thanks for your response Ford.

    As per that website you sent me, my particular version of WM5 already had the requisite Valicert SSL Root Certificate already installed. But just to make sure, I went ahead and deleted it, and reinstalled the root certificate off the website. No problems there.

    Then I went ahead and enabled SSL on IIS5 and chose SLL connection on activesync. Still no joy. I get one of two errors depending if I am wireless or not.

    Wired Activesync from the workstation, got this error:
    "Activesync eoncountered a problem on the server. Support Code: 85010014"

    Wireless Activesync gives me the same ol' error code 0x80072EE2 (Unable to reach server, can be temporary network condition).

    So now I am back to disabling SSL all around - and again, works like a champ.

    Apparently that 85010014 error is well known and, apparently, most of the solutions involve reinstalling or changing outlook settings and\or upgrading to Activesync 4.2.

    Well, Im not about to reinstall Outlook 2007 - and I can sync flawlessly against Outlook. The issue is syncing against Exchange 2k3 SP2 wirelessly over SSL via IIS5. I am pretty sure this is an IIS5 issue.

    Last edited by gojeda; 01/06/2007 at 12:54 AM.
  14. #14  
    Have you checked the eventlog in Exchange? I ended up following some instructions I found on MS's site about creating a new virtual folder/directory as outlined as "Method 2" under the "Resolution section". My problem was that I am using a single server to run everything Exchange needs (active Directory, IIS SSL, etc). This fix worked for me after hours upon hours of frustration.

    http://support.microsoft.com/kb/817379
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  15. gojeda's Avatar
    Posts
    93 Posts
    Global Posts
    104 Global Posts
       #15  
    Quote Originally Posted by stroths View Post
    Have you checked the eventlog in Exchange? I ended up following some instructions I found on MS's site about creating a new virtual folder/directory as outlined as "Method 2" under the "Resolution section". My problem was that I am using a single server to run everything Exchange needs (active Directory, IIS SSL, etc). This fix worked for me after hours upon hours of frustration.

    http://support.microsoft.com/kb/817379
    Thanks for the tip. Unfortunately, those step-by-step instructions are for IIS under Windows Server 2003. I am running Windows 2000 Server, so those instructions did not match up at all.

    I went ahead and backuped Exchange and deleted and reinstalled Exchange 2003. That went OK, but still SLL isnt working.

    I've spent so much time on this problem that now I am reinstalling Windows Server 2000 and Exchange 2003 from scratch. Lets see if that yields a different result. I'll report back later.

    Oh yes - I did check eventlog, and there were some errors in there regarding SSL which referred to the KB article you mentioned above. But as mentioned before, it didn't help me all that much.
  16. gojeda's Avatar
    Posts
    93 Posts
    Global Posts
    104 Global Posts
       #16  
    Oh - and btw Ford, what are the settings that need to be set under IIS? I still get the sneaking feeling this is an IIS issue, so when I try it again - I'd like to do it right the first time around after a fresh install.

    Much appreciated...

Posting Permissions