Page 1 of 2 12 LastLast
Results 1 to 20 of 26
  1.    #1  
    Okay, this is probably a wierd request because i havent seen it anywhere else:

    Is there a way to disable the onscreen pop up keyboard? I never use it and its nothing more than a minor annoyance popping up and shifting around stuff on my screen in certain apps.
  2. #2  
    Quote Originally Posted by makrotonik View Post
    Okay, this is probably a wierd request because i havent seen it anywhere else:

    Is there a way to disable the onscreen pop up keyboard? I never use it and its nothing more than a minor annoyance popping up and shifting around stuff on my screen in certain apps.
    there's a couple of ways...

    the easiest is to use SKTools and go under the Input Methods section. Simply disable what you want and soft-reset, done. Easy to reverse too.

    But you have to have at least one Input Method, so you'll need a "dummy" one to install. There was something on this at XDA but it's been awhile and I don't have the files/deets with me.

    WMExperts: News, Reviews & Podcasts + Twitter
  3.    #3  
    **EDIT** DO NOT make nullkeyboard your default input using sktools, it will crash your system. You have to select nullkeyboard after every reset for now.


    all i need was a nod in the right direction:
    voila

    If there were a pantheon of Winmob gods. You, sir malatesta, would be their messiah

    thanks
    Last edited by makrotonik; 11/21/2006 at 02:20 PM.
  4. #4  
    I agree nullkeyboard it the thing to use. I used it for a year on my PPC6700 and it saved me a lot of headaches.
  5. #5  
    Quote Originally Posted by makrotonik View Post
    all i need was a nod in the right direction:
    voila

    If there were a pantheon of Winmob gods. You, sir malatesta, would be their messiah

    thanks
    np!

    WMExperts: News, Reviews & Podcasts + Twitter
  6. #6  
    What am I missing?...

    I downloaded NullKB from the above link and installed on my Treo 750v. I see it now on the Settings --> Input list.
    I select it and click OK, but next time I got to Input it shows/defaults back to Keyboard. As if the NullKB won't stick.

    Any idea?

    Thanks!
  7. #7  
    You don't select it from settings, you select it on the command bar. There is a little keyboard in the middle of the command bar (bottom). Click on it. You will see a little up arrow. Click on it. Select NullKB.
  8. #8  
    I installed the nullkeyboard cab and it installed fine. I selected it by clicking the keyboard icon and it worked correctly. However, upon a soft reset it goes back to the default standard keyboard overlay. How do I force it to use the nullkb as default even after a soft reset?
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  9. #9  
    Quote Originally Posted by stroths View Post
    I installed the nullkeyboard cab and it installed fine. I selected it by clicking the keyboard icon and it worked correctly. However, upon a soft reset it goes back to the default standard keyboard overlay. How do I force it to use the nullkb as default even after a soft reset?
    I don't know how to do it manually, but if you use SKtools --> Input Methods it has the option to set one as the "default" keyboard, in this case the Null. You can also disable all the other ones from even loading (recommend for performance reasons).

    WMExperts: News, Reviews & Podcasts + Twitter
  10. #10  
    I tried the SKTools and set the nullkb as the default. It then automatically rebooted and went to a white screen after the Treo boot logo. Had to do a hard reset to fix. Luckily, I created a backup this morning, so all is good. Maybe I'll let the virtual kb stay for now.
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  11. #11  
    Quote Originally Posted by Malatesta View Post
    I don't know how to do it manually, but if you use SKtools --> Input Methods it has the option to set one as the "default" keyboard, in this case the Null. You can also disable all the other ones from even loading (recommend for performance reasons).
    Sorry Maletesta. This does not work. I tried doing this with both SK Tools and manually in the registry. It WILL crash your system when you reboot, if you make the NullKB the default.

    Problem is that since you can't make it the default, you must go in and reselect it from the command bar after each soft reset.

    I'm trying to solve it by creating a script using SKSchma, but have not perfected it yet. Of course, you need to have purchased SKSchema, to use the scripts it creates.

    Words of warning to all, SKTools and SKSchema are VERY powerful pieces of software. Make a backup of your whole phone before usiong any advanced functions.
    Daniel Levin
    levinda13@sbcglobal.net
  12. #12  
    ouch! sorry guys.

    WMExperts: News, Reviews & Podcasts + Twitter
  13.    #13  
    lol...so thats what crashed my treo this afternoon! I used sktool and attempted to set my default input to null and i got the white screen of death after a reboot! I really need to be more careful with reg edits. I'm also editing my original post so no one makes the same mistake. I'll reinstall the null keyboard and select it manually till someone makes a fix.
  14. #14  
    I did a google search and found a solution that works on my 700wx. I had no additional software to install and it works like a charm.

    Here's what I did.

    1. I found the following registry key - HKEY_CURRENT_USER\ControlPanel\Sip\AllowChange=1
    2. I changed the above value to AllowChange=0
    3. Soft Reset

    NOTE: To re-enable, change the registry key back to 1, reset again.
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  15. #15  
    stroths, no white-screen-of-death this time?

    Had the same white-screen-of-death today (same registry entry...) :-( too bad my backup was a week old.
  16. #16  
    I have not experienced the white screen with just the registry edit. I don't have SKTools or the null keyboard driver installed this time. Now I just have the keyboard icon at the bottom of the screen, but it does not popup or let me select it. I am a happy camper
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  17. #17  
    Since I (*now*) have a fresh backup (post whitescreen) I decided to test stroths's recommendation and it works great!
    Thanks.
  18.    #18  
    cool, as soon as i get home and restore - i'm going to give it a try. Someone should post all these hacks to a wiki!
  19. #19  
    Just out of curiosity...how to you use Ctrl-C/Ctrl-V now?

    That was one of the reasons I liked the SIP keyboard but if there is a work around (besides the stylus route, which doesn't always work) I'm all ears...

    WMExperts: News, Reviews & Podcasts + Twitter
  20. #20  
    I use my finger or the stylus for cut and paste. I don't use it a lot, but if I did I would use AE Button Plus to assign these functions to hotkeys.
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
Page 1 of 2 12 LastLast

Posting Permissions