Results 1 to 7 of 7
  1.    #1  
    I'm having a bit of an issue with the new Gmail mobile app, run from the IBM Java (IBM IVE on the 700w). When I install the app, it runs the first time flawlessly. When I logout and attempt to log back in, all i get is a blank screen. I have to delete and reinstall the Gmail app for it to work again.

    No, I'd believe it was the Java engine, but Google Maps works flawlessly all the time within the Java engine.

    In writing to Google, they've informed me that I have to change the preferences in the IBM Java app, but for the life of me, I can't figure out how to do it (an admittedly dumb question).

    Here's what they wrote back:

    "In order for the Gmail for mobile application to properly function on your Treo, the IBM JVM requires several configurations. Please review the following configuration settings on your Treo by visiting Preferences > "IBM Java VM":

    - Check "Use Double Buffering"
    - Check "Use high resolution coordinates"
    - Don't set anything for "HTTP Proxy"
    - Set "Memory maximum" to at least 4Mb
    - Set "Maximum java thread stack size" to 4kb"

    I can't figure out how to get there. Can someone please help?

    Thanks in advance!!!
  2. Widdy's Avatar
    Posts
    75 Posts
    Global Posts
    78 Global Posts
    #2  
    There are no preferences within the Java Machine App itself. If you look in the Treo preferences ("Prefs" when you hit the "Home" button) there you will see a new entry at the bottom for Java Preferences.

    Stumped me too for a while.
  3. #3  
    Those are the settings for the PalmOS java engine. To my knowledge, there is no settings screen to do that with the WM5 java version. I haven't tried the gmail app, but I did notice an issue with other java apps on my 700wx. If I get out of the app by clicking the OK button or exiting the app stays resident in the background and won't let me restart it.

    After you exit, try holding down the OK button to bring up the task manager. Kill all instances of the java app or midlet running. Try starting gmail again and see if it works correctly then. If it does, then the issue is the java app not shutting down completely.
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  4.    #4  
    Quote Originally Posted by stroths View Post
    Those are the settings for the PalmOS java engine. To my knowledge, there is no settings screen to do that with the WM5 java version. I haven't tried the gmail app, but I did notice an issue with other java apps on my 700wx. If I get out of the app by clicking the OK button or exiting the app stays resident in the background and won't let me restart it.

    After you exit, try holding down the OK button to bring up the task manager. Kill all instances of the java app or midlet running. Try starting gmail again and see if it works correctly then. If it does, then the issue is the java app not shutting down completely.
    Thanks for the clarification with the "Prefs" on the PalmOS - I thought I was going crazy.

    Even after exiting fully (no apps running) and restarting, it still does not work. Even after a soft reset I have no luck.

    Thanks to the both of you for the comments though, hopefully someoone else is also having the same problem.
  5. #5  
    I'm having the same problem. You have to reinstall every time you use it. I read a review somewhere (too lazy to google it out now) that says the same time.

    Basically reinstall to get it working again. But I have another issue. I can't install it through all the time. maybe once in 20 attempts. I keep getting incorrect byte size error. I gave up and uninstalled everything.
  6. #6  
    What version of Java are you using? There is a new 6.1 version out that may (or may not) help. Look at the thread below for details on getting the newer version and its limitations.

    http://discussion.treocentral.com/sh...d.php?t=128388
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  7. #7  
    hey guys, I tried unchecking the keep me logged in thing this morning to see what was up, and true enough, whenever I tried to log back in, it would not work. I had downloaded the gmail app the very first day it was released.

    So, what I did was i went to midlet manager this morning and selected the gmail app and went to actions->update. It might tell you it's the same version, just do it anyway. When it downloaded, it told me the file size was different than expected. But it ran anyways.

    And then it worked! Now I log off, log back on as another user, etc. It seems Google quietly released an upgrade (hence the size difference), so try redownloading the jad if necessary or try the upgrade procedure above and see.

    Edit: I'm using version 6.1, but since the app was previously failing as described, i don't believe that it matters.

Posting Permissions