Page 24 of 85 FirstFirst ... 1419202122232425262728293474 ... LastLast
Results 461 to 480 of 1700
  1. #461  
    Some progress. The 750's poutlook.exe fixes the problem of it taking over the sms on soft reset. No more having to rename the SMS folder in the registry. However, I don't see any UI differences in mail with it. I guess the new folder functionality must be in a dll someplace. At any rate it has a use so I'll post a cab to install it. If I figure out which dll gives the new functionality I'll update the cab later.
    Attached Files Attached Files
  2. #462  
    Quote Originally Posted by hannip View Post
    Some progress. The 750's poutlook.exe fixes the problem of it taking over the sms on soft reset. No more having to rename the SMS folder in the registry. However, I don't see any UI differences in mail with it. I guess the new folder functionality must be in a dll someplace. At any rate it has a use so I'll post a cab to install it. If I figure out which dll gives the new functionality I'll update the cab later.
    nice hannip. Keep up the great work!

    This is starting to make sense in regards to Palm's behavior to their WM mods: it's rarely just a single item but rather a bunch of little tweaks all tied together (like the infamous Carrier logo/contact lookup plugin). So just a matter of finding all the little pieces!

    WMExperts: News, Reviews & Podcasts + Twitter
  3. #463  
    Nice Hannip..
    Unless I'm mistaken, that somehow has stopped the Threading app from closing when you press up or back from the inbox. little baby steps but your getting there!! Thanks for all the work

    Blend

    Edit: Nope...sorry, it was from within a chat that it closed the program if you hit up or back...still does it
    Last edited by blend; 10/24/2006 at 01:43 AM.
  4. #464  
    yeah, I'm now thinking the new poutlook.exe isn't fixing anything. It was just a coincidence that it appeared to fix the problem. I do think I've figured out why poutlook sometimes takes over the text messaging. But time will tell. So there are two notification settings defined for text messages after installing the Palm Messaging cab. One is tied to the new sms app and the other is tied to poutlook. I think it is a race condition at boot that decides which notify will be used.

    This one is for the Palm threaded sms app:
    [HKEY_CURRENT_USER\ControlPanel\Notifications\{283E0018-E5C9-44e4-9864-4C4A3DED3BC3}]
    "Options"=dword:00000009
    "Wave"="\\Windows\\Treo Classic.mid"
    "VibrateWithRingerOff"=dword:00000001
    @="Messaging: New Message (Palm App)"
    "VibrateWithRingerOn"=dword:00000000
    "Duration"=dword:00000000
    "EventType"=dword:00000002

    This one is for poutlook sms:
    [HKEY_CURRENT_USER\ControlPanel\Notifications\{A877D65B-239C-47a7-9304-0D347F580408}]
    "Options"=dword:00000009
    "EventType"=dword:00000002
    "VibrateWithRingerOff"=dword:00000001
    "VibrateWithRingerOn"=dword:00000000
    "Wave"="\\Windows\\Alarm Triangle.mid"
    @="Messaging: New text message"
    "Duration"=dword:00000000

    I deleted the poutlook entries (these don't exist on the 750). I'll test it for a while and let you know, but it is working so far.

    Edit: ugh, poutlook still takes over sometimes, but it now uses the default alert sound. I still think there is some race condition at boot causing this problem.

    Maybe once I transfer all of the poutlook dll's from the 750 it will work.
    Enough fiddling for tonight...
    Last edited by hannip; 10/24/2006 at 02:23 AM.
  5. #465  
    Thanks for working on this.
  6. #466  
    So I couldn't stop fiddling

    Ok, so now I really believe I have a fix for the soft reset bug. The 750's tmail.exe app does not include a text message account like the 700's do. So there is no confusion where a text message goes to. I just have to figure out how to get the 750 version to load at boot.

    Ok I'm really done now. sleepy time!
  7. #467  
    Thanks for working on this for us
    Jimmie Geddes
  8. #468  
    Progress! thanks Hannip!
    I feel like you can figure this one out... can't wait!
    Thanks
  9.    #469  
    Quote Originally Posted by hannip View Post
    So I couldn't stop fiddling

    Ok, so now I really believe I have a fix for the soft reset bug. The 750's tmail.exe app does not include a text message account like the 700's do. So there is no confusion where a text message goes to. I just have to figure out how to get the 750 version to load at boot.

    Ok I'm really done now. sleepy time!
    What is the soft reset bug?

    I've soft reset a bunch of time and I'm not getting any bug like this at all. POutlook has not taken over at all.
  10. #470  
    Quote Originally Posted by gameboy213 View Post
    Progress! thanks Hannip!
    I feel like you can figure this one out... can't wait!
    Thanks
    We are getting closer. So the devices that don't get the sms delay in the chat window apparently are all using a later WM5 patch level than what's on our 700's. I think it's just a matter of figuring out which app or dll to copy over to fix the problem. We'll get there...
  11. #471  
    Quote Originally Posted by MHR View Post
    What is the soft reset bug?

    I've soft reset a bunch of time and I'm not getting any bug like this at all. POutlook has not taken over at all.
    Well the SMS folder in the registry seems to return on a softreset, at least for me and others that have reported the problem. This reenables the Text Message account on the mail app and depending on load order of tmail and the messaging app the first one loaded takes over the sms receiving.

    Maybe you have been very lucky.

    The 750 tmail app solves that problem.
  12. Fittske's Avatar
    Posts
    607 Posts
    Global Posts
    611 Global Posts
    #472  
    Hey hannip, some one at xda has a cingular rom for their up coming 750c. do you think this may help you out any?

    Read more here:
    http://discussion.treocentral.com/sh...d.php?t=126959
    "When Palm announced today that its new smartphone would run an operating system from Microsoft, it was the equivalent of Coca-Cola agreeing to fill its bottles with Pepsi." ~David M. Ewalt, Forbes Magazine
    ----------------------------------------------------
    My Phone history.....
  13. #473  
    Yeah I saw that. I think the apps installed on the cingular rom are the same, but the patch level is bit newer.
  14. #474  
    I've had a non-sms problem since I installed the first app. Everytime I try to use the ie shortcut(option+send) I get an error message...remap the button...same thing...no matter what I do it just jumps from button to button.
    Last edited by dpierre; 10/24/2006 at 03:24 PM.
  15. #475  
    thanks for the work hannip. keep it up
  16. kac
    kac is offline
    kac's Avatar
    Posts
    35 Posts
    #476  
    I too have the sms delay bug on my 700w but I did figure out a little trick.

    The delay is happening when you create a text to someone you already started a chat with. I noticed that if you create a "new" text from within the "outbox", it will go out without delay even if you do have a chat started.
  17. #477  
    Quote Originally Posted by dpierre View Post
    I've had a non-sms problem since I installed the first app. Everytime I try to use the ie shortcut(option+send) I get an error message...remap the button...same thing...no matter what I do it just jumps from button to button.
    Odd. It jumps right to PIE for me. I think on the 750 if you hit option+send it takes you to the messaging app, but I didn't think the reg changes in the cab install changed that.
  18. #478  
    I never had any problems with the option-send combo either. Strange.
  19. #479  
    So my plan of attack tonight is to create a new cab that
    installs all of the messaging related apps into its own install directory "\Program Files\Palm Messaging\". I'll include all of the system dll's it requires from the 750 to be installed in the same dir. I'll start the app from this dir so it uses the dll's in the same dir. My theory is this will fix the chat delay problem.

    If it works I'll start taking away system dll's until it breaks again to narrow down which files we actually need.
  20. #480  
    Well,.... we can wait for the 750w for Sprint, it seems like CompUSA will be getting them.
    Treo 700wx, Topram 4GB 150x

    Anyone want a Treo 700p for $430 ?

Posting Permissions