Page 1 of 2 12 LastLast
Results 1 to 20 of 34
  1.    #1  
    Hi All, some programs for my treo 700wx require net compact framework2.0.
    Questions:

    1. Where and how do I dowload 2.0?
    2. Are there any negative effects by downloading 2.0?
    3. Is it really needed or should I just stick with the current?

    Any help will be appreciated.
  2. #2  
    I believe the wx comes with the latest version (2.0). I say this as the application "On Demand" uses this to run. It does not impact the device or performance if you decide to reinstall it again. It basically overrides the installed version. Unless you can't run anything, I would leave it alone.
    Brian McGuire
    .../600/650/8700c/700w/Moto Q/700p/Nokia E62/700wx/8525/750c/BB Pearl/Blackjack/BB 8800/BB Curve & HTC Vox S710 >>iPhone
  3. #3  
    "On Demand" installs .Net CF 2.0 if you don't have it installed, but if you want to install it directly you can download it from here.

    http://www.microsoft.com/downloads/d...DisplayLang=en
  4. Pibe38's Avatar
    Posts
    483 Posts
    Global Posts
    653 Global Posts
    #4  
    There's also a CAB file for it on your Windows directory on your WX in case you don't want to install On Demand.
  5. #5  
    Quote Originally Posted by Pibe38 View Post
    There's also a CAB file for it on your Windows directory on your WX in case you don't want to install On Demand.
    I think this is put there by On Demand after it downloads CF for you. I didn't check before installing OD, but I know EXPRESS did this on my old wm phones also.

    (It's a good find when you go through the file explorer looking to free up memory. 2 MEGS right there!)
  6. Pibe38's Avatar
    Posts
    483 Posts
    Global Posts
    653 Global Posts
    #6  
    It's always there. I had to had reset once and installed .NET CF from that file without having to install On Demand.
  7. #7  
    I can't find the file in my 700WX's Windows Folder. What's the exact filename for Compact Framework 2.0?
  8. Pibe38's Avatar
    Posts
    483 Posts
    Global Posts
    653 Global Posts
    #8  
    Something like NETCFv20.wm.arm.XXX.CAB - at least that's how it starts.
  9. #9  
    I don't have any file in my Windows folder that starts with "NETCF".
  10. Pibe38's Avatar
    Posts
    483 Posts
    Global Posts
    653 Global Posts
    #10  
    Uhmmm weird... then just download it from MS' website posted above.
  11. #11  
    Can anyone else with a WX confirm that you have Compact Framework 2.0 in your 700WX's Windows folder?
  12. #12  
    Yes, I have it in my Windows directory. It is dated 9/4/06, which is the day I purchased the phone. I loaded ON DEMAND, but I don't think that I loaded it on the same day that I got the phone.
  13. #13  
    Ok I found it, but it wasn't there until after I ran On Demand for the first time.
  14. #14  
    I was under the impression that you could install 2.0 to your storage card to save device memory. Is this still true? I tried to install it to SD, but it ended up going into main memory for some reason.

    - Never mind - I found a post regarding this here.
    Last edited by Alienwhere; 10/15/2006 at 12:01 PM.
    END OF LINE
  15. #15  
    It seems like Treo WX came with .NET CF 1.0... And one of the application is requiring .NET CF 2.0 and sqlce3.0.. Someone please provide link to download those? Thanks!!

    BTW, you can check if you are running .NET CF 1.0 by running with file explorer file “cgautil.exe” in \Windows directory of your wx.
  16. #16  
    The link to download CF2.0 is posted above. My phone did not come with the file in the Windows directory either, and I'm sure most do not either.

    A newer AKU (3 I believe) is being shipped with CF 2.0 in ROM, but that doesn't apply to our devices
  17. #17  
    http://www.microsoft.com/downloads/d...DisplayLang=en
    link doesn't have a place to download CAB files for wx.

    I heard there's a newer verson (3).. anyone tried it..??
  18. #18  
    Quote Originally Posted by Dinomon View Post
    http://www.microsoft.com/downloads/d...DisplayLang=en
    link doesn't have a place to download CAB files for wx.

    I heard there's a newer verson (3).. anyone tried it..??
    Where? There's no newer version for ppc.

    WMExperts: News, Reviews & Podcasts + Twitter
  19. #19  
    CF for pocket PC is only up to 2.0. 3 might mean (AKU 3.0) which is an upate to the windows mobile OS. That can only be supplied via a firmware update from Palm.

    If you want an easy way to get it, go to start-programs-on demand. Let it install, then it will install CF 2.0, then you can uninstall it if you don't want it. CF stays on your device, and it leaves the cab behind in your /Windows directory
  20. #20  
    I tried running OnDemand on my wx today and it said I needed the .net 2CF, but it is installed and I ran OnDemand yesterday without this issue. I confirmed it was installed by looking in my "remove programs" and by running an app that requires .net 2CF. I ended up uninstalling .net and then letting OnDemand reinstall it which fixed the issue.
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
Page 1 of 2 12 LastLast

Posting Permissions