Treo 700w, and have it on Iusacell in Mexico.
However the username built into the firmware defaults to @vzw3g.com no matter what you put in the preferences.
I need it to be @iusacell3g.com to use the internet. Any suggestions? normal you change whit #*#data but no work


please help