Page 1 of 2 12 LastLast
Results 1 to 20 of 27
  1.    #1  
    Hey all,

    I was just curious due to the update, and being that the treo 700 is fairly new how many phones people have been through? I'm currently on my 3rd in about a month in a half. I'm wondereing if anyone else is having similar experiences with going through the phones quickly?
  2. #2  
    I'm on number 1. Not sure if my problems are phone specific and am quite sure they are not.
  3. Picasosz's Avatar
    Posts
    21 Posts
    Global Posts
    22 Global Posts
    #3  
    I am on the 5th one 1st one was returned within 14 days software compatibility (nothing worked when it was new) after most software was updated for the 240X240 screen I got my second 700w it had a defective Dpad the third phone was really good but an ***** at WTDS that did not know how wireless sync was supposed to work made me send it back because he could not fix the problem I was having (the problem was with wirelesssync software not hardware) the fourth phone would just hang up for no apparent reason no error messages no nothing. And now I am on the 5th Phone I have it updated and everything seems to be OK.
  4. #4  
    I am on my first since late January. Only hard reset once. Love this baby. But I just got my first scratches on it last week (freakin dropped out of my jacket pocket). I guess the scratches give it character. But still i cried like a little girl.
  5. #5  
    I'm on #2. Dropped it from my truck and the speaker stopped working...
  6. Souljer's Avatar
    Posts
    134 Posts
    Global Posts
    136 Global Posts
    #6  
    #1 for me also. With the exception of some of the usual issues, I'm all good.

    D
  7. naivete's Avatar
    Posts
    636 Posts
    Global Posts
    640 Global Posts
    #7  
    I'm still on #1, but I could be using a #2 or higher. That's because I got mine at discount from the Roadshow and rumor has it that those units were refurbished.
  8.    #8  
    I had my first one for about a month and it crashed during the update (to date the best I have had). Replaced it, 2nd worked completely fine for approximately 4 days, then would'nt complete a call, and actual earpiece on the phone stopped working. Got my third one today, and the earpiece is also defective. It sounds like it is already blown(new NOT REFURB). Anyone else have these problems, its interesting to see what issues people are having. Keep them coming.
  9. #9  
    Quote Originally Posted by lawrence.c.lee
    I am on my first since late January. Only hard reset once. Love this baby. But I just got my first scratches on it last week (freakin dropped out of my jacket pocket). I guess the scratches give it character. But still i cried like a little girl.
    I just vinyl skinned my new reburb; covers and protects.

    I'm on 650 number #2. The first one's keyboard started to malfunction.
    "Everyday is a Gift, A Blessing, An Opportunity!" - GM

    Phone history: Treo 600, Treo 650, Treo Centro, Pixi, Centro again, 800w, Treo 755p, Palm Pre
  10. #10  
    wait so if i have the insurance plan for verizon, and something happens to my phone, they don't give me a new one but they give me a refurbished one?
  11. #11  
    3rd one here. My last two lost the ability to pick up a signal, just outta nowhere. This one has been fine, and since the update, no issues. Much more stable, even with more apps installed than before.
  12.    #12  
    Quote Originally Posted by lawrence.c.lee
    wait so if i have the insurance plan for verizon, and something happens to my phone, they don't give me a new one but they give me a refurbished one?
    Yes, since the 700 is so new you are more than likely getting a new one, but WDTS told me that it was a 50/50 chance that I get a used one.
  13. #13  
    Quote Originally Posted by lawrence.c.lee
    wait so if i have the insurance plan for verizon, and something happens to my phone, they don't give me a new one but they give me a refurbished one?
    If you call Verizon's Wireless Data Technical Support team, they will replace your phone (1 year warranty). The refurbished units do not come with a battery or a battery cover, and you have to send your old/defective unit back. If you call Lockline, they will send you a new phone.
  14. #14  
    One only. Happy with all aspects so far.
  15. #15  
    #2 - only because Palm and VZW didn't understand how to resolve the Storage Card2 "problem" I figured it out after the replacement (new unit) arrived.
  16. #16  
    I'm on my 3rd, first one the EVDO modem broke(replaced by new one), 2nd one (refurb) the ear phone socket broke. The 3rd one has been very quirky since I did the firmware update, all sorts of random odd issues. Doesn't ignore calls sometimes if I hit end call or ignore. Sometimes the shortcuts in the Start menu mysteriously stop working then start working later. Somtimes the shortcut key to PIE option+send, says that the shortcut doesnt exist but if I use the shortcut in Programs it works. I've hard reset twice since the update and done 3-4 restores from Sprite. The last two days the phone seems to be fine with no issues.. go figure..
  17. #17  
    I'm on #5:

    - #1 was a Treo 180 and I traded that in for
    - #2 which was a Treo 300 which I dropped for a real phone (Moto 270C) then later bought
    - #3 a Treo 600 which I dropped quickly due to the lousy screen and no BT for a windows smartphone after which I tried
    - #4 a Treo 650 which had too little memory and too many crashes so I moved to an XV-6600, an SCH-i730 and then to
    - #5 a Treo 700W, which may get dropped for a return to my i730 if the memory and battery life problems aren't resolved.
  18. paulsg63's Avatar
    Posts
    75 Posts
    Global Posts
    76 Global Posts
    #18  
    Quote Originally Posted by JackondaRocks
    If you call Verizon's Wireless Data Technical Support team, they will replace your phone (1 year warranty). The refurbished units do not come with a battery or a battery cover, and you have to send your old/defective unit back. If you call Lockline, they will send you a new phone.
    What is Lockline???

    Sorry for my ignorance.

    Paul G
  19. #19  
    #2 for me. first one could not send e-mail. it was not a configuration issue - simply gave an error every time trying to send. 2nd one has been working fine.
  20. Cartman's Avatar
    Posts
    700 Posts
    Global Posts
    879 Global Posts
    #20  
    #3 for me...

    1st one had two dead pixels.
    2nd one had sticky left action button.
    3rd one.. the period sometimes doesn't work unless you push it autoritavely(sp?) but I can live with it....

    I've noticed a lot of other 700w's don't have as good of a tactile feedback from all the keys (especially the 5 way) as mine does so overall im happy with it.
Page 1 of 2 12 LastLast

Posting Permissions