Page 1 of 2 12 LastLast
Results 1 to 20 of 25
  1.    #1  
    Guys,

    I've recently switched from the 650 to the 700w. I pretty much agree with the review of the device from TreoCentral.

    Anyway, as I am new to WM5, I can't seem to figure out how to install a certificate for our Exchange server. I've tried a registry hack i found
    to disable verifiying the certificate, but that didn't work. Anyone have an idea how to get a self-signed certificate installed on their 700w?

    Thanks in advance.
  2. Cartman's Avatar
    Posts
    700 Posts
    Global Posts
    879 Global Posts
    #2  
    Dont have a root cert for the Exchange server? We ended up just using a root cert for the server to K.I.S.S
  3.    #3  
    Thanks for the response. We do have a root cert for the Exchange server, I just can't get the 700w to install it. I get an error message saying: "The security certificate on this server is invalid. Contact your Exchange Server Administrator or ISP to install a valid certificate on the server. Support code: 80072f0d"

    From what I have read from around, the above error message is because we signed our own certificate as opposed to using one from a certificate authority.

    I'd like to get my 700w to either accept this certificate, or bypass the need for a certificate so that I can use the Exchange ActiveSync.

    Any help would be appreciated.

    Thanks in advance.
  4. HalM's Avatar
    Posts
    86 Posts
    Global Posts
    134 Global Posts
    #4  
    Unlike WM3, the DisableCert utility has no effect on WM5. You will have to export and install the certificate from your Exchange server for ActiveSync to work. Google the topic and I am sure you will find the directions.
  5. HalM's Avatar
    Posts
    86 Posts
    Global Posts
    134 Global Posts
    #5  
    BTW, start here:
    http://spaces.msn.com/members/xpworld/Blog/cns!1pwLVDaHQF6ltiEJslNeKRkA!198.entry

    I have read on another forum that this will work on the 700w.
  6. #6  
    This is pretty easy to do. Export the website certificate from the machine that has it installed as will act as the server you synchronize with. This could be your Exchange server proper or a front-end Exchange server.. .just depends on your configuration. Regardless, from within IIS manager on that box, export the website's certificate as a .cer file and then once you have the file in hand, transfer it over to the Treo. Using File Explorer on the treo 'double-click' on the .cer file and you'll be prompted as to whether or not you want to install the certificat into the root store of the phone. Accept the dialog, and you're done. Try syncing again and it should now work OK.

    This is all I had to do to get my phone synchronizing with our Exchange server at work.
    Whitney Roberts
  7.    #7  
    Thanks for all your suggestions.

    Following AllCammedUp's instructions proved to be easy and effective. I now have my email/contacts/calendar sync'd with our exchange server, although it did duplicate all of my data

    Oh well.

    Thanks again.
  8. #8  
    what about if you have this issue but cannot log onto the server (as in you are not the IT admin)? Are there other ways to obtain the cert?
  9. #9  
    I had the same error message when I tried to get the 700 to connect to our exchange server. We run GoodLink but I wanted to try out the exhange push everyone was talking about.

    I ended up just downloading GL and moving on. Has anyone used both GL and the exchane push? If so, can anyone tell me if the WM5 exchange push works as well as Good?

    Thanks.
  10. HalM's Avatar
    Posts
    86 Posts
    Global Posts
    134 Global Posts
    #10  
    Quote Originally Posted by bsamini
    I ended up just downloading GL and moving on. Has anyone used both GL and the exchane push? If so, can anyone tell me if the WM5 exchange push works as well as Good?

    Thanks.
    Good is good, especially if you are still running Exchange 5.5 or Exchange 2000. However the pro's and con's blurr real fast if you have Exchange 2003. The big difference if you have Exchange 2003? That is easy: $$$. Exchange ActiveSync is FREE.

    BTW, I just read on another forum that Qtec has announced that they are releasing their AKU2.0 ROM in early February. Only then can your question be answered with facts, not whitepapers and hype.
  11. #11  
    Main thing is Exchange doesn't do push yet. Secondly, based on what we have read, there are several more differences between Exchange's push (when released) and GoodLink, but until we see what the product actually has when released, I'd rather not speculate.
  12. #12  
    Thanks Good Guy. GL has been so reliable and required almost no support after our initial set up that we are not even considering using the exchange sync function. Since the 700w wasn't supported by GL at launch, I wanted to try out the exchange sync while we waited.

    Hope the GL product for the 700w comes out soon.
  13. #13  
    Hi guys,

    I had the same problem with one of my users since we were using Startcom's free SSL cert service. All I had to do was follow AllCammedUP's suggestions and I was done. There was no reg hacking or anything else that needed to be done. So the link posted by HalM wasn't necessary. With all the links around, it was getting quite confusing as to what actually needed to be done to make this work.

    So to sum up, I exported the main cert and intermediate certs for my particular key (from my front-end Exchange server) and sent them to the user running the Treo. She simply installed each one which automatically installed to her local store and she was instantly able to sync with our Ex2k3 box.

    Thanks everyone.
  14. HalM's Avatar
    Posts
    86 Posts
    Global Posts
    134 Global Posts
    #14  
    Kazamali, you are 100% correct. The procedure I outlined is needed with Smartphones, as opposed to PPC's such as the 700w. What I do find interesting is that for me this was a "hit or miss" proposition. Sometimes the certs would say they installed but I could not sync and sometimes they would show up as root certs and I still could not sync. Following other hard resets, they would go right in. I never got a handle on why sometimes they would or wouldn't install.
  15. #15  
    I have our certificate installed on the 700w, but it still won't sync. It's like it doesn't see the certificate even though its listed. The web address for our front end server is what I have always used for everything else (OWA, OMA and RPC over HTTP), but it won't work for AS. I am install SP2 on our Exchange servers tonight and I hope that fixes it. We had to hold off installing SP2 because of Blackberry's and them not offically supporting it. Anyone have any ideas?
  16. HalM's Avatar
    Posts
    86 Posts
    Global Posts
    134 Global Posts
    #16  
    Creeper, see my post above yours. You might try reading and doing what I posted on 1/11 also in this thread. It works like a charm on WM5 Smartphone edition. I know that they are not the same OS's but it certainly would be worth the 10-15 minutes to give it a try.
  17. #17  
    The 700w lets you install certificates by clicking on them. I copied our cert to it via the usb cable and once it installed it showed up under root certificates. Does the hack outlined by you do something else?
  18. HalM's Avatar
    Posts
    86 Posts
    Global Posts
    134 Global Posts
    #18  
    Yes. If you follow the steps, it "application" unlocks the phone. That might help. And as I said, I saw the same behavior without the hack. One thing thatworked for me was to re-export the certificate with a different file name and then install the new one as well. That might work as well.
  19. #19  
    Quote Originally Posted by Creeper
    I have our certificate installed on the 700w, but it still won't sync. It's like it doesn't see the certificate even though its listed. The web address for our front end server is what I have always used for everything else (OWA, OMA and RPC over HTTP), but it won't work for AS. I am install SP2 on our Exchange servers tonight and I hope that fixes it. We had to hold off installing SP2 because of Blackberry's and them not offically supporting it. Anyone have any ideas?
    Have you tried to do a soft reset (turn off your phone for 1 min)?

    This is what I have done to make my work:

    On Server side:
    1-Exchange certificate must match mail server name, i.e.: mail.myserver.com;
    2-Make sure to follow instructions of KB817379 to create second key;
    3-Reboot Server;
    4-Attempt to connect to webmail and make sure no errors occur;
    5-Export certificate and upload on device;

    On Device:
    1-Create Exchange ActiveSync account with username, password, email;
    2-Make sure you choose SSL port 443;(my case, I have port 80 blocked)
    3-Sync certificate into phone and install it;
    4-Reboot device;

    hope this will help! I'm going to celebrate tonight lol
  20. #20  
    I didn't want to deal with the registry hacks and AllCammedUp's instructions weren't working for me either. I don't know if it's because of the specific certificate we have installed on our server or what. Our cert is from Equifax Secure Inc and is recognized my most browsers without any issues. To get it working with our exchange server and ActiveSync here is what I had to do.

    1) Export the certificate from our web frontend echange server as a .PFX file. To do this I logged into our server, opened IIS Admin, selected Properties for the site with the cert installed, selected the "Directory Security" tab, clicked "View Certificate", clicked the Details tab, then clicked "Copy to file". The Certifcate Export Wizard then started up, click next, select "Yes, export the private key" and click next, I checked the "Include all certs" and "enable strong protection" options and clicked next, type a password to protect the file and click next, type a name and location to retrieve the file and click next, then click finish. Copy this servername.pfx to a location on your 700w, I don't think it matters what directory you copy it to.

    2) Download this program and copy the .exe to your 700w. I copied it to \Windows\Start Menu\Programs, but again, I don't think it matters.

    http://www.jacco2.dds.nl/networking/p12imprt.html

    3) On the Treo, run p12import, browse to the .pfx file you copied, type in your password, and tap "import certificate".

    4) That's it. I didn't even need to do a soft reset. ActiveSync ran without any problems.

    Hope that helps for a few of you.
Page 1 of 2 12 LastLast

Posting Permissions