Page 6 of 36 FirstFirst 123456789101116 ... LastLast
Results 101 to 120 of 718
Like Tree78Likes
  1. #101  
    Quote Originally Posted by John Steffes View Post
    Ok so here is a script removing/adding the following:

    Added: pmwifidriver back (to get wifi working)...

    Removed: baseimage dspmon-omap34xx jpegdecodelib-omap34xx marvell8686microap omxclientlib-omap34xx

    and (from previous script attempt)

    luna-keymaps palmjpgencsink-omap34xx palmvideodecoder-omap34xx palmvideoencoder-omap34xx palmvideosink-omap34xx pmlegacyhcilinklayer tidspbridge-extra tidspbridge-lib tidspbridge-module tidspbridge-mpusamples tiopenmax-aacdec tiopenmax-aacenc tiopenmax-clock tiopenmax-common tiopenmax-core tiopenmax-inst2 tiopenmax-jpegdec tiopenmax-jpegenc tiopenmax-lcml tiopenmax-nbamrdec tiopenmax-pcmdec tiopenmax-policymanager tiopenmax-postproc tiopenmax-prepostproc tiopenmax-ram tiopenmax-resourcemanager tiopenmax-rmproxy tiopenmax-videodec tiopenmax-videoenc

    Leaving:
    bootloader kernel-dev kernel-module-oprofile kernel-module-scsi-wait-scan luna-prefs palmbuildinfo pmtpupdater camd-omap34xx camsrc-omap34xx castletpfw kernel-image-2.6.24-palm-joplin-3430 kernel-module-ecb kernel-module-ifb kernel-module-nbd kernel-module-pcbc pmwifidriver pmmedia-omap34xx tisgxgfx updatefsinfo bootie-images trenchcoat compcache

    Now see if this works?

    The next modules to test would be the ones that I think need to stay... but removing one at a time rebuild doctor, flash, and did it work? just because we have things working, does not mean they will work 100%, want only the 2.1.0 modules we need to make it work no more no less...
    Pushed matching updates to all three scripts in git.

    Testing on -wr now.

    Video - Check
    Music - Check
    WiFi - Check
    Touch Screen - Check
    USB - Check
    Skype - Check
    Camera: Photo & Video - Check

    Next, /etc/palm-build-info masquerading needs to happen so Preware knows it's 2.2.4, not 2.1.0 ...

    -- Rod
    Last edited by rwhitby; 12/29/2011 at 07:53 PM.
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  2.    #102  
    Quote Originally Posted by rwhitby View Post
    Pushed matching updates to all three scripts in git.

    Testing on -wr now.

    Video - Check
    Music - Check
    WiFi - Check
    Touch Screen - Check
    USB - Check
    Skype - Check
    Camera: Photo & Video - Check

    Next, /etc/palm-build-info masquerading needs to happen so Preware knows it's 2.2.4, not 2.1.0 ...

    -- Rod
    If you wish to mash that in be my guest, also does Novacom still think it is a roadrunner, I assume so we need to fix that...

    Also some one asked for a BELL script, I did not see it but a 2.1.0 script is in there, seems it also needs masquerading back down to 1.4.x. Would you be able to mash a BELL script up?

    Also there are 22 modules left, the few left might need to stay... but if someone has the time to remove each module from the script one at a time, build doctor and flash, if it works report, if it does not report, put back module and remove another one at a time... I assume kernel file(s) will need to stay, but what about the video driver (tisgxgfx) could we use the roadrunner version? Is bootie really device specific? or what about bootloader...
    Last edited by John Steffes; 12/29/2011 at 08:07 PM. Reason: Still more to do
  3. #103  
    Quote Originally Posted by John Steffes View Post
    If you wish to mash that in be my guest, also does Novacom still think it is a roadrunner, I assume so we need to fix that...

    Also some one asked for a BELL script, I did not see it but a 2.1.0 script is in there, seems it also needs masquerading back down to 1.4.x. Would you be able to mash a BELL script up?
    Don't wait for me - I won't have much time to put towards this in the next couple of days.

    Luckily, I can do pull request merges from my phone now

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  4.    #104  
    Quote Originally Posted by rwhitby View Post
    Don't wait for me - I won't have much time to put towards this in the next couple of days.

    Luckily, I can do pull request merges from my phone now

    -- Rod
    Ok updated PalmBuildInfo masquerading not sure if this works... used the code from previous webos 2.1.0 scripts...

    Only modified Verizon build as of yet as I want to make sure it is tested... Once tested will update the other two scripts and if I have time I will attempt to build a BELL script...
    Last edited by John Steffes; 12/29/2011 at 08:44 PM. Reason: Corrected PalmBuildInfo masquerading
  5. #105  
    Quote Originally Posted by John Steffes View Post
    Also there are 22 modules left, the few left might need to stay... but if someone has the time to remove each module from the script one at a time, build doctor and flash, if it works report, if it does not report, put back module and remove another one at a time... I assume kernel file(s) will need to stay, but what about the video driver (tisgxgfx) could we use the roadrunner version? Is bootie really device specific? or what about bootloader...
    Could you post or attach a list (to aid my froggy brain) of the 22 remaining modules to be considered?

    Here's the list that I've restored and tested from Preware and seem to be working. The Advanced System Prefs patches seemed to cause problems and I haven't installed them for several builds. All of the patches are 2.2.4 versions: Of note as well, I've been running GVoice, Angry Birds Rio Free, and Music Remix without issue.

    org.webosinternals.patches.notifications-advanced-reset-options
    org.webosinternals.patches.advanced-system-menus-device-menu-vzw -2.2.4-15
    org.webosinternals.patches.advanced-system-menus-framework-vzw -2.2.4-15
    AgendaZ
    com.apptuckerbox.register
    com.palm.futurepr0n.batterymonitorplus
    org.webosinternals.eom-overlord-monitoring
    org.webosinternals.govnah
    ca.canucksoftware.jsjsjs-$service$-$framework$
    org.webosinternals.impostah
    ca.canucksoftware.internalz
    ca.canucksoftware.ledtorch
    org.webosinternals.lsdiff
    com.quickoffice.webos
    org.webosinternals.patches.system-remove-tap-ripple
    org.webosinternals.saverestore
    ca.canucksoftware.systoolsmgr
    org.webosinternals.tweaks
    org.webosinternals.xecutah
  6.    #106  
    Quote Originally Posted by kayphoonstar View Post
    Could you post or attach a list (to aid my froggy brain) of the 22 remaining modules to be considered?

    Here's the list that I've restored and tested from Preware and seem to be working. The Advanced System Prefs patches seemed to cause problems and I haven't installed them for several builds. All of the patches are 2.2.4 versions: Of note as well, I've been running GVoice, Angry Birds Rio Free, and Music Remix without issue.
    You will want to update to build 21, which has PalmBuildInfo masquerading, so we can see how palm, preware, and others take to 2.2.4.

    Also here is the list of modules that get copied from 2.1.0 into 2.2.4:
    bootloader kernel-dev kernel-module-oprofile kernel-module-scsi-wait-scan luna-prefs pmtpupdater camd-omap34xx camsrc-omap34xx castletpfw kernel-image-2.6.24-palm-joplin-3430 kernel-module-ecb kernel-module-ifb kernel-module-nbd kernel-module-pcbc pmwifidriver pmmedia-omap34xx tisgxgfx updatefsinfo bootie-images trenchcoat compcache

    I assume as luna-prefs holds the files for device make/model and we leave the pre2 version, but replace the text files for device/model that should stay, and tisgxgfx counter part is tisgxgfx-roadrunner which we prune (we would have to remove the prune to test that), compcache is for the smaller memory footprint in pre, pmwifidriver you already proved we need...

    Also I want to thank you for all your hard work, testing this, without your help this never would have happened...


    Quote Originally Posted by kayphoonstar View Post
    Also, in relation to my voice mail issue, I'm thinking maybe I could try using Impostah to override old phone number on the device (changing it to my GV number) Are there any risks associated with doing that/re: profile or anything. Will an Impostah Phone Number Override change the number in the profile and does that do anything bad?
    As far as voicemail goes I thought it was part of the nv items in the modem board...
    use PmModemUpdater -b to backup your NV items, then try to find the item that corresponds to Voicemails and change it from 01 to 00, you might need a more powerful qualcomm editor, then once you know the nv item you can use PmModemUpdater -r /path/to/nvfile to restore your backup with the voicemail counter reset to 0, you can also dr. back to 1.4.5 which I thought had that reset voicemail count in the phone dialer...
    Last edited by John Steffes; 12/29/2011 at 09:07 PM.
  7. #107  
    sorry to interrupt the work discussions, but how is the performance ? Pretty similar to 2.1?
    Author:
    Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
    Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
    (1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
    GO OPEN WEBOS!
    People asked me for a donate link for my non-catalog work, so here you are:
  8.    #108  
    Quote Originally Posted by abellemare44 View Post
    Thank's I am able to do git pull again

    Is there a test script for BELL P100EWW

    Thank's
    Quote Originally Posted by abellemare44 View Post
    There is a script: meta-bellmo-pre-2.1.0

    I do not have BELL service, but I am assuming someone knows the right settings to apply to the Make file to set the correct settings, but I do not... I did not see any BELL 2.1.0 script, but as you point out there is one.

    So I mash together a script (based on version 21), never tested... let me know if it works... Posted on 1st post and sent to git...
    Last edited by John Steffes; 12/30/2011 at 08:04 AM.
  9. #109  
    Quote Originally Posted by John Steffes View Post
    You will want to update to build 21, which has PalmBuildInfo masquerading, so we can see how palm, preware, and others take to 2.2.4.
    Thanks for the list, I'll do a git pull and then start doing some more poking around -


    Quote Originally Posted by John Steffes View Post
    As far as voicemail goes I thought it was part of the nv items in the modem board...
    use PmModemUpdater -b to backup your NV items, then try to find the item that corresponds to Voicemails and change it from 01 to 00, you might need a more powerful qualcomm editor, then once you know the nv item you can use PmModemUpdater -r /path/to/nvfile to restore your backup with the voicemail counter reset to 0, you can also dr. back to 1.4.5 which I thought had that reset voicemail count in the phone dialer...
    Thanks! This is very interesting! I'm going to explore doing this. I should have done the reset when I had it doctored back to 1.4.5 a few days ago - sheesh!

    Quote Originally Posted by eblade View Post
    sorry to interrupt the work discussions, but how is the performance ? Pretty similar to 2.1?
    It's actually been a while since I've used the Pre +, since my main phone is now a Pre 2, and it isn't up to that performance level. Also, I've hardly let a build settle down ( completely sync, etc.) before slaming another build at it. But, once the Uber Kernel is loaded it seems to do a decent job and the phone app, e.g., actualy seems to load noticeably faster than in 2.1. Since I don't have cell service on it, I'm actually looking forward to using it as handy little Skype phone and music player.
  10.    #110  
    Quote Originally Posted by kayphoonstar View Post
    Thanks for the list, I'll do a git pull and then start doing some more poking around -
    Grab the post from the 1st page of this thread... for version 21...
    Meta-Doctor file list has version 20 (at this time)...

    Really want to know how the Palm-Build-Info works in version 21...
  11. #111  
    Wanted to know if the modem firmware in 2.2.4 is different from the one in 2.1....or can i proceed with no_modem_update switch 'on'...?
    -Mayank Mall
  12. #112  
    Quote Originally Posted by John Steffes View Post
    Grab the post from the 1st page of this thread... for version 21...
    Meta-Doctor file list has version 20 (at this time)...

    Really want to know how the Palm-Build-Info works in version 21...
    Got it. Device Info reports 2.2.4; Preware offers 2.2.4 patches w/o adding 2.2.4 feed; Palm Profile still on 2.1.0.

    UPDATE: ummm. . . maybe the Uberkernel for Palm Pre -/+ could be added to the alpha test feed for 2.2.4 kernels? I can't install it any more. . .
    Last edited by kayphoonstar; 12/30/2011 at 05:49 AM.
  13.    #113  
    Quote Originally Posted by mayank View Post
    Wanted to know if the modem firmware in 2.2.4 is different from the one in 2.1....or can i proceed with no_modem_update switch 'on'...?
    The Verizon script has both CDMA (updated from Verizon 2.1.0 build 124, 1.8) and UMTS (updated from Pre2 2.2.4 build 160), The two other scripts I created (BELL and Sprint, also have CMDA (updated from Verizon 2.1.0 build 124, 1.8), but I did not include the UMTS version. I included it in the Verizon script because I also posted notes (on first page of this thread), how to change the script for other carriers/devices so I wanted the current firmware for both CDMA and UMTS.

    Rod's script WR has just what comes with WebOS 2.1.0 build 285, from my understanding of the script. Rod can explain more if he wishes...

    Quote Originally Posted by kayphoonstar View Post
    Got it. Device Info reports 2.2.4; Preware offers 2.2.4 patches w/o adding 2.2.4 feed; Palm Profile still on 2.1.0.

    UPDATE: ummm. . . maybe the Uberkernel for Palm Pre -/+ could be added to the alpha test feed for 2.2.4 kernels? I can't install it any more. . .
    Ok so Palm Build Info reports 2.2.4 and now preware offers the correct patches, but it does not present the 2.1.0 kernels for Pre/Pre+...

    Assume everything else works, Camera, Sounds (MP3, Ringtones, System Events), Touchscreen, Palm Profile still thinks 2.1.0, that is good... Please report on all other tests...

    Changed 1st post that scripts are now ready for prime time users?
    Last edited by John Steffes; 12/30/2011 at 08:09 AM.
  14. #114  
    I got my answer.......thnku though, now just waiting for you to update your post, for open testing by prime time users !!!
    -Mayank Mall
  15. #115  
    Quote Originally Posted by John Steffes View Post

    Ok so Palm Build Info reports 2.2.4 and now preware offers the correct patches, but it does not present the 2.1.0 kernels for Pre/Pre+...

    Assume everything else works, Camera, Sounds (MP3, Ringtones, System Events), Touchscreen, Palm Profile still thinks 2.1.0, that is good... Please report on all other tests...

    Should I change 1st post that scripts are now ready for prime time users?
    I haven't, and won't be able to, test actual phone function although Skype works so I don't know why the phone wouldn't. So there's that. Everything else works.

    The only other thing is that, in all honesty, I haven't done a single full install/restore that didn't require at least one battery pull. I can't say for sure why that is but it might be good to note that. For all I know, this 2 year old phone is maybe just a little 'tired' and other's won't have the problem. But once things are synced and installed it seems pretty stable to me. I do think that particularly for the Pre + (coming back to it from the Pre 2) that it makes a big difference to install Uberkernel. Also, probably would be good to mention that there's been some issues with the Advanced System Prefs patches - they really messed things up for me, but they install so . . .

    That was the long answer I guess. Short answer: "Why not?"

    Oh! And the other thing is that it's also important to remember that all 2.2.4 meta-doctors (AFAIKAFAIKAFAIK) $will$ $clear$ $the$ $USB$ $partition$!

    BTW: I went ahead and did a Profile Override in Impostah to change the phone number, Restarted, and the voicemail notification went away - Then I applied the "Hide Voicemail Button Patch" and it came back - Doh!
    Last edited by kayphoonstar; 12/30/2011 at 08:48 AM.
    mayank likes this.
  16. #116  
    Quote Originally Posted by John Steffes View Post
    I do not have BELL service, but I am assuming someone knows the right settings to apply to the Make file to set the correct settings, but I do not... I did not see any BELL 2.1.0 script, but as you point out there is one.

    So I mash together a script (based on version 21), never tested... let me know if it works... Posted on 1st post and sent to git...
    I'm testing it right now

    Thank's
    ----------------------------------
    Alain (abellemare44)
    HP Pre3 2.2.4 (ATT 4G 16 Gigs) with BELL in Canada

    HP TouchPad 16 Gigs Wifi
    With UberKernel 3.0.4 1,8 Ghz
    Cyanogenmod 7 Alpha 3,5 Android 2.3.7


    PS: sorry for the bad english, it's not my native language
  17.    #117  
    Quote Originally Posted by mayank View Post
    I got my answer.......thnku though, now just waiting for you to update your post, for open testing by prime time users !!!
    Updated 1st Post Build 21 is ready for Prime Time Users...

    Quote Originally Posted by kayphoonstar View Post
    I haven't, and won't be able to, test actual phone function although Skype works so I don't know why the phone wouldn't. So there's that. Everything else works.

    The only other thing is that, in all honesty, I haven't done a single full install/restore that didn't require at least one battery pull. I can't say for sure why that is but it might be good to note that. For all I know, this 2 year old phone is maybe just a little 'tired' and other's won't have the problem. But once things are synced and installed it seems pretty stable to me. I do think that particularly for the Pre + (coming back to it from the Pre 2) that it makes a big difference to install Uberkernel. Also, probably would be good to mention that there's been some issues with the Advanced System Prefs patches - they really messed things up for me, but they install so . . .

    That was the long answer I guess. Short answer: "Why not?"
    Thanks for the testing...

    Quote Originally Posted by abellemare44 View Post
    I'm testing it right now

    Thank's
    Let me know how that goes...
  18. #118  
    test-bellmo-pre-2.2.4

    after downloading the jar files for each version

    The script stops here is the error:

    Your custom doctor file will be created at build/test-bellmo-pre-2.2.4/webosdoctorp101ueu-wr-2.1.0.jar

    rm -rf build/pre2-p224pre2-wr-2.2.4
    mkdir -p build/pre2-p224pre2-wr-2.2.4
    cp downloads/webosdoctorp224pre2-wr-2.2.4.jar build/pre2-p224pre2-wr-2.2.4/webosdoctorp224pre2-wr-2.2.4.jar
    ( cd build/pre2-p224pre2-wr-2.2.4 ; \
    unzip -q webosdoctorp224pre2-wr-2.2.4.jar META-INF/MANIFEST.MF com/* \
    resources/webOS.tar resources/recoverytool.config )
    ( cd build/pre2-p224pre2-wr-2.2.4 ; \
    unzip -q webosdoctorp224pre2-wr-2.2.4.jar resources/wr.tar )
    mkdir -p build/pre2-p224pre2-wr-2.2.4/webOS
    tar -C build/pre2-p224pre2-wr-2.2.4/webOS \
    -f build/pre2-p224pre2-wr-2.2.4/resources/webOS.tar -x
    cp scripts/WebOS-Internals.tga build/pre2-p224pre2-wr-2.2.4/webOS/BootLogo.tga
    mkdir -p build/pre2-p224pre2-wr-2.2.4/carrier
    tar -f build/pre2-p224pre2-wr-2.2.4/resources/wr.tar -t \
    > build/pre2-p224pre2-wr-2.2.4/carrier-file-list.txt
    tar -C build/pre2-p224pre2-wr-2.2.4/carrier \
    -f build/pre2-p224pre2-wr-2.2.4/resources/wr.tar -x
    gunzip -f build/pre2-p224pre2-wr-2.2.4/webOS/nova-cust-image-roadrunner.rootfs.tar.gz

    gzip: build/pre2-p224pre2-wr-2.2.4/webOS/nova-cust-image-roadrunner.rootfs.tar.gz: invalid compressed data--crc error

    gzip: build/pre2-p224pre2-wr-2.2.4/webOS/nova-cust-image-roadrunner.rootfs.tar.gz: invalid compressed data--length error
    make: *** [build/pre2-p224pre2-wr-2.2.4/.unpacked] Erreur 1
    abellemare44@acer-linux:~/meta-doctor$


    Don't know why!!

    Thank's

    Alain
    ----------------------------------
    Alain (abellemare44)
    HP Pre3 2.2.4 (ATT 4G 16 Gigs) with BELL in Canada

    HP TouchPad 16 Gigs Wifi
    With UberKernel 3.0.4 1,8 Ghz
    Cyanogenmod 7 Alpha 3,5 Android 2.3.7


    PS: sorry for the bad english, it's not my native language
  19. #119  
    Quote Originally Posted by kayphoonstar View Post
    Oh! And the other thing is that it's also important to remember that all 2.2.4 meta-doctors (AFAIKAFAIKAFAIK) $will$ $clear$ $the$ $USB$ $partition$!
    ....m also testing now....and thnx for telling that usb partition will be formatted, i would have never thght of tht and lost my data !!!
    -Mayank Mall
  20. AMR-1's Avatar
    Posts
    258 Posts
    Global Posts
    261 Global Posts
    #120  
    This is fun to watch! Usually have to be in irc to see stuff like this

    Will try it on whatever we are calling a Sprint Pre- with the comms slice from an unlocked Pre2 installed in it (maybe call it "LeftOverParts") as soon as I get home 2nite...

Posting Permissions