Page 27 of 36 FirstFirst ... 172223242526272829303132 ... LastLast
Results 521 to 540 of 718
Like Tree78Likes
  1. #521  
    Quote Originally Posted by mayank View Post
    I think I have few more segments there apart from modules only....can you please try the script in its original form and report the results, I donno much about the super script and anyway if the original v18 works then we'll have to bring in those modules in a better way than swapping from 2.1, By the way if you still want to use the super build, copy the segment of luna-service2 into the super build and make sure to add the module "luna-service2" to the end of the script section, preceding or after trenchcoat.

    Also one thing, PmWsfDaemon need not be in lowercase, the script i provided runs and builds perfectly, i dont think there should be an error with that, afterall the module is named in this form inside the ipkg info and everywhere else too.

    Anyway, please try the original one first, I want to know specifically how does this one goes.
    Super script just moves around a few additional files, unrelated to the problem we seem to be having. I ran you virgin v18 script just now and got the very same error:

    Overwriting md5sum for ./etc/palm-build-info
    mv: cannot stat `build/test-verizon-preplus-2.2.4/rootfs/usr/lib/ipkg/info/PmWsfDaemon.md5sums': No such file or directory
    cat: ./usr/lib/ipkg/info/PmWsfDaemon.list: No such file or directory
    Traceback (most recent call last):
    File "./scripts/replace-md5sums.py", line 17, in <module>
    for line in fileinput.input([sys.argv[1]]) :
    File "/usr/lib/python2.7/fileinput.py", line 253, in next
    line = self.readline()
    File "/usr/lib/python2.7/fileinput.py", line 345, in readline
    self._file = open(self._filename, self._mode)
    IOError: [Errno 2] No such file or directory: 'build/test-verizon-preplus-2.2.4/rootfs/usr/lib/ipkg/info/PmWsfDaemon.md5sums.old'
    Overwriting md5sum for ./usr/bin/luna-prefs-service

    Not smart enough to know just what effect this may have.

    After more battery pulls than normal, my last flash (Super Version 33 f105 with your v18) made it through the night on a charger. Airplane mode on, wifi off. Have been able to turn wifi on while needed with success, but temp goes up significantly. Still a gremlin in there!
  2. #522  
    I dont get this, it seems as the ipkg infos aren't extracted properly and thus it lacks the files required. You running the latest meta doctor version, try git pull once, and have your cleared the builds before running it, make clobber command. I am not sure, but if it doesn't help remove the PmWsf module and re-run the script, you can replace the module after you complete doctoring, just like the other modules i mentioned.

    ----------------
    Novacom Daemon,
    I donno if anyone else has experienced this yet, but this is the second time the daemon has stopped responding. I guess it doesn't start properly or is killed, yet to check the log. When i try to connect the device to my pc, niether novaterm nor WSQI detects it. The doctor detects it fine but not any of those two softwares. Will see if i get into this trouble again, It takes a complete shutdown and start to fix this, even reboots dont help.
    Last edited by mayank; 02/06/2012 at 12:15 PM.
    -Mayank Mall
  3. #523  
    Just did fresh install of meta doctor, starting from scratch with your v18. Same error!
  4.    #524  
    Quote Originally Posted by Tim Dugan View Post
    2.2.4/rootfs/usr/lib/ipkg/info/PmWsfDaemon.md5sums': No such file or directory
    Overwriting md5sum for ./usr/bin/luna-prefs-service
    Quote Originally Posted by mayank View Post
    I dont get this, it seems as the ipkg infos aren't extracted properly and thus it lacks the files required. You running the latest meta doctor version, try git pull once, and have your cleared the builds before running it, make clobber command. I am not sure, but if it doesn't help remove the PmWsf module and re-run the script, you can replace the module after you complete doctoring, just like the other modules i mentioned.
    All info files are lower case...

    So here is the Super script version I have been working with (with your v18 and your manuel modules baked in)... Still Freezes/Lockups and I do not see any benefit to bringing any of these (activitymanager pmwsfdaemon pmwirelesssystemframework opengles-omap3 opengles pmnetconfiglib luna-sysmgr-ipc or modify luna-service2 pmnetconfigmanager) still see the alerts instead of roadrunner they say castle...

    webos-device user.crit ls-hubd: {ls-hubd.public}: Error in /home/reviewdaemon/projects/nova/oe/BUILD-castle/work/luna-service2-2.0.0-125/125/src/hub/security.c:1154
    webos-device user.crit ls-hubd: {ls-hubd.public}: Unable to get permission from JSON

    Can you document what each module effects? What alert did you get that made you pick this module to bring over what alert went away?


    Quote Originally Posted by Tim Dugan View Post
    Just did fresh install of meta doctor, starting from scratch with your v18. Same error!
    Tim can you try the script below, it is all of mayank's tweaks baked in... I am running it for ~18 or so hours now... it is still freezing and locking up and I do not see the benefits as of yet... but I am will to try anything to make this better...
    Attached Files Attached Files
    Last edited by John Steffes; 02/06/2012 at 12:47 PM.
  5. #525  
    so it needs to be lowercase, sorry Tim, donno how mine gets successfully built.

    ----

    Detailed Info:

    1. ls-hubd
    As i told, my current log shows just one error (luna-service 125...), ignoring the phone app and hotspot app based error. Originally there were more errors, like (from my previous message log that i saved)...

    2012-01-26T11:21:18.063690Z [2612] webos-device user.crit ls-hubd: {ls-hubd.private}: Unable to push role (requester pid: "2121", requester exe: "/usr/palm/nodejs/node", requester cmdline: "ca.canucksoftware.systoolsmgr.jsjsjs&$quot$;)

    2012-01-26T12:08:16.499938Z [5417] webos-device user.crit ls-hubd: {ls-hubd.public}: Unable to push role (requester pid: "4755", requester exe: "/usr/palm/nodejs/node", requester cmdline: "ca.canucksoftware.filemgr.jsjsjs&$quot$;)

    2012-01-26T12:45:08.443481Z [7629] webos-device user.crit ls-hubd: {ls-hubd.private}: Encountered error during recv: 104, Connection reset by peer [fd: 69, client service name: com.palm.lunastats, client unique name: /var/run/ls2/jazpJ8

    You wont find these in my log, and there should be more in the log, as i checked it, mentioned just few.

    2. activitymanager
    Dont have anything specific about it, seeing the errors, i replaced it and found the change good for my hardware. Also, a reason for the change was, the daemon in text view had sources to boost library but again with roadrunner name in the oe-build line.

    3. PmNetConfig
    Again a roadrunner based build, Original log shows :
    updateDefaultRouting: Updating Default Route to be: eth0
    My Log:
    updateDefaultRouting: Updating Default Route to be: ppp0
    Now the net originally is identified as an ethernet based connection whereas actually is a point-to-point based ppp connection. anyway i think its coz of wfi and phone data usage mode messages.


    3. Opengles (Both)
    I mentioned before too, i had a poor experience with linux and graphics, my desktop pc hanged a lot just like my pre, that time it was just the graphics driver, i had to actually shift to VESA to get it to run. I looked at the info of the two and OMAP3 one has tisgxgfx-roadrunner as a dependency and the script removes that module replacing it with older tisgxgfx one, i donno why but maybe not necessary, i replaced it. Yea there are many more modules dependent on that roadrunner tisgxgfx but as i said my terrible experience with graphics and linux made me do it.

    4. PmNetconfigLib
    It is required by the daemon otherwise the OS fails to boot.

    5. PmWsfDaemon and wireless system framework
    I had various errors by these, but they weren't resolved, and now maybe they werent errors. I do not think they need to be shuffled in particular, but wanted someone to actually reach the stage like i am on, no freezing all working one. Will be changing it after someone else tries and reports the result upon my script v18.

    6. Luna-sys-mgr-ipc
    Originally the log had errors:
    webor pubsubservics-device user.ere: [bootStatusResponse: 972]: bootStatusResponse failed.
    {"serviceName":"com.palm.systemmanager","returnValue":false,"errorCode":-1,"errorText":"com.palm.systemmanager is not running."}

    com.palm.appinstaller is not running.

    My current log eliminated those,
    wait a sec. my log that i posted show them, but my v17 log eliminated those. I'll be rechecking this one.

    By the way, systemmanager, eventreporter, appinstalled, vibrate....all these are names seeking permissions from ls-hubd /usr/share/ls2/* directory, file is com.palm.luna.*, all reporting to luna-sysmgr

    Basically, the two that helped me most should be ls-hubd, acitivtymanager, that ipc would have been in the list but i see the error again, will be trying my v17 again to see if anything changes. Also did anyone find the novacom daemon issue as i mentioned in my first post on this page.

    Also, i dont think none of those make perfect sense, but what to say, i lack words. Will be testing your super build tommorrow to see if it is the same for me or not. Again am sorry if it doesn't work, but i donno what special thing is with my build, my script runs fine with the upper case module and my device does not freeze. The best i can do is show you guys a video of my device doing every kind of task, maybe that can make you believe me.
    Last edited by mayank; 02/06/2012 at 01:33 PM.
    -Mayank Mall
  6. #526  
    Latest script ran without error. Used f105. No pulls yet! Apps updating on wifi. Airplane mode on. Will pull log after apps update. This is the best result so far!

    Edit: messages after latest flash attached.
    Last edited by Tim Dugan; 03/04/2012 at 10:43 PM.
  7. #527  
    Quote Originally Posted by Tim Dugan View Post
    Latest script ran without error. Used f105. No pulls yet! Apps updating on wifi. Airplane mode on. Will pull log after apps update. This is the best result so far!
    With latest script you mean the version 33 as on first post, or the one which is posted on this page by John. talking of the super script....
    -Mayank Mall
  8. #528  
    Quote Originally Posted by mayank View Post
    With latest script you mean the version 33 as on first post, or the one which is posted on this page by John. talking of the super script....
    Script referred to is John's on this page that he asked that I try. Sorry if I wasn't clear. BTW, just had to do first battery pull while updating apps over wifi. Went longer than usual.
  9.    #529  
    Quote Originally Posted by Tim Dugan View Post
    BTW, just had to do first battery pull while updating apps over wifi. Went longer than usual.
    I have had to battery pull a lot more, or luna crash... set a simple pin lock 1234, and it worked the first screen then the second to re-type and boom luna crash, the second time battery pull... I also had touch screen issues, the device powered (moving slider) up awaiting input from the touch panel, but when I touched the screen it ignored my touch... I novatermed in a did a luna restart and it came back... (this has happened twice now)... I gave this a ~24 hour try and I am about to go back to my build 33...

    Tim, looked at your log but there were more message logs that are not present do you have message0.gz etc... they have the boot sequence that is what I am looking for... other then that it looks very similar to mine...


    Quote Originally Posted by mayank View Post
    My current log eliminated those,
    wait a sec. my log that i posted show them, but my v17 log eliminated those. I'll be rechecking this one.

    By the way, systemmanager, eventreporter, appinstalled, vibrate....all these are names seeking permissions from ls-hubd /usr/share/ls2/* directory, file is com.palm.luna.*, all reporting to luna-sysmgr

    Basically, the two that helped me most should be ls-hubd, acitivtymanager, that ipc would have been in the list but i see the error again, will be trying my v17 again to see if anything changes. Also did anyone find the novacom daemon issue as i mentioned in my first post on this page.

    Also, i dont think none of those make perfect sense, but what to say, i lack words. Will be testing your super build tommorrow to see if it is the same for me or not. Again am sorry if it doesn't work, but i donno what special thing is with my build, my script runs fine with the upper case module and my device does not freeze. The best i can do is show you guys a video of my device doing every kind of task, maybe that can make you believe me.
    Thanks for the detailed log, I will look into the modules and see if anything shakes out, but just because this build is not working for me, does not mean it won't for for others, not all our devices are the same (hardware does have different revisions although I have no idea how one would check as they all seem to report the same revision), but I have seen devices that have same model have different revisions (my touchpad for example I have heard there were several different revisions some with better batteries or better cases....). It is not that I do not believe yours is working well, I just can't produce the same result with my hardware. Also have never had issues with novacomd before or after the hex edit modification.
    Last edited by John Steffes; 02/06/2012 at 04:21 PM.
  10. #530  
    Messages.0 attached. Any other specific logs of value (don't want to send you junk!)?
    Last edited by Tim Dugan; 03/04/2012 at 10:43 PM.
  11. #531  
    A few more logs. Hope they tell someone something.

    Would we be better off just slowly adding desired modules to the 2.1.0 build? Wireless Skype my primary interest.
    Last edited by Tim Dugan; 03/04/2012 at 10:43 PM.
  12.    #532  
    Quote Originally Posted by Tim Dugan View Post
    A few more logs. Hope they tell someone something.

    Would we be better off just slowly adding desired modules to the 2.1.0 build? Wireless Skype my primary interest.
    Tim, if one has Verizon Wireless, one can have Skype as part of webOS 2.1.0, I have a script (test-verizon-preplus-2.1.0) that will bring Skype from the Verizon Pre2 webOS 2.1.0 and like the super script for webOS 2.2.4 it will give you all the updates, but Skype will not be over WiFi. The whole point was to attempt to bring webOS 2.2.4 as a whole over from a Pre2 to a PrePlus as they have similar hardware, we are close but there are a few things missing, first the kernel (I working on it but it is taking a lot of time to understand what each change does, also as I am testing these scripts and other modules it takes away from staring at the kernel code, also having a life outside of this...) and second modules something is not 100% right do not know what that is yet.

    I just do not want Skype but, DARE (Data At Rest Encryption), MAP with touchpad, the updated enyo phone app etc... I want it all (If HP would release a non-carrier related build life would be better) but as I am dreaming it will never happen... So I will keep trying... This is a project like any other, if we get it to work great, if not then it was worth trying... I at least have a phone that works ~18 hours out of my life (it may freeze or lockup), but then the benefits to me are great.

    All HP needs to do is supply a Palm PrePlus build with an empty carrier.tar file (well not 100% empty would need installer.xml and the basic apps like Skype etc... but no carrier apps, as we can meta-doctor a carrier tar ourselves).... I know it can work as this endeavor proves, however, the carriers have to approve why I have no idea, contracts seem to be for a short time, not for the life of a product but that seems to be not true for out little phone...

    I have no contact with HP in anyway shape or form in relation to my endeavor, nor do I have any NDA but I believe as I have seen with the Pixi (webOS 2.1.0 in the wild), Veer webOS 2.2.3 and webOS 2.2.4 in the wild), touchpad (webOS 3.0.3 in the wild), even on the Palm Pre Sprint webOS 2.1.0 in the wild before there was a webOS 2.1.0 release... But I believe on some server at HP/Palm there exists this build I so wish to re-create... If HP would release it...

    Ok I have to stop dreaming... sorry looking at more kernel code...
    Last edited by John Steffes; 02/06/2012 at 07:32 PM.
    Tim Dugan and mayank like this.
  13. #533  
    I'm with you John! I use your test-verizon-preplus-2.1.0 when not pulling the battery with your latest. You figure something out, I'm happy to try it. Even with all the loose ends, you're remarkable!
    mayank likes this.
  14. #534  
    Seriously, whatevr happens with this open webos 1.0, will we get it or not, its not the actual point. Currently we will be continuing with the project to see what works and what else could be done to make it better. I wanna thanks all for the testing, and John for continuing with the project (I've seen so many projects which are just left over due to such constraints), I donno why but now i can use mine as primary, it is primary but webos 2.2.4 enabled is what i mean, and continue to look for ways to eliminate the remaining errors, activitymanager.resourcecontainermanager - my primary aim.

    In the end, I too am with all of you, Thanks a lot. As of HP even i think there do exist a non carrier build afterall the codes show a segment for the castle and pixies too not just the higher models. If they weren't planning to make it work, why would they be interested in writing a code. The releasing thing, maybe they want some carrier to ask for the build to be able to release the 2.2 for these older ones. Even i agree that now when the contacts are over, there must be no point in sticking with the carrier but in releasing a non-carrier specific build.

    I have so many hopes with this Open WebOS 1.0, with those hopes i am gonna continue my efforts for this project.


    -------------

    That novacom thing, its just gone, i cant connect any more, not with my pc not with my laptop. The phone gives the message to charge or enter usb drive mode, usb mode works good. But no connection via novaterm or WSQI. Reverting to my v17 for now.

    EDIT: Its working now, my developer mode turned off by itself, still on the current build.

    -------------

    Quote Originally Posted by Tim Dugan View Post
    BTW, just had to do first battery pull while updating apps over wifi. Went longer than usual.
    Glad it proved a bit better to you, Just for a note, i tried all kernels, including av8 and f10*, uberkernel and the default palm kernel. I had lockups with all except the default palm kernel which is a modified one as after script 29. So i would suggest you to give the default kernel a try if you have further freezes, i am sure currently the occurrence of these would have reduced to an extent which could be easily felt.
    Last edited by mayank; 02/07/2012 at 01:58 AM.
    -Mayank Mall
  15.    #535  
    Quote Originally Posted by mayank View Post
    I have so many hopes with this Open WebOS 1.0, with those hopes i am gonna continue my efforts for this project.

    Glad it proved a bit better to you, Just for a note, i tried all kernels, including av8 and f10*, uberkernel and the default palm kernel. I had lockups with all except the default palm kernel which is a modified one as after script 29. So i would suggest you to give the default kernel a try if you have further freezes, i am sure currently the occurrence of these would have reduced to an extent which could be easily felt.
    I hope Open webOS 1.0 will build on our devices, but I feel that there will be a lot of things that will not be in the Open Source, that I will stay at webOS 2.2.4...

    FYI Script version 27 is where I removed bringing over the webOS 2.1.0 kernel modules (kernel-module-oprofile, kernel-module-scsi-wait-scan, kernel-module-ecb, kernel-module-ifb, kernel-module-nbd, and kernel-module-pcbc), version 29 was when I stopped bringing over the bootie-images and updatefsinfo (Still wish I knew what this is)...
    Last edited by John Steffes; 02/07/2012 at 10:06 AM.
  16. #536  
    Quote Originally Posted by John Steffes View Post
    I hope Open webOS 1.0 will build on our devices, but I feel that there will be a lot of things that will not be in the Open Source, that I will stay at webOS 2.2.4...

    FYI Script version 27 is where I removed bring over the webOS 2.1.0 kernel modules (kernel-module-oprofile, kernel-module-scsi-wait-scan, kernel-module-ecb, kernel-module-ifb, kernel-module-nbd, and kernel-module-pcbc), version 29 was when I stopped bringing over the bootie-images and updatefsinfo (Still wish I knew what this is)...
    I donno but if skype and my app works, plus i get few advantages like bluetooth obex profile, i'll consider shifting.
    -------------

    After v27 I did not feel the need to change my kernel to those available, it proved better to me. Apart from that i have no idea what they mean....
    --------------

    Currently I hex edited the ls-hubd module and related library, loaded them and saw the new log. The previous error of luna-service went off but a new error came in which says:
    webos-device user.crit ls-hubd: {ls-hubd.private}: Error in /home/reviewdaemon/projects/nova/oe/BUILD-castle:1157
    2012-02-07T14:06:22.989074Z [34] webos-device user.crit ls-hubd: {ls-hubd.private}: Unable to get permission from JSON (/usr/share/ls2/roles/prv/com.palm.mediad.pipeline.json)...multiple files here
    Now, what i see in my previous log is that apart from luna-service errors rest all were eliminated by the 2.1 module. But hex editing 2.1 ls-hubd doesn't help coz it increases the file size and maybe that troubles something (125 -> 131.2, is like 4 extra hex entires)....Is there a way to change 125 to 131.2 without corrupting the file.

    I am currently trying pre 2's 2.1 module, changing roadrunner to castle gives me required 4 bits to make the changes without altering file size....hope it works
    -Mayank Mall
  17.    #537  
    Quote Originally Posted by mayank View Post
    Currently I hex edited the ls-hubd module and related library, loaded them and saw the new log. The previous error of luna-service went off but a new error came in which says:
    webos-device user.crit ls-hubd: {ls-hubd.private}: Error in /home/reviewdaemon/projects/nova/oe/BUILD-castle:1157
    2012-02-07T14:06:22.989074Z [34] webos-device user.crit ls-hubd: {ls-hubd.private}: Unable to get permission from JSON (/usr/share/ls2/roles/prv/com.palm.mediad.pipeline.json)...multiple files here
    Now, what i see in my previous log is that apart from luna-service errors rest all were eliminated by the 2.1 module. But hex editing 2.1 ls-hubd doesn't help coz it increases the file size and maybe that troubles something (125 -> 131.2, is like 4 extra hex entires)....Is there a way to change 125 to 131.2 without corrupting the file.

    I am currently trying pre 2's 2.1 module, changing roadrunner to castle gives me required 4 bits to make the changes without altering file size....hope it works
    I applaud the effort, but I think changing the ls-hubd text from roadrunner to castle is not the fix, the fix is to find the table that ls-hubd is referencing and find what it looks like on the Pre2 and make it look like that under the pre plus...

    I assuming (hate doing this)...
    table on pre 2: roadrunner json permissions....
    table on preplus: roadrunner json permissions....
    should be, table on preplus: castle json permissions....

    We need to know what is it that it is looking for that it is not seeing...
    Not knowing what the table is, where it is, or what it is looking at does not help much...
    But just changing the binary from roadrunner to castle is not changing the issue that what it is referencing is broke... Now if you find that broken table and you fix it, ls-hubd will work and not error out and you will not see the roadrunner error...
    Last edited by John Steffes; 02/07/2012 at 10:35 AM.
  18. #538  
    I believe this is already known, but still.....total files in the whole system that contains roadrunner in them.....234 files, detailed info in the txt file.

    Am not sure, but one of these has a fix to some of our troubles...find it please
    Attached Files Attached Files
    -Mayank Mall
  19. davidka's Avatar
    Posts
    10 Posts
    Global Posts
    11 Global Posts
    #539  
    Quote Originally Posted by John Steffes View Post
    Sorry to read you had issues and if you have any thoughts on how to improve the Bell script please let me know, as I am not on Bell I can not test the script.
    I've noticed that 1.4.5 -> 2.1 upgrade makes following version change of modem's firmware 535 -> 557. Script version 33 builds package with modem firmware v595. Bell's Pre- probably needs v557.
  20.    #540  
    Quote Originally Posted by Davidka View Post
    I've noticed that 1.4.5 -> 2.1 upgrade makes following version change of modem's firmware 535 -> 557. Script version 33 builds package with modem firmware v595. Bell's Pre- probably needs v557.
    The current script on github uses the CDMA firmware from the Pre2 (Verizon webOS 2.1.0) and updates the Bell Pre to the same version, the old version was from the Verizon webOS 2.0.1 build, here is an updated script to backdate the firmware from the webOS 2.1.0 to webOS 2.0.1, did this work?

    If this is reported to work I will submit it to github..

    Removed Bell script as it was proved the firmware was not the issue...
    Last edited by John Steffes; 02/08/2012 at 04:15 PM. Reason: Removed Bell Script...

Posting Permissions