Page 21 of 36 FirstFirst ... 11161718192021222324252631 ... LastLast
Results 401 to 420 of 718
Like Tree78Likes
  1.    #401  
    Quote Originally Posted by mayank View Post
    Hmm....i dont have that deep knowledge of webos but as i said before worth a try. Thats the script i used and am running a stable os currently. Would be glad if you give it a shot, again as i said i dont know exactly what i did, but the results were promising to me atleast.

    Also, before testing i wont be posting any script, am currently testing another version as said, but the one posted, worked like charm for me.

    John, you should try it for once, maybe you'll get some idea of what is the real trouble, if the trouble isn't fixed.

    Also worth mentioning, the powerd is same for pre 2 and pre+ upon my comparison but the powerd in 2.2 pre+ seemed different, coz of whatever reason. After that script above, i did not find any powerd errors or anyother error, even now the messages.log is open infront of me.
    I have compiled a get script to get the two modules powerd and activitymanager and I am actively testing those (took the webOS 2.1.0 version and replaced my webOS 2.2.4 versions)... but I will not know if it fixes anything for a few days... My phone has been very stable went 36 hours before a freeze... So will report back when I have an update...

    Activity Manager was not a success, it failed... but still testing powerd...

    I want to thank you for looking into the message logs and for your trial and error...

    FYI if you compare the MD5SUMS from webOS 2.1.0 and webOS 2.2.4 the powerd modules you can see the binary files are different:

    d7cfe3d0a3466200a5924a0a32a82ff2 *./usr/var/preferences/com.palm.power/powerd.conf
    d7cfe3d0a3466200a5924a0a32a82ff2 *./usr/var/preferences/com.palm.power/powerd.conf

    6476cf533c749a72a59338580432e0c8 *./usr/sbin/powerd
    8bd75818cd4b477462b277aa6bbae917 *./usr/sbin/powerd

    e6f990df2e8b1b88b69f245025ac82cb *./usr/sbin/suspend_action
    c8cd35b0a939617e1fe48b3d0ea4bf27 *./usr/sbin/suspend_action

    838e42fac2e8d1c899185ce594ac62f2 *./usr/sbin/suspend_action.disabled
    838e42fac2e8d1c899185ce594ac62f2 *./usr/sbin/suspend_action.disabled

    34587760873b77b136b8ddd0e88ca58d *./usr/lib/libpowerd.so.0
    8fa1b2913d2008913e5760c93cbe2077 *./usr/lib/libpowerd.so.0

    7717036a0e2efc48ea1bf1f56098913c *./usr/share/dbus-1/system-services/com.palm.power.service
    7717036a0e2efc48ea1bf1f56098913c *./usr/share/dbus-1/system-services/com.palm.power.service

    7717036a0e2efc48ea1bf1f56098913c *./usr/share/dbus-1/services/com.palm.power.service
    7717036a0e2efc48ea1bf1f56098913c *./usr/share/dbus-1/services/com.palm.power.service

    d01e29812682687b4491ca636997c6fd *./usr/share/ls2/roles/prv/com.palm.power.json
    d01e29812682687b4491ca636997c6fd *./usr/share/ls2/roles/prv/com.palm.power.json

    d01e29812682687b4491ca636997c6fd *./usr/share/ls2/roles/pub/com.palm.power.json
    d01e29812682687b4491ca636997c6fd *./usr/share/ls2/roles/pub/com.palm.power.json

    ade2b78899fcc01d95ea1a7aa1ccee6b *./etc/event.d/powerd
    3bdf07fa0ecc2da5d0cb9a55007f4b5f *./etc/event.d/powerd

    8951ab1638ef8c850d1d792f54c54c5b *./etc/udev/rules.d/85-powerd.rules
    8951ab1638ef8c850d1d792f54c54c5b *./etc/udev/rules.d/85-powerd.rules
    Last edited by John Steffes; 01/25/2012 at 10:56 AM.
  2. #402  
    hmmm....so same, the daemon is different.....i guess we'll be having a stable version's script soon. For now my version of the script has solved most of my issues, so i can keep running the OS now. Until you find the right way to make the script, i think people desiring to run 2.2 on pre+ should give my random version a try, no one knows what might work until it actually do.
    -Mayank Mall
  3. #403  
    Ok... re-testing all and now with F105-88 Lithium Benchmark report me 187, 2 hours after reboot!

    But... I haven't youtube app! Help?!
    webOS Italia Community Manager

    User of webOS 2.2.4 on Pre-/ Pre3 & webOS 3.0.5 on HP TouchPad
  4. #404  
    Quote Originally Posted by DMeister View Post
    Ok... re-testing all and now with F105-88 Lithium Benchmark report me 187, 2 hours after reboot!

    But... I haven't youtube app! Help?!

    There is no youtube app in 2.2.4, you'll have to browse to youtube.com and videos will launch in the streaming video player.
    -Mayank Mall
  5.    #405  
    Quote Originally Posted by mayank View Post
    hmmm....so same, the daemon is different.....i guess we'll be having a stable version's script soon. For now my version of the script has solved most of my issues, so i can keep running the OS now. Until you find the right way to make the script, i think people desiring to run 2.2 on pre+ should give my random version a try, no one knows what might work until it actually do.
    Not using your script but grabbing the powerd and activitymanager from webOS 2.1.0 and replacing webOS 2.2.4 was not a success for me as of yet...

    Within 15 minutes I have had three freezes... Put back webOS 2.2.4 modules and have been stable again for 15 minutes...

    Now just testing powerd...

    Still testing CPU temp seems lower and seems stable...
    Last edited by John Steffes; 01/25/2012 at 10:57 AM.
  6.    #406  
    Quote Originally Posted by DMeister View Post
    Ok... re-testing all and now with F105-88 Lithium Benchmark report me 187, 2 hours after reboot!

    But... I haven't youtube app! Help?!
    Quote Originally Posted by mayank View Post
    There is no youtube app in 2.2.4, you'll have to browse to youtube.com and videos will launch in the streaming video player.
    The youtube app is a browser bookmark...

    Here is the info to get it up and running I posted this in a different thread...

    FYI To get the the new YouTube back as well as the old (webOS 2.1.0 youtube, part of the super scripts) create a browse bookmark for youtube use this URL:
    YouTube

    If you do not know how to do it, the webOS Nation posted a how to on it...
    http://www.webosnation.com/add-web-b...-your-launcher

    If you are Verizon I created a Super Script which adds the youtube app from webOS2.1.0 back...
  7. #407  
    Quote Originally Posted by John Steffes View Post
    Not using your script but grabbing the powerd and activitymanager from webOS 2.1.0 and replacing webOS 2.2.4 was not a success for me as of yet...

    Within 15 minutes I have had three freezes... Put back webOS 2.2.4 modules and have been stable again for 15 minutes...

    Now just testing powerd...

    Replacing powerd alone will have soothing results, i had done that before. Though i wasn't able to replace activitymanager via ssh, it just doesn't let me. Also i replaced the powerd file in etc\event.d....dont ask me why ^_^, by the way i am used to linux, running ubuntu as my default desktop, so am not total newbie to the OS, its just that in webos, i have no idea what the modules are, what the services are...have just began learning, so this whole time am just giving trials, and would be surprised myself, if any works.

    BTW How did you replace the activitymanager?
    Last edited by mayank; 01/25/2012 at 10:30 AM.
    -Mayank Mall
  8.    #408  
    Quote Originally Posted by mayank View Post
    Replacing powerd alone will have soothing results, i had done that before. Though i wasn't able to replace activitymanager via ssh, it just doesn't let me. Also i replaced the powerd file in etc\event.d....dont ask me why ^_^, by the way i am used to linux, running ubuntu as my default desktop, so am not total newbie to the OS, its just that in webos, i have no idea what the modules are, what the services are...have just began learning, so this whole time am just giving trials, and would be surprised myself, if any works.

    BTW How did you replace the activitymanager?
    There are several ways to replace files, reboot phone into recovery mode and then use the installer uimage to replace files works well (as no file is in use), but it is not easy to do and unless you understand linux and mounting can be hard...

    The easy way...

    Create a script like this one getpwrd (attached to post) which grabs the modules from both doctors (webOS 2.1.0 and webOS 2.2.4) puts them in a pwrd210.tar and pwrd224.tar files.

    untar those files and you will see a directory structure with all the files in their right directories... (I copy them to pwrd210 and pwrd224)

    Copy that directory structure to your phone's USB drive...
    Now use novaterm
    Assuming you have read/write root:mount -o remount,rw /
    Rename the file in use:mv /usr/sbin/powerd /usr/sbin/powerd.old
    Then copy all files to their directory structure:cp -r /media/internal/pwrd210/* /
    Reboot

    Now use novaterm (again)
    Assuming you have read/write root:mount -o remount,rw /
    Remove the old file:rm /usr/sbin/powerd.old

    Once you are done testing and feel that it does not help reverse and use the pwrd224 files instead i.e. change the directory copied from pwrd210 to pwrd224.

    Optional lock rootfs back down:mount -o remount,r /

    For Activity Manager, I had to move the locked file activitymanager under /usr/bin.

    Hope this helps...

    FYI you will not know which files are in use until your first copy it will tell you I can't copy file because i.e. cp: can't create '/usr/sbin/powerd': Text file busy

    To find what files are in a module look under your meta-doctor/build/[buildsource]/rootfs/usr/lib/ipkg/info directory

    Now [buildsource] is what the directory your build is in for script test-verizon-preplus-2.2.4 that would be test-verizon-preplus-2.2.4 and look under you will see many files grouped by name look for powerd.control it is the file linux uses to understand the module, powerd.list is the file that the directories and file names copied, powerd.md5sums, is the hashes to compare to make sure the file is not corrupt. There are other files post and pre what it should do when installed...

    Also I have been stable (testing powerd only) and CPU temp's seems lower... you might have found a module to bring back... still testing...
    Attached Files Attached Files
    Last edited by John Steffes; 01/25/2012 at 11:07 AM.
    lephilwld likes this.
  9. #409  
    Thanks for the detailed instructions, creating a script is always a problem for me, the first step is suitable though, i was thinking about this one before too. Also thanks for the already made script, i might not need to write one....By the way, using winscp and ssh is just few minutes job, but i wasn't able to replace the locked file with it, it does move or delete it, but copying new file over it, doesn't work. I did not give internalz a try too...enabling its master mode.

    About powerd...after running the modified script i uploaded, i did not find any powerd errors in the log, whereas the daemon was showing multiple errors previously, and so goes the case for activitymanager which doesn't show errors that were previously frequent.

    So with the elimination of those errors, the system might have gained back its stability.


    One thing more, I redoctored with few more changes to the script, am running palm kernel currently, and seems like it is functioning well. No freezes with the default kernel too...another good news
    Last edited by mayank; 01/25/2012 at 11:47 AM.
    -Mayank Mall
  10.    #410  
    Quote Originally Posted by mayank View Post
    Thanks for the detailed instructions, creating a script is always a problem for me, the first step is suitable though, i was thinking about this one before too. Also thanks for the already made script, i might not need to write one....By the way, using winscp and ssh is just few minutes job, but i wasn't able to replace the locked file with it, it does move or delete it, but copying new file over it, doesn't work. I did not give internalz a try too...enabling its master mode.

    About powerd...after running the modified script i uploaded, i did not find any powerd errors in the log, whereas the daemon was showing multiple errors previously, and so goes the case for activitymanager which doesn't show errors that were previously frequent.

    So with the elimination of those errors, the system might have gained back its stability.


    One thing more, I redoctored with few more changes to the script, am running palm kernel currently, and seems like it is functioning well. No freezes with the default kernel too...another good news
    Activity Manager, did not work for me, it caused lock-ups might be I am replacing an existing system... but I am not seeing any messages in my messages log referring to issues with activity manager... Can you post the event so I can search my message logs to see if I have those?

    Powerd is still is testing... but my phone is now 27-35 temp where before it was 35-42 ish... so this seems to have lowered that... but still testing... will know more...

    I never saw any errors with powerd in my messages either what event were you having?
  11. #411  
    Look at my post #389

    The first one is the powerd error, a specific error could be...cannot identify charger source, and activitymanager had errors stating queing the process, process did not start within allotted timeframe, process id not found.....(as far as i can recall, did not backup the log, was viewing them directly....and now i dont have those errors, so cannot actually post them)

    And no errors in your log could be the result of patches you might have installed say muffle logging patch, eom service, or your logging profile is set to minimal....though any of these shouldn't be preventing errors from being logged but anything can happen.
    Last edited by mayank; 01/25/2012 at 12:18 PM.
    -Mayank Mall
  12.    #412  
    Quote Originally Posted by mayank View Post
    1. Charger Related, Seems like the charger status, power source etc are having some unkown trouble....also telephony reports issue with power, so i think its something with the phone app again
    2. systemui related, all errors can be located in /usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs, $Ex$. $One$ $Error$ : $WAN$ $Network$ $ICON$...$something$ $like$ $this$, $search$ $for$ $wan$ $in$ $the$ $file$, $you$'$ll$ $see$ $the$ $error$.
    Quote Originally Posted by mayank View Post
    Look at my post #389

    The first one is the powerd error, a specific error could be...cannot identify charger source, and activitymanager had errors stating queing the process, process did not start within allotted timeframe, process id not found.....(as far as i can recall, did not backup the log, was viewing them directly....and now i dont have those errors, so cannot actually post them)

    And no errors in your log could be the result of patches you might have installed say muffle logging patch, eom service, or your logging profile is set to minimal....though any of these shouldn't be preventing errors from being logged but anything can happen.
    So I see the event "Invalid charger source unknown" on the Pre2 and PrePlus before and after the Powerd change on the PrePlus...

    So I see the event "LunaSysMgr: {LunaSysMgr}: Unable to get percent_ui for battery state", "LunaSysMgr: {LunaSysMgr}: Unable to get charger type" on the Pre2 but not on the PrePlus before or after the Powerd change on the PrePlus...

    Sorry I do not see any errors with Powerd before or after, but I can tell the CPU temp seems to be lower... Still testing...

    As far as Activity Manager on Pre2 "Activity did not start within a reasonable time frame!" and "Clearing create token!", but I do not see that on my PrePlus and I have the same patches on both devices...

    Quote Originally Posted by mayank View Post
    Activitymanager....Hmmm so maybe all this time i was looking at the webos errors, I need a Pre 2, who is Donating??? :P
    Love it... I got my Pre2 from Verizon, when they had them for $0... also got me a Verizon PixiPlus for less then $10... Nice to have a spare battery and power/cable for the PrePlus...
    Last edited by John Steffes; 01/25/2012 at 01:07 PM.
  13. #413  
    Well....that was just one, one other error was cannot identify battery state (or maybe percentage), there were more, appearing as critical errors which have vanished for now. I should have saved the log, HUH !!!

    Anyway, i told you, worth trying, afterall whatever changes they were.....they have positive effect, our only concern. And Do test the other modules, too...

    Activitymanager....Hmmm so maybe all this time i was looking at the webos errors, I need a Pre 2, who is Donating??? :P

    ---------

    do you have these errors on your pre2...
    1. user.crit ls-hubd: {ls-hubd.private}: Error in /home/reviewdaemon/projects/nova/oe/BUILD-roadrunner/work/luna-service2-2.0.0-131.2/131.2/src/hub/hub.c:1141, Error opening directory '/var/mft/palm/system-services': No such file or directory
    2. ls-hubd: {ls-hubd.private}: Unable to get permission from JSON ***Multiple files***
    3. webos-device user.err /usr/bin/filenotifyd[1712]: schedule act from inotify changes done.
    4. No valid names found for service **** while processing service connect update
    5. user.crit LunaSysMgr: {LunaSysMgrJS}: com.palm.systemui (palm.telephony, palm.phone...)
    6. user.err PmModemInfo: PmModemInfo = Version 1.0.1.9 Castle 2010 Oct.@ Palm Inc

    Please Post your log from Pre2....
    Last edited by mayank; 01/25/2012 at 01:31 PM.
    -Mayank Mall
  14. #414  
    Quote Originally Posted by John Steffes View Post
    Love it... I got my Pre2 from Verizon, when they had them for $0... also got me a PixiPlus for less then $10... Nice to have a spare battery and power/cable for the PrePlus...

    I bought a pixi plus for about 50$ in your currency, used it for a month and its touch screen stopped working, dissembled the device at home, nothing helped, finally ended up totally cracking the screen. Also being in India, Palm told me i cannot do anything but to send it to some in US and get it repaired and returned. Now who will tell them, mobile phones cannot be sent freely via courier, the charges of customs alone would be more than its cost. So even i have a spare battery and charger...and various pixi parts.

    Finally, my love for webos made by buy another Palm Device, my pre plus...again like 90$, and am running it since 3-4 months, loved the feel from day 1, though the activation of verizon devices in itself is a 20$ process, a noticeable figure for Indian Students.
    -Mayank Mall
  15. #415  
    LunaSysMgrJS PmWsfDaemon PmNetConfigManager PmModemInfo ls-hubd filenotifyd

    Well i tried these modules too, but did not go well, freezed during profile restore.....its 2am now, feeling exhausted, redoctoring with the modified script i uploaded, the best one yet.
    -Mayank Mall
  16.    #416  
    Quote Originally Posted by mayank View Post
    Well....that was just one, one other error was cannot identify battery state (or maybe percentage), there were more, appearing as critical errors which have vanished for now. I should have saved the log, HUH !!!

    Anyway, i told you, worth trying, afterall whatever changes they were.....they have positive effect, our only concern. And Do test the other modules, too...

    Activitymanager....Hmmm so maybe all this time i was looking at the webos errors, I need a Pre 2, who is Donating??? :P

    ---------

    do you have these errors on your pre2...
    1. user.crit ls-hubd: {ls-hubd.private}: Error in /home/reviewdaemon/projects/nova/oe/BUILD-roadrunner/work/luna-service2-2.0.0-131.2/131.2/src/hub/hub.c:1141, Error opening directory '/var/mft/palm/system-services': No such file or directory
    2. ls-hubd: {ls-hubd.private}: Unable to get permission from JSON ***Multiple files***
    3. webos-device user.err /usr/bin/filenotifyd[1712]: schedule act from inotify changes done.
    4. No valid names found for service **** while processing service connect update
    5. user.crit LunaSysMgr: {LunaSysMgrJS}: com.palm.systemui (palm.telephony, palm.phone...)
    6. user.err PmModemInfo: PmModemInfo = Version 1.0.1.9 Castle 2010 Oct.@ Palm Inc

    Please Post your log from Pre2....
    From Pre2 message log:
    1. See lots of these type
    webos-device user.crit ls-hubd: {ls-hubd.private}: Error in /home/reviewdaemon/projects/nova/oe/BUILD-roadrunner/work/luna-service2-2.0.0-131.2/131.2/src/hub/security.c:1009
    webos-device user.crit ls-hubd: {ls-hubd.private}: No such file or directory
    webos-device user.crit ls-hubd: {ls-hubd.private}: Error in /home/reviewdaemon/projects/nova/oe/BUILD-roadrunner/work/luna-service2-2.0.0-131.2/131.2/src/hub/security.c:1369
    webos-device user.err mediaserver: Error in /home/reviewdaemon/projects/nova/oe/BUILD-roadrunner/work/luna-service2-2.0.0-131.2/131.2/src/transport.c:18902

    2. Do not see any ls-hubd.private messages nor any Unable to get permission from JSON

    3. See lots of those
    webos-device user.err /usr/bin/filenotifyd[1533]: schedule act from inotify changes done. 0
    webos-device user.err /usr/bin/filenotifyd[1533]: schedule act from inotify changes done. 1
    webos-device user.err /usr/bin/filenotifyd[1533]: Starting AM timeout.

    4. see lots of those
    webos-device user.warning activitymanager[1524]: [activitymanager.lunabus] No valid names found for service "/var/run/ls2/AxknnJ" while processing service connect update
    webos-device user.warning activitymanager[1524]: [activitymanager.lunabus] No valid names found for service "/var/run/ls2/W27K5r" while processing service connect update
    webos-device user.warning activitymanager[1524]: [activitymanager.lunabus] No valid names found for service "/var/run/ls2/V35aos" while processing service connect update

    5. See lots of these...
    webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: com.palm.systemui: SystemUI - Phone Notification {xxx lots of stuff here...}, palmInitFramework2112:14

    6. No error messages for user.err PmModemInfo: PmModemInfo = Version 1.0.1.9 Castle 2010 Oct.@ Palm Inc

    So out of all those #2 bugs me...

    I should also note though, my PrePlus has F105 Kernel, my Pre2 is stock HP/Palm kernel... not sure if that makes a difference yet...

    Quote Originally Posted by mayank View Post
    I bought a pixi plus for about 50$ in your currency, used it for a month and its touch screen stopped working, dissembled the device at home, nothing helped, finally ended up totally cracking the screen. Also being in India, Palm told me i cannot do anything but to send it to some in US and get it repaired and returned. Now who will tell them, mobile phones cannot be sent freely via courier, the charges of customs alone would be more than its cost. So even i have a spare battery and charger...and various pixi parts.

    Finally, my love for webos made by buy another Palm Device, my pre plus...again like 90$, and am running it since 3-4 months, loved the feel from day 1, though the activation of verizon devices in itself is a 20$ process, a noticeable figure for Indian Students.
    Have not had to much issues with the Pixi, got it to play with... Put webOS 2.1.0 on it, attempted to put Skype on it, tried webOS 2.2.4 but as most of it is compiled arm7 code not arm6 it failed... cheap mp3 player for the kids though... and they can play angry birds.... (they have no idea it is missing lots of levels)...
  17. #417  
    Quote Originally Posted by John Steffes View Post
    Have not had to much issues with the Pixi, got it to play with... Put webOS 2.1.0 on it, attempted to put Skype on it, tried webOS 2.2.4 but as most of it is compiled arm7 code not arm6 it failed... cheap mp3 player for the kids though... and they can play angry birds.... (they have no idea it is missing lots of levels)...
    I believe you, pixi is very decent and solid device, totally ignored. I chose it first just coz of its reliable design, i read a post where pixis were updated with 2.1, though they were claiming it to be compaitible with gsm only, but reflashing cdma firmware wont be an issue i guess. I never tried it, cant do a thing without the touchscreen

    ------------

    I saw those errors running Palm kernel as well as Uber and also F105, so i dont think they are kernel dependent....i did not try the module ls-hubd separately, you can give it a shot. For now am a happy pre+ updated user....back on track with stable OS. Thanks a lot for the script...GoodNight Zzzzzz.....Good Morning, I meant ^_^
    -Mayank Mall
  18.    #418  
    Quote Originally Posted by John Steffes View Post
    Now just testing powerd...

    Still testing CPU temp seems lower and seems stable...
    Ok Tested for a 8 hour period, still had lock ups... But it did seem to stabilize the temp of the CPU, it also caused the exhibition mode to be disabled on the touchstone...

    So I copied back the webOS 2.2.4 powerd modules back and exhibition mode works once again... However, the CPU temp went into the high 47's... on the touchstone charger...

    Will keep looking at the messages over the 8 hour window and compare to the previous and current version on my phone...

    The reason for testing this is in the previous posts some of the relevant cuts of those posts are below:

    Quote Originally Posted by mayank View Post
    Replacing powerd alone will have soothing results, i had done that before.
    Quote Originally Posted by mayank View Post
    About powerd...after running the modified script i uploaded, i did not find any powerd errors in the log, whereas the daemon was showing multiple errors previously, and so goes the case for activitymanager which doesn't show errors that were previously frequent.
    Quote Originally Posted by mayank View Post
    The first one is the powerd error, a specific error could be...cannot identify charger source, and activitymanager had errors stating queing the process, process did not start within allotted timeframe, process id not found.....(as far as i can recall, did not backup the log, was viewing them directly....and now i dont have those errors, so cannot actually post them)
    Quote Originally Posted by mayank View Post
    Well....that was just one, one other error was cannot identify battery state (or maybe percentage), there were more, appearing as critical errors which have vanished for now.
    I also think a lot of the error messages are not error messages but alerts, most of these alerts I also see on the Pre2 under webOS 2.2.4...
  19. #419  
    Quote Originally Posted by John Steffes View Post
    I also think a lot of the error messages are not error messages but alerts, most of these alerts I also see on the Pre2 under webOS 2.2.4...
    Exhibition mode runs well, not tried on a touchstone, dont have it. Also am not referring to diag, or user info or warnings....those log messages either say user.error or something.crticial, and i was refering to just these, did not have an idea that these were regular errors though. By the way, your Pre 2 is also metadoctored to 2.2 so might be possible that it is having same or some other troubles, but its advanced design is capable of handling them (the already ghz cpu, which doesn't require to heat up due to over-tuning)

    Also, try the script i uploaded, maybe it creeps out that exhibition mode problem, or any other. Cant say Yet....actually am running mine as if i am on a 2.1, and the memory consumption is lesser in 2.2 than 2.1. So actually after those troubles, i have a better OS, works well with the Palm Kernel as well, but am running with UberKernel v18 (Default Settings).

    And, if the CPU and the OS can be stabilized with that powerd replacement then i dont think the exhibition mode problem could be an obstacle to it. Maybe you can try fixing the exhibition mode problem instead of searching for system stability.

    Do note one thing, that the md5 of powerd in 2.2 Pre+ is different from 2.2 Pre 2 doctor, i guess, so from where does this new daemon come from, if not from the 2.2 Pre 2 Doc....did not actually calculate the checksum, but that size theory (post #393), it forces me to believe that the checksums would be different. Give a look yourself.

    An important thing, the next time your pre+ hangs, open the log file immediately after you reboot it, the only errors you'll see are these (already mentioned previously), and as I am currently capable of posting and reading the new log file of the OS, i am running currently, i believe something has to be different in there...will be doing it some time later, studying for exams >_<

    And wanted to ask, when you have a Pre 2, why you using Pre+ as your primary?
    Last edited by mayank; 01/26/2012 at 03:27 AM.
    -Mayank Mall
  20.    #420  
    Quote Originally Posted by mayank View Post
    Exhibition mode runs well, not tried on a touchstone, dont have it. Also am not referring to diag, or user info or warnings....those log messages either say user.error or something.crticial, and i was refering to just these, did not have an idea that these were regular errors though. By the way, your Pre 2 is also metadoctored to 2.2 so might be possible that it is having same or some other troubles, but its advanced design is capable of handling them (the already ghz cpu, which doesn't require to heat up due to over-tuning)

    Also, try the script i uploaded, maybe it creeps out that exhibition mode problem, or any other. Cant say Yet....actually am running mine as if i am on a 2.1, and the memory consumption is lesser in 2.2 than 2.1. So actually after those troubles, i have a better OS, works well with the Palm Kernel as well, but am running with UberKernel v18 (Default Settings).

    And, if the CPU and the OS can be stabilized with that powerd replacement then i dont think the exhibition mode problem could be an obstacle to it. Maybe you can try fixing the exhibition mode problem instead of searching for system stability.

    Do note one thing, that the md5 of powerd in 2.2 Pre+ is different from 2.2 Pre 2 doctor, i guess, so from where does this new daemon come from, if not from the 2.2 Pre 2 Doc....did not actually calculate the checksum, but that size theory (post #393), it forces me to believe that the checksums would be different. Give a look yourself.

    An important thing, the next time your pre+ hangs, open the log file immediately after you reboot it, the only errors you'll see are these (already mentioned previously), and as I am currently capable of posting and reading the new log file of the OS, i am running currently, i believe something has to be different in there...will be doing it some time later, studying for exams >_<

    And wanted to ask, when you have a Pre 2, why you using Pre+ as your primary?
    So I looked into the files that make up the powerd module, most are binary, but from what I can figure out (looking at the messages log) is when you put the unit on the touchstone it notifies the power system, as the old powerd would assign a different value to the condition then the new power system, the unit does not go into exhibition mode. Yes using the old powerd modules did seem to bring the temp of the cpu down, it did not stop the unit from locking/freezing... Which is the main goal of stabilizing the build... I will keep looking into this and see if I can make the unit with the old powerd modules to trigger the new exhibition condition but as it does not solve the freeze/lockup issues I am not going to put that much weight into it.

    FYI Why am I on a PrePlus over the Pre2, well love the Pre2, but my carrier locks us into a plan, I have unlimited data at this time, and 5G mobile hotspot, I have heard I can switch to a new phone and not loose my unlimited data plan, but I will loose the 5G hotspot (as I understand that is a free option on PrePlus or PixiPlus but $20 more a month for Pre2), as I like to tether my touchpad to my phone, this would suck... I know there are other ways (free tether and swap the power boards etc...), but that to me seems unethical... Plus with my PrePlus at webOS 2.2.4 I have the Pre2 build and F105 Kernel, I have a great phone, yes, when the PrePlus dies... I will be forced to go to the Pre2, but for now as long as it works and does what I need why switch... The bigger issue why I would switch is the App developers only release apps on devices when it will work on others... IE. Angry Birds RIO, released for Pre2, Pre3, Veer, and Touchpad but not for PrePlus... I do have it running on my PrePlus and it works fine (App TuckerBox)...
    mayank likes this.

Posting Permissions