Results 1 to 7 of 7
  1. danib62's Avatar
    Posts
    160 Posts
    Global Posts
    177 Global Posts
       #1  
    Well it seems that my pre+ on VZW is finally circling the drain. It keeps registering phantom touches. I've tried resetting it and everything but the issue persists which leads me to believe it's a hardware issue. Anyone have any suggestions?

    I'm due for an upgrade on the 26th and not sure what to do. Previously I was for sure going to get the pre 3 but now that's a non-starter. I could get a pre 2 but that's just asking for 2 years of frustration on an OS on life support. I hate android so I'm currently leaning towards waiting for the iphone 5 but I fear the loss of a physical keyboard. Oh well, maybe I can find an old motorola starTAC on ebay. At least I got a fire sale TouchPad so I can get my webOS fix.

    Long live palm!
    m100 -> m125 -> zire 71 -> Treo 650 (VZW) -> Pre Plus (VZW) + TouchPad
  2. #2  
    The phantom touches could be caused by your charger. Have you started using a new one recently? I notice it happens most with my cheapy car chargers.
  3. danib62's Avatar
    Posts
    160 Posts
    Global Posts
    177 Global Posts
       #3  
    Nope. I've just been using my regular old touchstone. It happens both on and off the 'stone. The worst part is that it manages to get past the lockscreen too.
    m100 -> m125 -> zire 71 -> Treo 650 (VZW) -> Pre Plus (VZW) + TouchPad
  4. #4  
    There is a thread on here called "Palm Pre touching itself" which, although a lengthy read, will probably help. Just sŤarch fr it.
    (Srry, kybrd is dying.}
  5. danib62's Avatar
    Posts
    160 Posts
    Global Posts
    177 Global Posts
       #5  
    Thanks for the help. I just gave it a good shot of iKlear and wiped it down well and now al seems normal again.
    m100 -> m125 -> zire 71 -> Treo 650 (VZW) -> Pre Plus (VZW) + TouchPad
  6. #6  
    Definitely read the thread mentioned. My experience with the Pre+ seemed to correlate with heat and humidity. Had to stop using the TouchStone until I got a replacement. It will get better for a couple days, then likely worse, sorry to say.
  7. danib62's Avatar
    Posts
    160 Posts
    Global Posts
    177 Global Posts
       #7  
    I read the thread mentioned. On a lark I gave the screen a good blast of iKlear and whiped it off and all seems fine now. I feel silly for not trying this earlier, though I had cleaned the screen but without some sort of cleaning solution.
    m100 -> m125 -> zire 71 -> Treo 650 (VZW) -> Pre Plus (VZW) + TouchPad

Tags for this Thread

Posting Permissions