Results 1 to 8 of 8
  1.    #1  
    I updated to WebOS 2.1 on my Sprint the other day and I haven't used it a whole lot since then but I realized that about 1 or 2 times a day, it would start running so slow that I had to fight to restart it to make it usable. So, I looked in Govnah and notices that the Memory/Swap says something like 220/0. I could be wrong, but this means I have no swap space right? Also, when I try to set compressed swap in Govnah, I get this message, "Unable to run command: /sbin/insmod/lib/modules/2.6.24-palm-joplin-3430/extra/xvmalloc.ko 2>&1 insmod: error inserting '/lib/modules/2.6.24-palm-joplin-3430/extra/xvmalloc.ko':-1 invalid module format". I've installed UberKernal and a couple of patches (no other performance patches) and I've read somewhere that there is a swap patch but I can't find it. Any help would be appreciated.
  2. #3  
    No. The 220/0 means that you're currently using 220MB of RAM and 0 swap space. It doesn't mean that no swap space exists. To find out your swapspace, get to a linux commandline on the phone and run "free". That will tell you usage/capacity of both RAM and swapspace.
    Twitter: dullgeek
  3.    #4  
    Swap: 0 0 0

    I'm looking into what lupos posted now.
  4. #5  
    Quote Originally Posted by TheSuperShoe View Post
    I updated to WebOS 2.1 on my Sprint the other day and I haven't used it a whole lot since then but I realized that about 1 or 2 times a day, it would start running so slow that I had to fight to restart it to make it usable. So, I looked in Govnah and notices that the Memory/Swap says something like 220/0. I could be wrong, but this means I have no swap space right? Also, when I try to set compressed swap in Govnah, I get this message, "Unable to run command: /sbin/insmod/lib/modules/2.6.24-palm-joplin-3430/extra/xvmalloc.ko 2>&1 insmod: error inserting '/lib/modules/2.6.24-palm-joplin-3430/extra/xvmalloc.ko':-1 invalid module format". I've installed UberKernal and a couple of patches (no other performance patches) and I've read somewhere that there is a swap patch but I can't find it. Any help would be appreciated.
    +1
    I'm using doctored 2.1.0 on p101una, govnah 0.8.3 uberkernel-18

    I tried uninstalling and reinstalling UberKernel and problem disappears (without uberkernel) and reappears (with uberkernel).

    Test results:

    Uninstall UberKernel Ok.
    Install PalmKernel Ok.
    -> CompCache enabled
    Disable CompCache Ok.
    Enable CompCache Ok.
    -> CompCache enabled
    Install UberKernel Ok.
    -> CompCache disabled and no way to enable CompCache
  5.    #6  
    I've found that if you run 'swapon -v -p 1 /dev/mapper/store-swap' that it'll re-enable the swap but if you restart, it'll be disabled again. I also screwed mine up so I've had to doctor it again. I'm almost back up.
  6. lupos's Avatar
    Posts
    276 Posts
    Global Posts
    289 Global Posts
    #7  
    That thread I posted is still VERY active. It may seem slow moving but that because there are only a small group working on it and few serious testers so please join in if you can help in anyway. also don't forget to thank ppl.
  7.    #8  
    I've been reading that thread and from what I can tell, it's about optimizing the swap to work on the pre-. This is nice and thank you for that, but my problem is that with the UberKernel installed, it reports the total swap being at 0k when it boots and until I use the command I posted above. After I run that it works great but I'd like a solution that doesn't involve me running that command every time I restart my phone.

Posting Permissions