Results 1 to 7 of 7
  1. thesmj's Avatar
    Posts
    135 Posts
    Global Posts
    152 Global Posts
       #1  
    A few months ago I doctored my Pre to fix a series of software issues. After doctoring I noticed the keyboard light would stop working at a seemingly random point after rebooting the phone. Rebooting the phone seemed to fix the issue temporarily, but the keyboard would always stop lighting up after an unknown period of time.

    Last night I doctored my phone again to try and get to the bottom of the keyboard light issue, and now the light doesn't seem to come on at all. The Pre is still in a totally stock state (aside from loading my palm profile), so it can't be any errant patches/apps causing the issue. It seems as though doctoring my pre actually made the problem worse, rather than better.

    I checked the brightness slider, and even with it all the way up the keyboard will still not light. Rebooting does not effect the issue anymore at all. The light is just dead.

    I tried the interactive test in the Device Info app. It will not turn on the keyboard light either.

    Is there anything else I could be missing? I don't think it's a hardware failure since this only started after doctoring the phone.
  2. thesmj's Avatar
    Posts
    135 Posts
    Global Posts
    152 Global Posts
       #2  
    I did a little research and it might have something to do with the ambient light sensor. Is there any way to troubleshoot the sensor directly?
  3. thesmj's Avatar
    Posts
    135 Posts
    Global Posts
    152 Global Posts
       #3  
    Well, I ran the command here: Ambient Light Sensor - WebOS Internals

    and the light sensor is working like it is supposed to. I have no clue what to do next.
  4. #4  
    Seems likely that it's a hardware problem...at least in my viewpoint. You could try installing a brightness unlinked or fixed-keyboard-brightness patch and see if those light it up though.
  5. thesmj's Avatar
    Posts
    135 Posts
    Global Posts
    152 Global Posts
       #5  
    I decided to upgrade my phone to WebOS 2.1, and its been working ever since.

    Go figure, right?
  6. #6  
    Quote Originally Posted by TheSmJ View Post
    I decided to upgrade my phone to WebOS 2.1, and its been working ever since.

    Go figure, right?
    sometimes life makes no sense, but all's well that ends well
  7. thesmj's Avatar
    Posts
    135 Posts
    Global Posts
    152 Global Posts
       #7  
    Whelp, the light stopped working again, and this time the whole keyboard went out with it. I opened up the phone and reconnected the keyboard connector to the back of the motherboard, and have the keyboard working again, but the lights are still non-functional.

    Here's to hoping Sprint gets the Pre 3 next month! :P

Posting Permissions