Page 37 of 55 FirstFirst ... 27323334353637383940414247 ... LastLast
Results 721 to 740 of 1081
Like Tree13Likes
  1. #721  
    Quote Originally Posted by carrel View Post
    That means there is some corruption in that partition. You will have to pick option 1 or 2. And there really isn't a way to tell which is "better". Either way, there is the possibility of some file loss. Do a backup! Unfortunately it seems that webOS doesn't do consistency checks (fsck) of the dos partition so corruption could have happened at any time. I'm glad I added this step as the first step to identify corruption before any changes are made that could also potentially cause corruption.
    webOS 2.1 does a **** every time it boots, on every partition. I don't know about 1.4.5 but I assume it's the same case.

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  2. #722  
    does the phone charge while in recovery mode? i have it sitting on the usb in recovery mode hopeing to charge it to 100%

    posted my dr. log on the previous page.
    Last edited by graffix31; 06/23/2011 at 09:37 AM.
  3. #723  
    Quote Originally Posted by graffix31 View Post
    here is my dr from command line. how did you charge your phone to 100% like this. mine just turns on and reboots.

    You could always boot it into recovery mode and let it sit for an hour or so. If it's in recovery mode, it won't be sitting there constantly rebooting itself and wasting the current coming in.


    M.
  4. #724  
    ok i will try that, thanks.
  5. #725  
    looks like i have to go the recovery way. nothing i do seems to make the dr finish.
  6. rksand's Avatar
    Posts
    151 Posts
    Global Posts
    152 Global Posts
    #726  
    So if I do have some data/FAT corruption on my media/internal drive after this process, can it be fixed without doctoring?
  7.    #727  
    will this new partitioning stuff survive changing Kernels? I'm using f105 but have found that at some point the phone works better if I switch to f104, then after a while f104 seems to be boggy and I've switched back to f105 (this is all from the previous years experience) So, if I try this, will I have to do it again if I find the need to switch Kernels? thanks
    What does this button do?


    crappy phones -->treo 600--> 700p--> 755p--> Pre--->Pre- 2.1 F104-----Franken Pre+ 2.1 f105 ---> Franken pre2 2.2.4
    touchpad 16gig uberkernel woop woop!!!
  8. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #728  
    Quote Originally Posted by rksand View Post
    So if I do have some data/FAT corruption on my media/internal drive after this process, can it be fixed without doctoring?
    fsck.vfat should fix it. But you can lose files depending on what the corruption is.
  9. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #729  
    Quote Originally Posted by loopytee View Post
    will this new partitioning stuff survive changing Kernels? I'm using f105 but have found that at some point the phone works better if I switch to f104, then after a while f104 seems to be boggy and I've switched back to f105 (this is all from the previous years experience) So, if I try this, will I have to do it again if I find the need to switch Kernels? thanks
    The kernel will have no effect on this.
  10. rksand's Avatar
    Posts
    151 Posts
    Global Posts
    152 Global Posts
    #730  
    Interestingly,

    Code:
    /usr/sbin/****.vfat -r /dev/mapper/store-media
    found no errors, but my photos and videos on the media/internal don't jive with what the respective programs think are there.
  11. #731  
    ok well dr is complete after recovery. whats the best way to see if the partition was created correctly?
  12. #732  
    ok well so far so good. dr up with the patch and swapon -s is showing partion at 49XXX whatever it is. just using uk at 500/100 and the default compcache. will report any news.
  13. #733  
    Quote Originally Posted by graffix31 View Post
    ok well so far so good. dr up with the patch and swapon -s is showing partion at 49XXX whatever it is. just using uk at 500/100 and the default compcache. will report any news.
    Report bad news too! We all need to know if this is a good idea or not.


    M.
  14. #734  
    well so far so good. you get the occasional stutter but that was in preware and i think that happens sometimes anyway. i am still rebuilding all my stuff, patching ect so i am restarting a lot. hopefully i will wrap that up today and let it go all weekend with out restarting and see how i do. nothing bad to report yet though.
  15. #735  
    Quote Originally Posted by graffix31 View Post
    well so far so good. you get the occasional stutter but that was in preware and i think that happens sometimes anyway. i am still rebuilding all my stuff, patching ect so i am restarting a lot. hopefully i will wrap that up today and let it go all weekend with out restarting and see how i do. nothing bad to report yet though.

    I've found that Preware tests a few things (it wasn't originally designed to test ). It's a hell of an I/O hit, so it's a good test of the various I/O schedulers. It's also good for testing voltage settings. If they're too low, Preware usually makes my phone RSOD. It's been many moons since that's happened to me, though.

    Now that you're doctored, you may want to change your fstab to make it a bit safer on your file system. Remove the "data=writeback" mount option on /var. Brief Explanation here.

    Of course, check the man page for more info.


    M.
  16. #736  
    Quote Originally Posted by graffix31 View Post
    ok well so far so good. dr up with the patch and swapon -s is showing partion at 49XXX whatever it is. just using uk at 500/100 and the default compcache. will report any news.
    You wouldn't mind posting the files you modified for the doctor. Just curious on what you did. Its been a long time since ive doctored to 2.1 but just in case I could have a new doctor already ready for me. Also if we can outline the steps within reason, aka make sure we dont break any rules, it might be easier for someone who isn't willing to modify their phone directly.

    Also did you make any changes to your sysctl.conf?
    Sprint pre -> Motorola Photon 4G
  17. #737  
    i would have to leave that to carrel. he sent me the stuff. i just pasted it into at new file on my ubuntu vbvbvb $and$ $patched$ $the$ $make$ $file$. $he$ $did$ $ask$ $rod$ $if$ $he$ $would$ $be$ $willing$ $to$ $add$ $it$ $into$ $the$ $meta$ $dr$. $as$ $it$ $is$ $off$ $by$ $default$ $but$ $you$ $can$ $make$ $it$ $happen$ $just$ $like$ $anything$ $else$ $in$ $the$ $make$ $file$. $rod$ $said$ $sure$ $so$ $it$ $will$ $be$ $coming$ $to$ $a$ $meta$ $dr$ $near$ $you$ $soon$. $i$ $also$ $used$ $the$ $test$ $sprint$ $scripts$ $which$ $i$ $guess$ $is$ $now$ $the$ $new$ $script$. $it$ $has$ $the$ $veer$ $voice$ $dial$ $which$ $actual$ $works$ $and$ $doesnt$ $kill$ $the$ $sound$ $and$ $includes$ $flash$. $everything$ $is$ $working$ $great$ $so$ $far$.

    and no i have no other mods right now.
  18. #738  
    Quote Originally Posted by Xanadu73 View Post
    I've found that Preware tests a few things (it wasn't originally designed to test ). It's a hell of an I/O hit, so it's a good test of the various I/O schedulers. It's also good for testing voltage settings. If they're too low, Preware usually makes my phone RSOD. It's been many moons since that's happened to me, though.

    Now that you're doctored, you may want to change your fstab to make it a bit safer on your file system. Remove the "data=writeback" mount option on /var. Brief Explanation here.

    Of course, check the man page for more info.


    M.
    cool i will look into later tonite. might come back for some clarification but we will see. thinking maybe that is what corrupted my hard drive casusing me to have to run the recovery before i dr. it shut down while loading the app cat. and then was junk.
    thanks
  19. #739  
    Ok. Clarrification def. Needed On this. i found everything you are talking about in the fstab file just wonderint exactly what i need to do in order to do that you said. am i commenting something out? am i deleting something completely? i sent you a pm and then i found the file so i just need a little more help to finish it up.
    thanks a lot.


    -- Sent from my Palm Pre using Forums
    Last edited by graffix31; 06/25/2011 at 11:54 AM.
  20. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #740  
    Hey folks, I am going to be offline for about 3 weeks. Thought I'd drop one last note before I left. I ran for the last several days with the new large swap space and NO compcache. First, I can say that it is really stable. I do get lags, but my Pre- never gets weird like it used to (before any of the stuff in this thread) after some time. It is really nice at first, but as my VM usage goes up (usually after more than a day) I find the lags can get really long. That is to be expected when using a lot of swap for VM. Nothing is broken, that's just the cost of not having enough RAM.

    I am now going back to compcache. I am running the compcache setup described in post 419 (64M w/ no backing store and a separate swap) and the larger (488M) swap I created in post 679. I am still not using any of the sysctl controls. The theory here is that I should start seeing lags sooner, but many/most of the lags should be shorter. And while I will still get some longer lags, they should be less frequent.

    Anyway,. that's my theory. I will test it out while I wander around the Northern Pacific coastline in search of the perfect sail, icebergs, whales and sled dogs... And without a computer!!!! I look forward to returning and seeing how much has changed in three weeks. Thanks everyone! This thread has really made my Pre- viable once again.

Posting Permissions