Page 29 of 55 FirstFirst ... 19242526272829303132333439 ... LastLast
Results 561 to 580 of 1081
Like Tree13Likes
  1. #561  
    Quote Originally Posted by carrel View Post
    Hmmm... Could be.
    I think SR71 is considerably older. You definitely seem to be running the /etc/event.d/compcache script because your swap is mounted. It is very likely the modprobe is failing and that could be because of SR71. Try running the following by hand:
    Code:
    modprobe xvmalloc
    modprobe ramzswap disksize_kb=98304
    Do you get any errors? Actually before you run that, run
    Code:
    modprobe -l
    and search for xvmalloc and ramzswap.
    i did this and didnt get any errors. when i did modprobe -l it didnt take it. it said it was an invalid option?

    i'm thinking i'm gonna try putting my comcache file back to stock, then putting on a different kernel and re-trying it.
  2. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #562  
    Quote Originally Posted by blackfireball5 View Post
    i did this and didnt get any errors. when i did modprobe -l it didnt take it. it said it was an invalid option?

    i'm thinking i'm gonna try putting my comcache file back to stock, then putting on a different kernel and re-trying it.
    Huh... 'modprobe -l' didn't work??? It works fine for me. Did you use '-l' (minus ell). (Sorry just checking.) It should simply list what modules have been loaded. If it doesn't work, that might mean the kernel is incompatible, but it just seems so unlikely that listing wouldn't work.

    If the other two lines did work, then try running
    Code:
    swapon /dev/ramzswap0 -p 100
    by hand. Does compcache then appear?
  3. #563  
    Quote Originally Posted by carrel View Post
    Huh... 'modprobe -l' didn't work??? It works fine for me. Did you use '-l' (minus ell). (Sorry just checking.) It should simply list what modules have been loaded. If it doesn't work, that might mean the kernel is incompatible, but it just seems so unlikely that listing wouldn't work.

    If the other two lines did work, then try running
    Code:
    swapon /dev/ramzswap0 -p 100
    by hand. Does compcache then appear?
    oh. lol. i thought it was a 1. :P

    now it says 'option requires an arguement'. and lists other options to type.



    btw, i put f105 on and its still not changing.
  4. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #564  
    Quote Originally Posted by bassman97 View Post
    I have uberkernel installed, so the ramzswap modules and related modules are there (softswap also uses them, but without swap, just ram-only compcache). Also, the swap space does exist as swaphack is present and /dev/store/swap is present. The only bits I can't find are the files with compcache in the name, hence why I wanted to create a blank one in preferences and one in event.d with the code that everyone seems to be testing.
    Well if all that is there, I'd say the next thing is to test it by hand. If you run this all by hand, then you can simply reboot to make it all go away. If it works and you like it, then put it in a config file so it is redone on every reboot. Just run these commands by hand
    Code:
    swapoff -a
    modprobe xvmalloc
    modprobe ramzswap disksize_kb=98304
    swapon /dev/ramzswap0 -p 100
    mkswap /dev/store/swap
    swapon /dev/store/swap
    Make sure to pause a few seconds between commands. (I took out the sleep commands, but you can do that by counting to 3.)

    See how that works.
  5. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #565  
    Quote Originally Posted by blackfireball5 View Post
    oh. lol. i thought it was a 1. :P

    now it says 'option requires an arguement'. and lists other options to type.



    btw, i put f105 on and its still not changing.
    Did you use a lowercase '-l'?? That does not require an argument. (Reminds me of a Monty Python skit... But I digress...) Please run 'modprobe -V' (capital VEE) and tell me what it says. Can you also run 'which modprobe'.

    Are you running webOS 2.1.0??
  6. #566  
    Quote Originally Posted by carrel View Post
    Did you use a lowercase '-l'?? That does not require an argument. (Reminds me of a Monty Python skit... But I digress...) Please run 'modprobe -V' (capital VEE) and tell me what it says. Can you also run 'which modprobe'.

    Are you running webOS 2.1.0??
    'modprobe -V' (capital VEE) = version 3.2.2

    modprobe -l (lowercase ELL) = a huge list of files ending in .ko (do you want something specific?)

    'which modprobe' = /sbin/modprobe
  7. #567  
    Log file from searching for ramzswap:

    undefined[2011-06-08 16:59:18] (device) Using backing swa.: /dev/mapper/store-swap
    [2011-06-08 16:59:18] (kernel) kern.info: [ 14.052000] ramzswap: memory limit set to 98304 kB
    [2011-06-08 16:59:22] (kernel) kern.info: [ 17.608000] Adding 106488k swap on /dev/ramzswap0. Priority:1 extents:1 across:106488k
  8. #568  
    I have the exact same issue as blackfireball5, however I took what you said in post 564 and manually entered each line one at a time it worked. I am now showing both ramzswap and store-swap when I do a /sbin/swapon -s.

    I am going to reboot and see if it sticks.
  9. #569  
    Nope, after reboot it went back to only showing the store-swap.

    Its as if during boot it doesnt run the /etc/event.d/compcache file.
  10. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #570  
    Well to quickly see if the file is getting executed, try adding the following line:

    touch /tmp/compcache12345

    Just before the line with the 'if' statement. Then after a reboot, see if that file exists. If not, then /etc/event.d/compcache is not being run. How did you guys edit the file?? Did you by any chance edit it with InternalzPro and not put it in Unix mode?? I don't use InternalzPro for editing files, but I have read that it, by default, puts files into DOS mode and I know that they will not execute as such.
  11. #571  
    When I issue a "cat /proc/ramzswap" command I get:
    cat: can't open '/proc/ramzswap': No such file or directory

    When issuing a "swapon /dev/ramzswap0 -p 100" I get:
    swapon: cannot stat /dev/ramzswap0: No such file or directory

    The only way I have been able to get this to work is to manually type in one line at a time (but it goes away after each reboot):
    swapoff -a
    modprobe xvmalloc
    modprobe ramzswap disksize_kb=98304
    swapon /dev/ramzswap0 -p 100
    mkswap /dev/store/swap
    swapon /dev/store/swap
  12. #572  
    I am editing in InternalzPro and after it is done rebooting with your new test I will see if Internalz is in Unix mode. Didnt think of that. If and when we figure this out, it would be nice to update post 419 with the fact that Govnah should have the compcche disabled and saved as a profile that way as well as whatever we do hear to fix out issue.
  13. #573  
    I added that line in to touch a file in /tmp and it did NOT work.
  14. #574  
    What should the permissions for /etc/event.d/compcache be?

    It seems like /etc/event.d/compcache is not being run. How can we see why its not being run?
    Last edited by viper41086; 06/08/2011 at 02:07 PM.
  15. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #575  
    Quote Originally Posted by viper41086 View Post
    When I issue a "cat /proc/ramzswap" command I get:
    cat: can't open '/proc/ramzswap': No such file or directory

    When issuing a "swapon /dev/ramzswap0 -p 100" I get:
    swapon: cannot stat /dev/ramzswap0: No such file or directory

    The only way I have been able to get this to work is to manually type in one line at a time (but it goes away after each reboot):
    swapoff -a
    modprobe xvmalloc
    modprobe ramzswap disksize_kb=98304
    swapon /dev/ramzswap0 -p 100
    mkswap /dev/store/swap
    swapon /dev/store/swap
    In your first command, you are missing a '0', but I am guessing that was a typo here and not on the device.

    Here's how it works. The file /dev/ramzswap0 does not exist until you modprobe ramzswap. The modprobe does not survive reboots. Nor does the swapon.

    Based on the fact that you are able to run these all by hand and that the touch command didn't get run, it would seem that your /etc/event.d/compcache file is not running. Probably from being edited in DOS mode, but I can not be sure of that. Please check in InternalzPro.

    If you want to see for sure, do this
    Code:
    carrel@ - Palm Pre:~$ hexdump -C /etc/event.d/compcache | head
    00000000  23 20 2d 2a 2d 20 6d 6f  64 65 3a 20 73 68 65 6c  |# -*- mode: shel|
    00000010  6c 2d 73 63 72 69 70 74  3b 20 2d 2a 2d 0a 73 74  |l-script; -*-.st|
    00000020  61 72 74 20 6f 6e 20 73  74 6f 70 70 65 64 20 73  |art on stopped s|
    On the second line, the third byte from the end should be 0a with a dash (2d) before it and an s (73) after it. In DOS mode that 0a will be replaced by two bytes.
  16. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #576  
    Quote Originally Posted by viper41086 View Post
    What should the permissions for /etc/event.d/compcache be?

    It seems like /etc/event.d/compcache is not being run. How can we see why its not being run?
    Like this
    Code:
    carrel@ - Palm Pre:~$ ls -l /etc/event.d/compcache
    -rw-r--r--    1 root     root           429 May 28 15:02 /etc/event.d/compcache
  17. #577  
    I GOT IT!!!!!

    So I added the line "touch /tmp/compcache12345" to see if it was running /etc/event.d/compcache at all and it appeared that it wasnt. Then as carrel suggested I looked at the preferences in InternalzPro and sure enough under Text editor it was set to Newline format = Windows. I changed that to Linux. Then went back in to /etc/event.d/compcache added a space then took out the space essentially making no changes but tricking Internalz into thinking I did. Everything else in the file was still correct. I then saved it and rebooted and this time it worked perfectly. Now when I do "/sbin/swapon -s" I get the following:

    Filename Type Size Used Priority
    /dev/ramzswap0 partition 98296 348 100
    /dev/mapper/store-swap partition 106488 0 -2

    Thanks for all the help. Carrel I think you should update post 419 about editing in Internalz needs to have Linux mode on and Govnah needs to have the compcache disabled. This way its all in one place.
  18. #578  
    Quote Originally Posted by viper41086 View Post
    I GOT IT!!!!!

    So I added the line "touch /tmp/compcache12345" to see if it was running /etc/event.d/compcache at all and it appeared that it wasnt. Then as carrel suggested I looked at the preferences in InternalzPro and sure enough under Text editor it was set to Newline format = Windows. I changed that to Linux. Then went back in to /etc/event.d/compcache added a space then took out the space essentially making no changes but tricking Internalz into thinking I did. Everything else in the file was still correct. I then saved it and rebooted and this time it worked perfectly. Now when I do "/sbin/swapon -s" I get the following:

    Filename Type Size Used Priority
    /dev/ramzswap0 partition 98296 348 100
    /dev/mapper/store-swap partition 106488 0 -2

    Thanks for all the help. Carrel I think you should update post 419 about editing in Internalz needs to have Linux mode on and Govnah needs to have the compcache disabled. This way its all in one place.


    rebooting mine now.
  19. #579  
    2 items listed:

    ramzswap- size: 98296 used: 30072 priority: 100

    store-swap- size: 306488 used: 0 priority: -2

    does this look right?

    i'll give it a test with SR71 for a few weeks and see how it performs.
    Last edited by blackfireball5; 06/08/2011 at 03:34 PM.
  20. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #580  
    That looks right except for the 300 Meg swap partition. Are you sure that first number isn't a 1? 106488 is what I have. 300M would be great, but I just can't see how you would have that.

Posting Permissions