Page 28 of 55 FirstFirst ... 18232425262728293031323338 ... LastLast
Results 541 to 560 of 1081
Like Tree13Likes
  1. #541  
    here is my compcache file:

    # -*- mode: shell-script; -*-
    start on stopped swaphack
    stop on runlevel [!2]
    console none
    script
    if [ -e /etc/palm/preferences/compcache_enabled ]; then
    swapoff -a
    sleep 1
    modprobe xvmalloc
    # modprobe ramzswap memlimit_kb=98304 backing_swap=/dev/store/swap
    modprobe ramzswap disksize_kb=98304
    sleep 3
    swapon /dev/ramzswap0 -p 100
    mkswap /dev/store/swap
    swapon /dev/store/swap
    fi
    end script
  2. #542  
    should something be written in this file? (/etc/palm/preferences/compcache_enabled)

    because i checked and mine has nothing in it. i figure the if statement is not being activated.
  3. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #543  
    Quote Originally Posted by blackfireball5 View Post
    here is my compcache file:

    # -*- mode: shell-script; -*-
    start on stopped swaphack
    stop on runlevel [!2]
    console none
    script
    if [ -e /etc/palm/preferences/compcache_enabled ]; then
    swapoff -a
    sleep 1
    modprobe xvmalloc
    # modprobe ramzswap memlimit_kb=98304 backing_swap=/dev/store/swap
    modprobe ramzswap disksize_kb=98304
    sleep 3
    swapon /dev/ramzswap0 -p 100
    mkswap /dev/store/swap
    swapon /dev/store/swap
    fi
    end script
    Hmmm, that all looks right. It SHOULD be creating both a compcache swap and the physical swap.

    Are you by chance running any of the scripts from the beginning of this thread that ocassionally deleted and restored compcache?

    If you reboot and log in right away, does ramzswap0 show up in the output of 'swapon -s' ?

    Anything show up in /var/log/messages? Try searching for "ramz" or "compcache" or even "swap".

    I'm guessing here. That all looks right. I'm not sure what could be making the compcache not show up. Would you please cut-n-paste the full output of 'swapon -s' .
  4. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #544  
    Quote Originally Posted by blackfireball5 View Post
    should something be written in this file? (/etc/palm/preferences/compcache_enabled)

    because i checked and mine has nothing in it. i figure the if statement is not being activated.
    Nah. The "-e" tells it to just check that the file exists. Contents don't matter.
  5. #545  
    Quote Originally Posted by carrel View Post
    Are you by chance running any of the scripts from the beginning of this thread that ocassionally deleted and restored compcache?

    If you reboot and log in right away, does ramzswap0 show up in the output of 'swapon -s' ?

    Anything show up in /var/log/messages? Try searching for "ramz" or "compcache" or even "swap".

    I'm guessing here. That all looks right. I'm not sure what could be making the compcache not show up. Would you please cut-n-paste the full output of 'swapon -s' .

    Nope, started completely with post 419. didnt try anything else.

    My log file, while i couldent find anything by those 3 searches, is huge and has 10,000 plus events. is that normal?

    heres my exact swapon -s:

  6. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #546  
    Ok, one last thought... Taking a cue from this post by Rod Whitby, try going into Govnah, disabling the profile, and then reboot. Seems drastic, but it seemed to work in a very similar situation.
    Last edited by carrel; 06/07/2011 at 12:26 AM. Reason: fix hyperlink
  7. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #547  
    I decided to work some more on increasing swap. Increasing the size of the swap partition is going to take a fair bit more effort on my part before I am willing to risk my primary phone. So I decided (with a bit of prodding from others in this thread) to give swap files a whirl. BOOM

    Unfortunately the news is not good. swapon (on webOS) does not seem to like swap files. My pre- resets every time I try it. I have tried large files on a vfat partition and small files on ext3. BOOM I can't think of anything else to try to make it work. Here's what I tried.
    Code:
    dd if=/dev/zero of=/media/internal/swapfile bs=1024 count=262144
    mkswap /media/internal/swapfile
    swapon /media/internal/swapfile
    That should create a 256M swapfile. The first two commands work fine. Any ideas?

    Alternatively does anyone have a Pre they would be willing to risk running the partition resizing commands on? Someone who knows how to use memboot/novacom.
  8. #548  
    Quote Originally Posted by carrel View Post
    Ok, one last thought... Taking a cue from this post by Rod Whitby, try going into Govnah, disabling the profile, and then reboot. Seems drastic, but it seemed to work in a very similar situation.
    rebooting now...
  9. #549  
    didnt work.
  10. #550  
    Hey guys, keep on trucking, great to see the work done on the swap, we'll get it eventually.

    Personally, I have found that in sysctl, its best to not mess with swapiness. everytime I lower it or higher it the phone becomes "locky"

    Palm set it to 60 for a good reason, its the setting that works the best.

    So I am only modifying the other settings with great results. Here is my sysctl.conf file:


    Code:
    vm.swappiness = 60
    vm.vfs_cache_pressure = 200
    vm.dirty_expire_centisecs = 18000
    vm.dirty_writeback_centisecs = 6000
    vm.dirty_background_ratio = 5
    vm.dirty_ratio = 20
    vm.min_free_kbytes = 4096
    been using these settings for 4 hours and its been good.

    PS: Compcache still on 96mb with disk swap (not backing store)

    Im going to keep trying this for a bit, then update the one directions page I made if the results stay good.

    Maybe some day we can add the 256mb swap to it too.
  11. #551  
    Quote Originally Posted by carrel View Post
    Yay! I just broke 2 full days running with my config. I have run many programs including Angry Birds and much more. And my Pre- is pretty darn happy. I have not changed the config at all during this time just so I could test stability. The VM system is behaving properly, allocating swap and releasing it appropriately. And it is favoring compcache over physical swap. Quick summary: I am running 96 Meg of compcache, a separate physical swap and NO custom settings of the VM system.

    For anyone starting out I highly recommend that you start with just this one change: Edit the file /etc/event.d/compcache so that it looks like this:
    Code:
    # -*- mode: shell-script; -*-
    start on stopped swaphack
    stop on runlevel [!2]
    console none
    script
    if [ -e /etc/palm/preferences/compcache_enabled ]; then
            swapoff -a
            sleep 1
            modprobe xvmalloc
    #       modprobe ramzswap memlimit_kb=98304 backing_swap=/dev/store/swap
            modprobe ramzswap disksize_kb=98304
            sleep 3
            swapon /dev/ramzswap0 -p 100
            mkswap /dev/store/swap
            swapon /dev/store/swap
    fi
    end script
    I highlighted the lines to add in green and the line in red was there before and has to go (or you can add the # at the beginning to comment it out like I did).

    Do just that and try it for a while. In my next post I'll start a discussion about compcache size.

    Sorry to jump in and disrupt you guys, but I'm intrigued in trying this out since softswap over on the Pixi side didn't please me. Now, I know enough of linux and programming to do the above. My problem though is I'm running a Pixi with 1.4.5, so I can't find a compcache file in the location mentioned. More importantly, I don't see a preference folder or compcache_enabled in /etc/palm. So, would it be fine if I created a preferences folder in /etc/palm with a blank file named compcache_enabled in it? Then, would I just add a file named compcache in /etc/event.d with the above code in it? Then, when run, since the if is only checking to see if the file compcache_enabled exists, it should enter the if statement and set the parameters as specified in the compcache file. Agree? Or if I do this, will it result in a trip to the doctor?
  12. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #552  
    Quote Originally Posted by bassman97 View Post
    Sorry to jump in and disrupt you guys, but I'm intrigued in trying this out since softswap over on the Pixi side didn't please me. Now, I know enough of linux and programming to do the above. My problem though is I'm running a Pixi with 1.4.5, so I can't find a compcache file in the location mentioned. More importantly, I don't see a preference folder or compcache_enabled in /etc/palm. So, would it be fine if I created a preferences folder in /etc/palm with a blank file named compcache_enabled in it? Then, would I just add a file named compcache in /etc/event.d with the above code in it? Then, when run, since the if is only checking to see if the file compcache_enabled exists, it should enter the if statement and set the parameters as specified in the compcache file. Agree? Or if I do this, will it result in a trip to the doctor?
    1.4.5!!??!! Yikes. I really can't say for sure, but my guess is that this won't work. Are you running a stock kernel or custom kernel? I'm pretty sure that the stock Palm kernel didn't support compcache. If you can find the xvmalloc and ramzswap modules (.ko extension), then they could be loaded and this might work. Or if you are on a custom kernel, then you might be able to enable compcache with Govnah and the just create the swap partition in /etc/rc.local or somewhere generic. Hmmm, did 1.4.5 even have a swap partition? It would be really interesting for you to attempt some of this, but I will not be able to help much as I don't have a 1.4.5 unit anymore. Start by figuring out if you have compcache (either loadable modules or in the kernel) and then see if you have a swap partition (try looking for /dev/mapper/store-swap).
  13. #553  
    Are you guys manually editing your compcache or using Govnah?
    Quote Originally Posted by rwhitby View Post
    We always prefer that people donate in response to tangible items they can use today, rather than for intangible promises about the future that may or may not be possible to achieve.
  14. #554  
    could it have anything to do with the kernel I'm running? (SR71)

    I've tried a few more times and different things last night and I'm gonna try some more now.
  15. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #555  
    Quote Originally Posted by Jakeeeee View Post
    Are you guys manually editing your compcache or using Govnah?
    Don't use Govnah to set compcache. Compressed swap should show as disabled in Govnah.
  16. #556  
    Quote Originally Posted by carrel View Post
    Don't use Govnah to set compcache. Compressed swap should show as disabled in Govnah.
    I've yet to do this yet, I'm waiting for a more consistent answer. I might try it soon though.
    Quote Originally Posted by rwhitby View Post
    We always prefer that people donate in response to tangible items they can use today, rather than for intangible promises about the future that may or may not be possible to achieve.
  17. #557  
    Quote Originally Posted by Jakeeeee View Post
    I've yet to do this yet, I'm waiting for a more consistent answer. I might try it soon though.
    Then anything on any page in this thread will be of little use to you.


    M.
  18. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #558  
    Quote Originally Posted by blackfireball5 View Post
    could it have anything to do with the kernel I'm running? (SR71)

    I've tried a few more times and different things last night and I'm gonna try some more now.
    Hmmm... Could be.
    I think SR71 is considerably older. You definitely seem to be running the /etc/event.d/compcache script because your swap is mounted. It is very likely the modprobe is failing and that could be because of SR71. Try running the following by hand:
    Code:
    modprobe xvmalloc
    modprobe ramzswap disksize_kb=98304
    Do you get any errors? Actually before you run that, run
    Code:
    modprobe -l
    and search for xvmalloc and ramzswap.
  19. #559  
    Quote Originally Posted by Xanadu73 View Post
    Then anything on any page in this thread will be of little use to you.


    M.
    Well I wanna contribute to this. Where should I start? I think I might start with carrel's post from earlier.
    Quote Originally Posted by rwhitby View Post
    We always prefer that people donate in response to tangible items they can use today, rather than for intangible promises about the future that may or may not be possible to achieve.
  20. #560  
    Quote Originally Posted by carrel View Post
    1.4.5!!??!! Yikes. I really can't say for sure, but my guess is that this won't work. Are you running a stock kernel or custom kernel? I'm pretty sure that the stock Palm kernel didn't support compcache. If you can find the xvmalloc and ramzswap modules (.ko extension), then they could be loaded and this might work. Or if you are on a custom kernel, then you might be able to enable compcache with Govnah and the just create the swap partition in /etc/rc.local or somewhere generic. Hmmm, did 1.4.5 even have a swap partition? It would be really interesting for you to attempt some of this, but I will not be able to help much as I don't have a 1.4.5 unit anymore. Start by figuring out if you have compcache (either loadable modules or in the kernel) and then see if you have a swap partition (try looking for /dev/mapper/store-swap).
    I have uberkernel installed, so the ramzswap modules and related modules are there (softswap also uses them, but without swap, just ram-only compcache). Also, the swap space does exist as swaphack is present and /dev/store/swap is present. The only bits I can't find are the files with compcache in the name, hence why I wanted to create a blank one in preferences and one in event.d with the code that everyone seems to be testing.

Posting Permissions