Results 1 to 5 of 5
  1.    #1  
    HI

    I am trying to access the WI-FI at my parents home with my pre but i keep getting (please enable networking before using the browser) but when i go to my setting it say connected. i even re-typed the Ip address and everything but i still cant access the net.

    on my sister I-phone she has no problem accessing it and even on the laptop except my pre

    can anyone tell me what is causing that.

    tks in advance?
  2. #2  
    Does it connect to other wifi networks fine?
  3. #3  
    You should try to disable then click the WiFi again. Or try restarting your phone then try again.
  4. #4  
    Quote Originally Posted by flipmode007 View Post
    HI

    I am trying to access the WI-FI at my parents home with my pre but i keep getting (please enable networking before using the browser) but when i go to my setting it say connected. i even re-typed the Ip address and everything but i still cant access the net.

    on my sister I-phone she has no problem accessing it and even on the laptop except my pre

    can anyone tell me what is causing that.

    tks in advance?
    Instead of re-typing the IP address, it should all be on automatic. Then check the router to see if it is set to only allow specific MAC addresses. If it is, you will have to add the MAC address for the phone to the table on the router.

    Check to make sure the router allows enough connections so there is room for you. Another form of security is that some people will restrict their router to a few simultaneous devices so they only have room for one guest connection...

    Then cycle the phone in/out of airplane mode, reboot, etc. One or more of those should help.
  5. #5  
    Quote Originally Posted by Cantaffordit View Post
    Instead of re-typing the IP address, it should all be on automatic. Then check the router to see if it is set to only allow specific MAC addresses. If it is, you will have to add the MAC address for the phone to the table on the router.

    Check to make sure the router allows enough connections so there is room for you. Another form of security is that some people will restrict their router to a few simultaneous devices so they only have room for one guest connection...

    Then cycle the phone in/out of airplane mode, reboot, etc. One or more of those should help.
    Iīve been having a similar problem as @flipmode007 with my Pre- which was originally activated on O2 Germany but I am using with a prepaid GSM SIM on mexican carrier Telcel. Sometimes for no apparent reason the phone refuses connecting to my home wifi router or any other wifi router that was previously working fine, while my laptop has no problems connecting to the same router. When that happens, I get an error of IP address configuration failed. I have tried everything you and the others on this forum have suggested and have checked that my router is not restricted to specific MAC addresses, either. I have cycled on/off airplane mode, rebooted, taken out the battery and rebooted to no avail. In fact since I first got my Pre last August I was never able to connect to wifi at all, so I couldnīt even install any apps or patches OTA until one day I activated the data service which I usually had turned off to save money since I am on a prepaid GSM SIM and have no data plan. Besides that on my carrier where I live the data service only works intermittently anyway. But with the data being on, I was finally able to connect to wifi. After I had wifi turned on I could then turn off the data service and wifi continued working fine. For a few weeks I could turn the wifi on and off whenever I wanted without having to first turn on data until recently again I got the IP address config error after a reboot. I was only able to fix it turning on and off DevMode and rebooting a few times followed by turning on data service again.
    Sorry for the long post but maybe it will help someone else who is having similar problems!

Posting Permissions