Results 1 to 6 of 6
  1.    #1  
    I was wondering with the roll out of the new WebOS 2.0 Devices and hopefully the growth of more apps for WebOS.

    Will the Palm Pre Plus and the handsets before, be left behind as far as new apps go?

    I understand that certain apps will only be for 2.0 already, but is this going to be the case with the majority of new apps released for WebOS 2.0?
  2.    #2  
    Bump
  3. #3  
    Apps that use APIs only available on 2.0 (such as Voice Memos, Internalz, etc) will not work. But, I see no reason why other apps won't continue to work if they only use what would be available on 1.4.5. Most apps are made using Javascript+HTML+CSS, so they are pretty portable across devices.
  4.    #4  
    Quote Originally Posted by rsanchez1 View Post
    Apps that use APIs only available on 2.0 (such as Voice Memos, Internalz, etc) will not work. But, I see no reason why other apps won't continue to work if they only use what would be available on 1.4.5. Most apps are made using Javascript+HTML+CSS, so they are pretty portable across devices.
    Thanks for the info!

    Just to be extra clear so i can pass on the right information..

    When new apps are made in the future for the Pre 2,Veer,3. Angry Birds, Spaz, Stitcher type apps..

    They'll most likely work with Pre Plus's on 1.4.5?
  5. #5  
    It really depends on whether those apps use 2.0 APIs for critical functionality.

    Actually, it depends on the developer. They can specify a minimum version for their app, and if your phone doesn't have a webOS version that meets the minimum version requirement, then your phone won't have access to that app in the app catalog. For now, the only reason I see why developers would specify a 2.0 minimum for apps is if those apps require 2.0 functionality.

    For example, the Internalz app in the app catalog requires 2.0 APIs to manage files, so you can see it has 2.0 as its minimum OS version.
    Palm USA | Palm webOS Applications | Mobile apps that go further.

    On the other hand, the Baseball Live app uses Exhibition Mode, which is only available on 2.1. But since it doesn't require any other APIs for critical functionality, it still has 1.4.0 as its minimum OS version.
    Palm USA | Palm webOS Applications | Mobile apps that go further.
  6.    #6  
    Quote Originally Posted by rsanchez1 View Post
    It really depends on whether those apps use 2.0 APIs for critical functionality.

    Actually, it depends on the developer. They can specify a minimum version for their app, and if your phone doesn't have a webOS version that meets the minimum version requirement, then your phone won't have access to that app in the app catalog. For now, the only reason I see why developers would specify a 2.0 minimum for apps is if those apps require 2.0 functionality.

    For example, the Internalz app in the app catalog requires 2.0 APIs to manage files, so you can see it has 2.0 as its minimum OS version.
    Palm USA | Palm webOS Applications | Mobile apps that go further.

    On the other hand, the Baseball Live app uses Exhibition Mode, which is only available on 2.1. But since it doesn't require any other APIs for critical functionality, it still has 1.4.0 as its minimum OS version.
    Palm USA | Palm webOS Applications | Mobile apps that go further.

    That is very much appreciated!

    Not sure, but i have a feeling this is going to be asked a lot more once the new devices get rolling.. good info for legacy users!

Posting Permissions