Page 1 of 9 123456 ... LastLast
Results 1 to 20 of 172
Like Tree7Likes
  1.    #1  
    I recently upgraded my Spring pre- to 2.1.0 and was wondering if anyone has had any luck getting Spring Nav working, and if they could guide me through the process. I have read mixed results throughout the forums, but most of it seems to lean towards no.

    EDIT: Rough walkthrough of my installation

    What I used:

    - WebOs SDK/PDK (for the nova-browser) <-- Nova-browser is not a necessity, see instructions
    - Windows 7 32-bit
    - Novaterm
    Instructions for running novaterm - Link
    - Nova-browser
    - Palm-webOS-Doctor_webOS-Sprint-pre_pre_sprint.jar (it is the leaked 2.0.1 sprint build, I will not be distributing this, you will need to find it on your own)
    - 7-zip
    - Sprint Pre- with WebOs 2.1.0

    Installation Procedure:

    1. Extract Palm-webOS-Doctor_webOS-Sprint-pre_pre_sprint.jar

    2. Find the Sprint.tar file inside the resources folder

    3. Extract the Sprint.tar file

    4. Find the com.telenav.sprintnavigation_1.0.1-86_armv7 file inside the /sprint/sprint folder

    5. Connect phone via USB, select just charge

    6. Use Nova-browser to place the com.telenav.sprintnavigation_1.0.1-86_armv7 file into the /media/internal directory (I believe you can also do this by simply going into USB mode and dropping the file into the root folder)

    7. Run Novaterm and use the command: ipkg install /media/internal/com.telenav.sprintnavigation_1.0.1-86_armv7.ipk -force-depends

    8. Disconnect and restart the phone

    And then you should have the new and improved Sprint Nav!

    (If for any reason any moderator has an issue with what I have posted, please feel free to edit/remove the post, or let me know what to change)


    ALTERNATE INSTRUCTIONS BY mikeisnowonfire FOR ANYONE HAVING TROUBLE

    Quote Originally Posted by mikeisnowonfire View Post
    I was able to get this working by using quick install and the linux command line without much effort; if someone would like the sprintnav file then feel free to contact me. I will put details below:

    -You will need an older veresion of webOS QuickInstall, which you can get HERE

    1. Download SprintNav file

    2. Put your phone in Dev Mode, open up quick install, and send file to /media/internal

    3. Open up the linux command and type the following command:

    ipkg install /media/internal/com.telenav.sprintnavigation_1.0.1-86_armv7.ipk -force-depends

    4. Restart your phone. It should be there and working!
    Last edited by wesleymarin; 03/16/2011 at 02:36 PM.
  2. NitOxYs's Avatar
    Posts
    191 Posts
    Global Posts
    215 Global Posts
    #2  
    I tried the ipks in the sprint tarball and could not get it working. I haven't gone further than that.
    Sprint Palm 2 - Developer Mode - 2.1.0
  3. #3  
    I already mentioned in another thread that it works, if one was to somehow have a 2.0.1 Sprint.tar and replace the wr.tar with it...

    Again, not condoning that behavior though.
  4. NitOxYs's Avatar
    Posts
    191 Posts
    Global Posts
    215 Global Posts
    #4  
    So... Anyone find this mysterious tar ball he's talking about!?
    Sprint Palm 2 - Developer Mode - 2.1.0
  5.    #5  
    Quote Originally Posted by jhoff80 View Post
    I already mentioned in another thread that it works, if one was to somehow have a 2.0.1 Sprint.tar and replace the wr.tar with it...

    Again, not condoning that behavior though.
    I believe that would be illegal, wouldnt it? at least to distribute that .tar

    http://forums.precentral.net/palm-pr...s-2-0-a-3.html

    This is the post you are referring to correct? =/, it keeps giving me a broken link

    Quote Originally Posted by jhoff80 View Post
    Not advocating this at all, but hypothetically, if one had the sprint.tar from a 2.x build, then they could rename it to wr-castle-plus.tar and replace the file in the meta-doctored.jar file with that.

    This may or may not also add "Update Network Settings" and "Update PRL" to the phone app's preferences, like on a regular Sprint Pre, though nobody has gotten PRL updating to work on 2.x.
    Last edited by wesleymarin; 02/27/2011 at 01:38 AM.
  6. #6  
    Yes.


    Someone might also want to experiment to see if you can just take the two Sprint Navigation ipks from the Sprint.tar in the 1.4.5 doctor and insert them into the wr-castle-plus.tar. When the doctor auto-installs the ipks inside the carrier.tar file, it installs it to /usr/palm/applications, instead of /media/cryptofs (there might be other differences as well, that's just the main one I know about) so you might get better results that way.
  7.    #7  
    Ok, so i found those files. sprint nav ipk and sprint tv ipk, would i be able to wosqi them? or do i have to meta-doctor? nvm, answered my own question, of course it isnt going to install the easy way

    Ya, ill try the 1.4.5 one. Doesnt seem like Kujila had much luck going the way i was about to try

    I have unpacked both the 2.0.1 nav ipk and the 1.4.5 ipk's. They seem very similiar, except the 2.0.1 is much bigger, has added features such as weather

    Anyway, too tired to work on this now. Anyone else please feel free to post any attempts/results/success stories.
    Last edited by wesleymarin; 02/27/2011 at 03:10 AM.
  8. #8  
    i don't even have any Sprint applications on my 2.1 pre-.

    how does one get them?
  9. Kujila's Avatar
    Posts
    400 Posts
    Global Posts
    401 Global Posts
    #9  
    Quote Originally Posted by wesleymarin View Post
    Ok, so i found those files. sprint nav ipk and sprint tv ipk, would i be able to wosqi them? or do i have to meta-doctor? nvm, answered my own question, of course it isnt going to install the easy way

    Ya, ill try the 1.4.5 one. Doesnt seem like Kujila had much luck going the way i was about to try

    I have unpacked both the 2.0.1 nav ipk and the 1.4.5 ipk's. They seem very similiar, except the 2.0.1 is much bigger, has added features such as weather

    Anyway, too tired to work on this now. Anyone else please feel free to post any attempts/results/success stories.
    Hey, on the other thread I got the 2.0.1 Sprint Nav ipk to install/work with using novacom, and ipkg install <ipk> -force-depends

    Now I have both Sprint TV and Sprint Navigation back on 2.1, so I am set!
  10.    #10  
    Alright, thanks to kujila I got it working. Would anyone be interested in step by step instructions? or no? If so, you will need to find a 2.0.1 nav .ipk, i cannot supply that for you
  11. #11  
    Quote Originally Posted by wesleymarin View Post
    Alright, thanks to kujila I got it working. Would anyone be interested in step by step instructions? or no? If so, you will need to find a 2.0.1 nav .ipk, i cannot supply that for you

    So hypothetically iF you find a 2.0.1 sprint nav ipk, simply install it using webosqi linux command line in 3.x (send file to /media/internal folder thru webosqi send file command):

    ipkg install (filename here).ipk -force-depends

    confirmed that this worked. hopefully there can be some legal way of finding the sprint 2.0.1 ipk's
  12. #12  
    Quote Originally Posted by cyberprashant View Post
    So hypothetically iF you find a 2.0.1 sprint nav ipk, simply install it using webosqi linux command line in 3.x (send file to /media/internal folder thru webosqi send file command):

    ipkg install (filename here).ipk -force-depends

    confirmed that this worked. hopefully there can be some legal way of finding the sprint 2.0.1 ipk's
    You need to use Nova Terminal.
  13. NitOxYs's Avatar
    Posts
    191 Posts
    Global Posts
    215 Global Posts
    #13  
    On page 4 I believe of that mentioned thread there may be a link to the webos 2.0.1 file. You would use those ipks in that sprint tarball. Just rename the WebOS doctor to a .tar file and open it. Resources is what you're looking for. If you were to obtain that leaked OS doctor illegally, that's your problem.
    I believe that HP is going to release a Sprint OS doctor that we can do ourselves if wanted. This release works really well and is quick even at 500mhz.
    Sprint Palm 2 - Developer Mode - 2.1.0
  14. #14  
    Hey all. Ive managed to install the 2.0.1 ipks but get an error saying the telenav service was not properly initialized .

    Edit: got it working
    Last edited by ryudo423; 02/28/2011 at 10:58 PM.
  15.    #15  
    Updated with installation instructions
  16. schlk21's Avatar
    Posts
    775 Posts
    Global Posts
    776 Global Posts
    #16  
    Quote Originally Posted by wesleymarin View Post
    Updated with installation instructions
    Nice.. I'm sure this can be done with a meta-script. The Sprint 2.0.1 ROM isn't exactly leaked, it's on the HP FTP. WebOS Internals could add this ROM to the script and then cherry pick what's needed to be rolled into a custom doctor.

    This will do for now.
    VZW Pre 2 on 2.1

    Thanks webOS Internals!

    @thereddestdog
  17. #17  
    Far as the legality goes, I'm pretty sure pulling the 1.4.5 version from the publicly available Doctor and doing it all yourself is legit. But edistributing the package would not be okay.

    The 2.0.1 version's a bit sneakier since it's only sort of publicly available...

    Only hiccup might be if Sprint wasn't happy with it. If that were the case, I'd take the opportunity to remind them that this is a bunch of Sprint loyalists cobbling together a bunch of software they already had so they can stick to their favorite carrier at no additional cost to Sprint. (Same can be said for all of those spending tons of money buying Pre 2's to cobble their own hardware/software together.)

    That's love, baby. Especially after not getting any Pre 2 love, but who's keeping track?

    Nice workaround, OP. No Sprint TeleNav was a huge knock to not twoing my Pre. Fantastic app I use all the time, regardless of version!
  18. #18  
    Quote Originally Posted by wesleymarin View Post
    Ya, ill try the 1.4.5 one.
    Any luck there?
  19. #19  
    Quote Originally Posted by deesugar View Post
    You need to use Nova Terminal.
    maybe, but WebOSQI LInux command line did it for me. (3.x version). MIne works~!
  20. krische's Avatar
    Posts
    421 Posts
    Global Posts
    442 Global Posts
    #20  
    Quote Originally Posted by schlk21 View Post
    Nice.. I'm sure this can be done with a meta-script. The Sprint 2.0.1 ROM isn't exactly leaked, it's on the HP FTP. WebOS Internals could add this ROM to the script and then cherry pick what's needed to be rolled into a custom doctor.

    This will do for now.
    It's not on the FTP site anymore. HP took it down and removed everything from there since the login credentials were leaked. If you Google around, you can find some crazy Chinese file hosting site that it is at. That's where I got it.

    Quote Originally Posted by cyberprashant View Post
    maybe, but WebOSQI LInux command line did it for me. (3.x version). MIne works~!
    I think the Quick install linux command line is just novaterm. It needs to be installed in novaterm because it needs to be installed as root.
Page 1 of 9 123456 ... LastLast

Posting Permissions