Results 1 to 11 of 11
  1.    #1  
    Does anyone know the details of the WIFI power drain issues with certain routers? It seems like Palm put the Wifi Off during sleep option in to specifically address this issue.

    My question is - what is the cause? I have a D-Link DIR 655 router and I'm getting about 4-5% more drain per hour when I have wifi on. If i put wifi off during sleep, it's only improving it by about 2%.

    I'm wondering if there's anything I can change in the router config that might improve this. Otherwise, I might consider replacing the router.

    I've read through all the threads I could find on this, but I never found the specific cause. I did read that it was because the router maintains a constant connection with the phone. My question is why?
  2. #2  
    not sure why, but I found that turning the 3g radio OFF when using wife really helps. Wifi radio uses less power, but somehow the 3g radio is still doing something unless you turn it off.

    also, encryption and low signal strength will both add work/power drain to the wifi radio.

    I haven't notice any difference between different routers. Try it at starbucks and see if that is any different.
  3.    #3  
    Does disabling the 3g radio affect incoming phone calls or text messages?

    I'll try it and see which way is better (3g or wifi only).

    Thanks for the input.
  4. m0ngr31's Avatar
    Posts
    365 Posts
    Global Posts
    465 Global Posts
    #4  
    Yes, not having your radio on will affect your calls and texts. I always just leave my wifi on because I'm always in a place with wifi. My battery seems to last fine even in low coverage areas because wifi is doing most of the work.
  5.    #5  
    My phone is within 4 feet of the router most of the day while i work. But leaving wifi on is keeping my power drain at about 11.5% with a Mugen 1400.

    Turning wifi off drops it down to about 7.5%.
  6. #6  
    Quote Originally Posted by m0ngr31 View Post
    Yes, not having your radio on will affect your calls and texts. I always just leave my wifi on because I'm always in a place with wifi. My battery seems to last fine even in low coverage areas because wifi is doing most of the work.
    i dont mean turn off the phone radio, just 3g (data). You will still get calls and text messages without the 3g radio on. Everything else will come through wifi.

    for me, that combination helps battery drain. Also, when I'm unable to charge I turn off 3g+wifi+everything but phone off and that will give me MUCH lower drain so I can at least get calls/text until I can swap batteries or get to a charger.
  7.    #7  
    I tried turning off data from the phone preferences tab, and in a short test with wifi on, my drain percentage was about the same as with data enabled.

    I am pretty sure that wifi is the culprit here. Just trying to figure out why. I've read in a lot of threads about some routers draining batteries while others don't. I'm guessing I've got one of the offenders. Though honestly, I don't remember it always being this way.
  8. #8  
    I also have the DIR-655m I tried many things and was never able to solve the issue.

    Nor did I find information about why it's happening.

    It has something to do with the power save mode. The router supports it, but when on wifi, the Pre still wake up every few seconds. When wifi is off while sleeping, the Pre wakes up a lot less often.

    even if the issue can't be solved, I would really like to understand it better.
  9.    #9  
    In the end, I decided to just turn wifi off. In doing so, my drain has dropped to under 4% an hour and I'm getting over 24 hours off of one charge (light use). I was getting 8-9 hours with it on. I can always turn it on when I need it which is not often.
  10. #10  
    If I want relatively good battery life, I turn off wi-fi when I am not in a wi-fi area. It definetely uses a lot of battery to have wi-fi on and not connected.
  11.    #11  
    All of my tests have been 90% of the time in my house. It actually drains slower when I'm out of my wifi area (when it's on). But I'm pretty sure the cause is an unhappy router/phone combination.

Posting Permissions