Results 1 to 11 of 11
  1. JKTex's Avatar
    Posts
    376 Posts
    Global Posts
    487 Global Posts
       #1  
    So a few times lately my Pre will loose battery power while on the TS over night where it sits every night and has for 20 months. Like today, pick it up, battery is at about 30% (even off the TS it wouldnt have lost that much) so I figure there may be a problem with the TS cover etc.

    I power the Pre off, pull the battery, put the battery back in, cover back on and it won't power back on. I've tried the hold power and 3 flip of the mute switch, holding the power button down, rechecked the battery and let it sit on the TS for a while. It was on long enough that it got warm as it does when it charges, but I get nothing. Plugging it in to a PC doesn't get anything either.

    What have I missed? It was a simple battery pull, or so I thought.
  2. #2  
    Definitely try charging with USB.
  3. JKTex's Avatar
    Posts
    376 Posts
    Global Posts
    487 Global Posts
       #3  
    I should have been more clear when I said plugging in to a PC. USB is the only way I'm aware of to do that.

    So, I have plugged it in to a PC via USB as well as the wall charger. "If" it were a USB problem, either would still not work. It does appear to charge on the TS although no display at all, I'm only going by the fact that it gets warm.

    I'm leaning towards a bad battery, if it could have died simply from pulling and replacing it.

    FYI, prior to be pulling the battery, it had charged up to about 50% from 35% or so.
  4. #4  
    Try reseating the battery, again. Then plug it in to charge and just let it go for about 15 to 20 minutes.
    Sent from my favorite gadget!
  5. #5  
    Should the title be "SPRINT" not SPRING?
  6. #6  
    Quote Originally Posted by Unclevanya View Post
    Should the title be "SPRINT" not SPRING?
    <<fixed title>>

    How old is the battery? It may be time to replace it anyway.
  7. JKTex's Avatar
    Posts
    376 Posts
    Global Posts
    487 Global Posts
       #7  
    Been there, done all that.

    I'm going to drop by SprinT and see if they have battery I can test with. I'll order a new one for $5 vs $50 from them, but I'll know if it's simply the battery that died. Otherwise, I'm changing phones soon anyway, so I'll just push that up and go Andriod. I hope HP can come up with some good hardware before the world forgets about WebOS.
  8. JKTex's Avatar
    Posts
    376 Posts
    Global Posts
    487 Global Posts
       #8  
    Quote Originally Posted by bevcraw View Post
    <<fixed title>>

    How old is the battery? It may be time to replace it anyway.
    Thanks. I checked to se if I could via EDIT but you were already doing it.

    The battery may have just died from the stress of getting touched. It's 20 months old and spends 95% of the time on a TS in the house or truck. It may have just gotten charged to death. I was suspecting that since it was starting to deplete on the charger, but it was also not holding the TS like it used to, but after pulling the cover and replacing it, it's locking on to the TS like glue again.
  9. JKTex's Avatar
    Posts
    376 Posts
    Global Posts
    487 Global Posts
       #9  
    Turned out to be the phone. The battery tested bad, but they couldn't get the phone to respond at all to a good battery. 20 months in my hands and never any hardware issues at all, the guy at the Sprint Service Center laughed because he was even very surprised.

    I don't buy the rip off insurance for anything, so I was planning my upgrade a few months early instead of forking out $$$ for a replacement but they offered to let me do a swap for $35 for a refurb. I thought that was a decent deal! It looked great, all worked fine until I left and tried to make a call. Someone missed the reason it went back for refurbing.

    No problem, walk back in to Sprint, get bumped up to the top of the waiting list, 10-15 minute later I'm walking out with a new in the box Pre and several apologetic and very helpful Sprint folks. Kudo's to them to say the least.

    Now, I wonder if I can get My Tether to work on the new one as it was still working on the old one.
  10. #10  
    Awesome, glad it worked out for you!
    Sent from my favorite gadget!
  11. #11  
    Quote Originally Posted by JKTex View Post
    Now, I wonder if I can get My Tether to work on the new one as it was still working on the old one.
    You should try the new free tether. It's the way to go now.
    But someone my cry for not getting his "donations".

Posting Permissions