Page 2 of 2 FirstFirst 12
Results 21 to 29 of 29
  1. Helidos's Avatar
    Posts
    791 Posts
    Global Posts
    810 Global Posts
    #21  
    Quote Originally Posted by HardBeatZ View Post
    The battery follows the same warranty as the device, so it comes with a one year warranty.
    That is what I was trying to point out. Sorry if it came out weird its the holidays I'm not required to make sense until next year 8D!!!
  2. #22  
    BTW, you can get the 1400 mugen battery right now for $29.71 from mugen-power-batteries.com with free shipping. Use code pixispecial to get to the final price. Here's the link : [HLI-PRESL] Buy Mugen Power 1400mAh Extended Battery For Palm Pre, Palm Pre 2 and Palm Pixi
  3. #23  
    And here is the thread about this battery (you may skip the first 25 pages ;-):
    http://forums.precentral.net/palm-pr...ighlight=mugen
  4. ejscarfo's Avatar
    Posts
    22 Posts
    Global Posts
    24 Global Posts
    #24  
    I just bough the 1350mah battery used in the Palm Pre 2 and Centro and it works great! I get a whole day out of my Pre now with moderate use whereas before with the original battery, it would barely last 8 hours. It cost me $7 too.
  5. #25  
    Quote Originally Posted by NachoB View Post
    Did you place your phone in Airplane mode and try (as instructed if it errors out)?
    had errors too, turned on airplane and solved the issue.
  6. #26  
    Quote Originally Posted by ejscarfo View Post
    I just bough the 1350mah battery used in the Palm Pre 2 and Centro and it works great! I get a whole day out of my Pre now with moderate use whereas before with the original battery, it would barely last 8 hours. It cost me $7 too.
    Never heard about such a battery. My cheap 1200mAh doesn't even have 1000,Ah.
  7. #27  
    Quote Originally Posted by NachoB View Post
    Calibrate the battery via the Dr.Battery app.

    Dr.Battery
    I cannot get my battery to calibrate and I have tried everything.


    My Themes:CLICK HERE
  8. #28  
    Quote Originally Posted by mikeisnowonfire View Post
    I cannot get my battery to calibrate and I have tried everything.
    To sad. I'm trying to make it more robust.
    The problem is, that:
    1. It takes some time after you connect the charger until it actually charges. Even though you got the banner "charging" it's still draining.
    2. WebOS brutally shutsdown below 3.4V

    I don't know why very few (around 2%) members don't get it to work.
    Sorry.

    Did you try setting the start voltage to a higher value (in app menue of calibrate scene?)
    Did you actually complained about it in my support thread (sorry if yes, it's a long thread ;-)
  9. #29  
    battery doctor tells me I got 50% health...didn't want to buy a new battery for an old minus...got lucky and found an extended battery with back on criagslist for 15 bucks...98% life....man I can't kill this thing...surf all day download hit it with hours of angry birds....loving my pre all over again
Page 2 of 2 FirstFirst 12

Posting Permissions