Results 1 to 16 of 16
  1.    #1  
    I am being maybe too optimistic with this, but I think I've learn to fix the touchscreen and USB issue...

    I'm just testing it, and if it works as expected, I will post pictures of the process.
  2. #2  
    You mean the one where you plug a cable into the USB port (and it doesn't have to be connected to anything on the other end) and the touchscreen no longer responds?
    Clicking the Thanks button is a great way to say... well THANKS
    Phone Apps: Church Search, Tap for HELP
    TouchPad Apps: Tap for HELP! HD, webOS Meetups
  3. #3  
    wow pastor ! Do I detect just the slightest hint of sarcasm in your tone ? Lol ltm ltm ha ha
  4. #4  
    My wife's was the other way around. Her's would only respond when the USB cable was plugged in. We were in Vegas at the time, so I just hacked off the end of the plug so she wasnt walking around with a 3 foot cable in her purse.
  5. #5  
    yes we would like to know exactly what the issue was to begine with lol ha ha ltm
  6. #6  
    Quote Originally Posted by Shadavis08 View Post
    wow pastor ! Do I detect just the slightest hint of sarcasm in your tone ? Lol ltm ltm ha ha
    No... not towards the OP anyway. I had the issue I described on one of my early Pre's and I thought it was completely ridiculous that it would do that. Totally a hardware issue.

    If he in fact has found a fix, it is likely more technical than most users would attempt. I don't think I would take my screen apart when I know I can get a replacement for free from Sprint for this issue.
    Clicking the Thanks button is a great way to say... well THANKS
    Phone Apps: Church Search, Tap for HELP
    TouchPad Apps: Tap for HELP! HD, webOS Meetups
  7. #7  
    Yeah there's 2 issues.
    Either it stops responding when USB connected, or it only responds when it's USB connected. Which is it?
    Because I would be interested in the fix behind door number 2.
  8.    #8  
    Quote Originally Posted by GuyFromNam View Post
    (...) Because I would be interested in the fix behind door number 2.
    That is!!

    STANDARD DISCLAIMER APPLY!!
    (This worked for me, maybe it won't work for you. If you break your phone, it's your fault, not mine)


    Just before starting, 2 things:

    1. This is what I believe it fixed my pre. Maybe it does not fix yours.
    2. This picture shows the level of disassembly I had to reach to fix my pre.


    PIC0001.jpg

    Well, let's go.

    These first two pictures show a USB connector just it should be. If you don't know what I'm talking about, see the other pictures.
    pic0002.jpg
    PIC0003.JPG

    But when you plug the USB cable...
    PIC0004.JPG

    And then remove it...
    pic0005.JPG

    See what happens? The enclosure of the connector is separated. So, I put the connector back just like the first pictures, and put a couple of solder drops to keep the enclosure that way.

    I was so excited for this being a possible solution, that I forgot to take a picture of the fixed connector. Shame on me...

    I assembled it all again, tested and... voilą!! It worked!! The touchscreen and gesture area works again!!

    So, as said before, This is what I believe it fixed my pre. Maybe I am wrong at I touched another thing but this is what I directly did for this to work.

    I hope it works for others that take the risk.
    Last edited by Tokafondo; 11/10/2010 at 10:40 AM.
  9. #9  
    Quote Originally Posted by Tokafondo View Post
    See what happens? The enclosure of the connector is separated.
    Cool, but can't this be fixed from the outside?
  10.    #10  
    Quote Originally Posted by GuyFromNam View Post
    Cool, but can't this be fixed from the outside?
    That side of the connector is just under the screen, so the connector board has to be removed for this to be made.
  11.    #11  
    Quote Originally Posted by GuyFromNam View Post
    OK, but just so I get you right. This was a Pre that had an irresponsive touchscreen when the USB connector was removed, right?
    USB cable plugged -> touchscreen working
    USB cable removed -> touchscreen dead

    USB cable plugged again -> touchscreen working again
    USB cable removed again -> touchscreen dead again

    after the fix...

    USB cable plugged -> touchscreen working
    USB cable removed -> touchscreen working
    Pre rebooted -> touchscreen working
    Battery removed, put again and boot -> touchscreen working

    Right?
  12.    #12  
    Just bought a Pre for next to nothing
    I think I'll just try your fix
    Did you tried it?

    Mine is working wonderful since the fix!!
  13. #13  
    I had something like this happen to a pre once back before i plussed mine i just replaced the whole plug solder works for a bit bu its so soft it will re break loose good work though i did not have the touch screen issue though just the plug was bent apart and loose
    Sprint Palm Pre/Verizon Pre Plus On Sprint/Sprint Pixi Hybrid with WIFI
  14. #14  
    just bought a pre cheap but the usb plug doesn't work for me at all, or any other tricks for that matter
  15. #15  
    Hi there

    I am in this boat I think ?

    Could you explain what the USB has to do with the touch screen ?
    I am getting Phantom taps and moody touch screen, when I insert the USB cable and wiggle it it works fine, then if I close the slider a bit hard or use the USB cable the touchscreen goes AWOL.

    PLease help

    Regards
    Sneakypuff
    South Africa
  16. #16  
    Do you think that reseeding the digitizer connector fixed it and repairing the USB connector was a a red herring?

Tags for this Thread

Posting Permissions