Results 1 to 20 of 20
  1.    #1  
    So I've noticed that my pre's time/clock is gradually going faster than the clocks around my house. I'm not sure why that is. It's like everyday I need to reboot my phone to fix this...kind of annoying. Does anyone have a solution to this fix?
  2. #2  
    are you on a pre plus at&t?

    use clock sync to correct the time periodically

    Check out Clock Sync: http://developer.palm.com/appredirect/?packageid=de.content754.clocksync&applicationid=1819
  3. #3  
    assuming that your phone is getting the time from the network... It sounds like your other clocks are slow.

    have you gone to one of the sites that indows uses to keep time? If you phone doesn't agree with that, then there is something strange at at&t or in the way your phone is getting time updates.
  4. #4  
    Wow! I just had post the same problem! http://forums.precentral.net/palm-pr...-zone-off.html
  5.    #5  
    Quote Originally Posted by abegee View Post
    are you on a pre plus at&t?

    use clock sync to correct the time periodically

    Check out Clock Sync: Palm USA | Palm webOS Applications | Mobile apps that go further.
    thanks abegee. i'll give this a try and see how it goes.
    this time issue has only been going on for a few days now. dunno what's going on.
  6. #6  
    On a side note, whenever my pre shuts down (or restarts) the clock gets behind by whatever time it was turned off.
    My pre is still locked to sfr so I basically use it as a pda (no network time for me, but I appreciate the extra juice) but for such a great piece of tech it's a shame not to have a reliable clock in there.
    Franklin eBookMan >> Palm Zire71 >> Lifedrive with flash mod >> Palm Pre Plus
  7. #7  
    Near a worm hole?

    [i]-- Sent from my Palm PrPrPr
  8. #8  
    Quote Originally Posted by abegee View Post
    are you on a pre plus at&t?

    use clock sync to correct the time periodically

    Check out Clock Sync: Palm USA | Palm webOS Applications | Mobile apps that go further.
    Thank you. Installed this app. Result: Pre is off by 6 seconds for every hour!
  9. #9  
    I reset it every time and it keeps going back to the wrong time after an hour or so it's upsetting me and it just started happening. My 3g doesn't work either sometimes. For instance if I'm connected to a wifi network and then I leave the area and get disconnected from the wifi, my 3g doesn't kick in, I have to completely restart my phone. I've tried the airplane mode trick and it doesn't work. It's frustrating!
  10. #10  
    One thing that worked for me when I had a clock issue was to shut the Pre down completely, remove the battery, wait for a minute or so, then replace the battery and turn it back on. If you haven't tried that yet, it's worth a shot. It seems that the complete removal of power from the device gives the clock a chance to recalibrate or something.
    Palm III-->Handspring Visor-->Sony Clie PEG-NR70-->no PDA -->Palm Treo 755p-->Palm Pre-->HP Veer
  11. #11  
    I have tried this and it doesnt work for me
  12. #12  
    I don't know if this will make a difference as i just tried it. I have my pre rooted and preware installed. There is a NTP sync tool that will sync the time when you run it. I don't know how long yet the change makes.

    The issue DOES seem to happen with the recharging process. I've been swapping out my battery for a fresh one for a few months and no major issues. but yesterday I just charged while I was messing with stuff and today the problem came back.

    Mine is losing ALL time tracking ability as soon as i go airplane mode with network time on. I've tried to go manually and that was just as bad. its almost as if the device doesn't keep time at all without a network connection.

    maybe a problem with the module for system time.
    being a phone there is some tracking of uptime and system connection stats. I bet that when you charge or go airplane an error is happening that kills the time. ntpd is the linux network time module. we need a linux guru to look into this.

    edit: no dice, i'm already over 20 minutes off.
  13. #13  
    can we all list our specs. So we can discover the cause of the bug.

    mine are:

    device: pre plus
    carrier: at&t
    service: none / meta-doctor
    webOS version: 1.4.5

    likely cause: network time isn't getting synced due to no sim card, cbuiltin clock isn't good enough
  14.    #14  
    my time app is keeping my clock on time now. i have the same specs abegee.
  15. #15  
    Quote Originally Posted by jbg7474 View Post
    One thing that worked for me when I had a clock issue was to shut the Pre down completely, remove the battery, wait for a minute or so, then replace the battery and turn it back on. If you haven't tried that yet, it's worth a shot. It seems that the complete removal of power from the device gives the clock a chance to recalibrate or something.
    I actually did this and in the process of replacing the battery I put a piece of paper in between so that the battery will stay in place and mine has been good ever since
  16. Jimbode's Avatar
    Posts
    424 Posts
    Global Posts
    427 Global Posts
    #16  
    One thing I've also found that works is to open up the Date & Time settings, turn off both network time and zone, flick the card away then open it again and turn them back on.
  17. #17  
    Atomic Clocks Measure Relative Time

    "Physicists at the National Institute of Standards and Technology (NIST) tested Einstein’s theories about relative time in a physical setting. Time goes faster at higher elevations, and slower for moving objects. The experiments involved a comparison of two identical atomic clocks.

    The NIST experiments focused on two scenarios predicted by Einstein’s theories of relativity. First, when two clocks are subjected to unequal gravitational forces due to their different elevations above the surface of the Earth, the higher clock—experiencing a smaller gravitational force—runs faster. Second, when an observer is moving, a stationary clock’s tick appears to last longer, so the clock appears to run slow. Scientists refer to this as the “twin paradox,” in which a twin sibling who travels on a fast-moving rocket ship would return home younger than the other twin. The crucial factor is the acceleration (speeding up and slowing down) of the travelling twin in making the round-trip journey

    NIST scientists observed these effects by making specific changes in one of the two aluminum clocks and measuring the resulting differences in the two ions’ relative ticking rates, or frequencies.

    In one set of experiments, scientists raised one of the clocks by jacking up the laser table to a height one-third of a meter (about a foot) above the second clock. Sure enough, the higher clock ran at a slightly faster rate than the lower clock, exactly as predicted.

    The second set of experiments examined the effects of altering the physical motion of the ion in one clock. (The ions are almost completely motionless during normal clock operations.) NIST scientists tweaked the one ion so that it gyrated back and forth at speeds equivalent to several meters per second. That clock ticked at a slightly slower rate than the second clock, as predicted by relativity. The moving ion acts like the traveling twin in the twin paradox.

    So if you want to age more slowly, you should run as fast as you can on a beach or a valley below sea level. The time you gain would not offset the difference in the time you put in, but you might live longer due to the benefit of the physical exertion."


    Now I'm no physics expert, but based on that above article, it seems like you and your Pre move around fairly quickly and fairly high in altitude. I would suggest taking it easy on the UFO joyrides and maybe your phone will sort itself out.
  18. #18  
    Since its good for the health & well being (so to speak) of WebOS to reboot often, why not use Jason's Preset Reset app. Its main purpose is to automatically reset your device at the time you specify on the days you specify. But, it also has an option to sync your clock when it restarts. Additionally, you can also have it automatically start specified apps for you.
    http://www.precentral.net/homebrew-apps/preset-reset

    Mine-Sprint Samsung Galaxy Nexus 4G/LTE
    Sprint Pre, 1.4.5 overclocked with F102A Delta Dagger - retired 12-18-11
    Wife's- Sprint LG Viper 4G/LTE
    R.I.P. - My Launch day Pre - 06-06-09--04-18-11

    Never trust a computer (or phone) named after a fruit.
  19. srdoyle's Avatar
    Posts
    14 Posts
    Global Posts
    15 Global Posts
    #19  
    I flew from Atlanta Eastern Time to Chicago Central Time to Toledo Eastern Time Zone yesterday, now my Pre is stuck in CT while I sit here in ET. I have reset the phone, manually set the Time zone to ET in Date and Time Settings, yet turning the Network Time Zone back on switches it back to CT. I Cycled Airplane Mode on then back off as mentioned in Date and Time Settings. Weird........Am I alone here???
  20. #20  
    Have you placed any phone calls since you've been back in ET? I know that WebOS updates the time automatically, but I remember some older phones wouldn't update the time until a call was placed or received.

    As a second suggestion, use PresetReset to force a time sync. Or, I believe there is another app or patch out there that will force time sync because apparently there are some networks out there that don't do it automatically.

    Mine-Sprint Samsung Galaxy Nexus 4G/LTE
    Sprint Pre, 1.4.5 overclocked with F102A Delta Dagger - retired 12-18-11
    Wife's- Sprint LG Viper 4G/LTE
    R.I.P. - My Launch day Pre - 06-06-09--04-18-11

    Never trust a computer (or phone) named after a fruit.

Posting Permissions