Results 1 to 10 of 10
  1.    #1  
    Hey fellas. I am right now on my third Pre phone and now I am having a bit of a heavy issue. First of all this Pre is about 7 months old, the third one I have owned since the previous two stopped working properly. It runs UberKernel at 1GHZ and has many different patches. I also think I am covered by the one year warranty since I purchased the first phone in early December.

    Now the issues I have with the phone are these three:

    1) Radio problems. Its having problem getting EVDO signals, and even with EV marked in the phone after a while it just drops and doesn't download a single byte of data. Putting it on and off airplane mode fix this temporarily and I get data on my phone again. As soon as few minutes pass it just stops downloading things. Phone calls and texts go through without a hitch, though sometimes the CONNECTING part of the call takes a while. There are also many times when it only has voice-only connection and not Data, in an area where I know I have data. Its not the cell in my area as I've gone to farther away areas and still face the same problem, plus my father has a Pre as well and he uses it without a problem. I am thinking the radio is borked.

    2) Cracking in the overside and corners. Right below the Standby button the plastic fell apart and there's a nasty little hole there. The plastic by the side of that hole has also cracked heavily and also on the side by the volume buttons a bit up from there it has another hole thanks to plastic breaking. And it hasn't even been from falling since I use a hard-rubber cover on it. It just... broke.

    3) Abysmal battery. Dr.Battery reports 50% of the battery life, and usually even with Calibrating by 40-30% it jumps to low battery. I have to go with my USB cable anywhere. This is completely unacceptable.

    What can be my course of action? Should I go to Sprint and try get it exchanged by warranty? Doctor the phone and buy a new battery?
  2. #2  
    Quote Originally Posted by Relix View Post
    Should I go to Sprint and try get it exchanged by warranty? Doctor the phone and buy a new battery?
    Yes....for the physical cracking issues alone. This will get you a new (or refurbished) phone...this will fix your radio issues if your having any. As to your radio issues...what your describing sounds like signal quality issue. Does what you describe above happen all the time no matter your location?

    I think your data issues ("in an area where I know I have data") might be do to roaming. Do you have data roaming enabled? This costs nothing extra on Sprint.
    Sprint|Samsung Epic
  3.    #3  
    Yeah the problems happen in any location, even in full bar areas where I've gotten Sprint signal before. I don't think its roaming as I've never seen the "R" pop up except from certain areas so I am definitely sure its a radio problem. *shrugs*. I love WebOS but the hardware really leaves a lot to be desired. I will go Friday and see if they can exchange my phone.

    I have PreWare installed, and I remember there was an app called Save and Restore or something along those lines. How does it work? I don't wanna lose settings and some saved progress in games like Angry Birds! =P
  4. #4  
    I was having the same problems before all the same losing radio conn. And being slow ... Dropping from 30 -20 to 0 then dead.... I had alot alot of patches and homebrewed games and themes....( No uber) I did a few things (not sure exactly which fixed it) I dr the pre started fresh I now use less patches and no themes( noticed everytime I ran a theme would get very slow) I also had a prob w my usb cable it would charge fine but I started to notice it wouldn't go to usb mode once in a while on my pc... So whem I would charge it it would run bad as if somesort of short.. Meantime I would restart after everycharge had no prob.
  5. #5  
    Quote Originally Posted by Relix View Post
    Yeah the problems happen in any location, even in full bar areas where I've gotten Sprint signal before. I don't think its roaming as I've never seen the "R" pop up except from certain areas so I am definitely sure its a radio problem. *shrugs*. I love WebOS but the hardware really leaves a lot to be desired. I will go Friday and see if they can exchange my phone.

    I have PreWare installed, and I remember there was an app called Save and Restore or something along those lines. How does it work? I don't wanna lose settings and some saved progress in games like Angry Birds! =P
    Yes, Save/Restore can save your 'Angry Birds.'
    Palm III > Palm V > Palm Vx > (Sprint) Kyo 6035 > Handspring Treo 300
    > Handspring Treo 600 Oct.'03 > Palm Treo 700P May'06 > Treo 755P Aug.'07 > Pre(-) June'09 + TouchPad July'11 LONG LIVE webOS!!!
  6.    #6  
    Yep, definitely radio's dead. Phone suddenly goes to Phone Offline mode, calls take an eternity to be made, EVDO barely works, etc. I downloaded Save/Restore through Wi Fi. I have to get a file off my phone through the drive mode right? Like an overall restore file? =P.

    Will go and request a phone tomorrow at my local sprint store. Thanks a bunch everyone.
  7.    #7  
    Well they just gave me a very weak excuse. They said they had problems with three towers and that was the reason for my connectivity problems, and also that my phone couldn't be handed in for warranty reasons since there was physical damage, the cracks I mentioned earlier. Of course I tried reason with her that it was a common problem but she just wouldn't budge, so I just left.

    Now I ask, is there any possible proof I can show them if in fact there are no tower problems and its just my phone acting?
  8. #8  
    call Palm. They were easier to deal with than Sprint. Similar issue with the crack and they sent me a replacement without a question.
    Last edited by lenmac08; 10/15/2010 at 07:04 PM.
  9.    #9  
    Quote Originally Posted by lenmac08 View Post
    call Palm. They were easier to deal with than Sprint. Similar issue with the crack and they sent me a replacement without a question.
    Could chat also work? I have no close phone to make the call
  10. #10  
    maybe. I called them and had a positive response but that was ~ 4 months ago.

Posting Permissions