Page 1 of 4 1234 LastLast
Results 1 to 20 of 80
  1.    #1  
    In the last few days I noticed that my Pre would burn through about 20% battery an hour. After messing around a bit and taking off Govnah and the UberKernel to see if that was the problem (it wasn't) I THINK I found the issue.

    My phone will not sleep.

    Running the terminal app while you put the Pre to sleep will allow you to see system notifications. Normally it is just "going to sleep" and then "waking up" once for each time you hit the power button. Now it is "going to sleep" and "waking up" every second for the time it is supposed to be down.

    Getting kernel logs using dmesg and I get ...

    [35632.440000] Forcing firmware into extreme power save..
    [35632.450000] hscfg: cond=0x6 gpio=0xff gap=0x32 PSState=1 HS_Activated=0
    [35632.450000] WLAN: Received EVENT (0xa) interrupt from firmware
    [35632.650000] WakeOnWLAN Rx:
    [35632.650000] ff ff ff ff ff ff 00 08 a1 14 89 b0 08 00 45 00
    [35632.650000] 00 4e 87 67 00 00 80 11 66 45 9c 1a 08 bf 9c 1a
    [35632.650000] 0b ff 00 89 00 89 00 3a 1e 41 ea b8 01 10 00 01
    [35632.650000] IPT_PACKET_DROPPED_NO_MATCH: IN=eth0 OUT= MAC=ff:ff:ff:ff:ff:ff:00:08:a1:14:89:b0:08:00 SRC=156.26.8.191 DST=156.26.11.255 LEN=78 TOS=0x00 PREC=0x00 TTL=128 ID=34663 PROTO=UDP SPT=137 DPT=137 LEN=58
    [35632.650000] WakeOnWLAN Rx:
    [35632.650000] ff ff ff ff ff ff 00 80 ad 0c e9 9a 08 06 00 01
    [35632.650000] 08 00 06 04 00 01 00 80 ad 0c e9 9a 9c 1a 08 7a
    [35632.650000] 00 00 00 00 00 00 9c 1a 09 dd 00 00 00 00 00 00
    [35632.690000] WLAN: Received EVENT (0xb) interrupt from firmware
    [35632.700000] Syncing filesystems ... skipped for target platform ... done.
    [35632.700000] Freezing user space processes ... (elapsed 0.00 seconds) done.
    [35632.710000] Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
    [35632.710000] Suspending console(s)
    [35632.710000] Suspending... WakeupReq=Y Conn=Y PS_Mode=1 PS_State=3
    [35632.960000] musb_suspend 2197: suspend from 0 -> 2
    [35632.960000] musb_suspend 2231: idle, standby etc.
    [35632.960000] twl4030_phy_suspend: irq_disable=1
    [35632.960000] twl4030_phy_suspend: phy is already asleep
    [35632.970000] rtc_alarm: Read current rtc alarm of 11:58:56
    [35632.970000] fastpath_prepare: RTC = 11:48:59, UserAlarm = 11:58:56, NextFastWake = 11:55:29
    [35632.970000] fastpath_prepare: Alarm set after 390 seconds by fastpath client : Battery Check Fastpath Client
    [35632.970000] 00040544.161: enter suspend
    [35632.970000] 00040544.185: leave suspend
    [35632.970000] WAKEUP STATE/REASON
    [35632.970000] PM_WKST_WKUP 00000100
    [35632.970000] fastpath_fastsleep: Non RTC Wakeup
    [35632.970000] twl4030_phy_resume: mode=1
    [35632.980000] twl4030_phy_suspend: irq_disable=0
    [35632.980000] phy_suspend: enter
    [35633.040000] Resuming... WakeupReq=Y Conn=Y PS_Mode=1 PS_State=3
    [35633.040000] Restarting tasks ... done.
    [35633.100000] hscfg: cond=0xffffffff gpio=0xff gap=0x32 PSState=3 HS_Activated=1

    ... repeated 60 times a minute. Hence why I think this is killing my battery.

    I don't want to Doctor my phone yet. This is Linux and it should be fixable without a reinstall. And I'm sure others will eventually see this as well. So a reason as for why it is happening would be great.

    I haven't done Linux Kernel work in years and years. But, happy to help and hopefully someone can point me in the right direction.

    - mark
  2. #2  
    How can I test this from terminal? What exactly do I type in terminal?

    I think I am having the same issue as my battery is draining really fast as well so I would love to check for this.
  3.    #3  
    1. Don't plug your Pre into the charger (if it is being charged it never actually goes to sleep).

    2. Open Terminal. Hit the power button. Wait 5 seconds. Hit the power button and unlock the screen.

    You should see a couple of broadcast messages in the terminal" "powerd: System going to sleep now" and "powerd: System woke up". The times listed on the message will be about 1 to 2 seconds apart. If the Pre was going to sleep correctly it would only list one sleep and one wake up (the times you hit the power button).

    Something is giving the wake up signal. Don't know what yet. Hoping someone on the list can give some pointers on where to look. The real Linux guru here at work is off for this week so I'm on my own for hunting and pecking around the problem.

    - mark
  4.    #4  
    rmausser ...

    If you are seeing the above can you open terminal and do the following.

    1) Hit the power button and wait 5 seconds before waking it up.

    2) Type the following commands to get the kernel messages ...

    cp /var/log/messages /media/internal/messages.txt
    dmesg > /media/internal/dmesg.txt

    3) Look at dmesg in a text editor and look for something similar to ...

    [ 376.470000] 00000390.805: enter suspend
    [ 376.470000] 00000390.829: leave suspend

    Then look in messages for the same time stamps (my example is 376) for something similar to ...

    2010-09-27T20:19:15.517303Z [376] palm-webos-device user.info powerd: {powerd}: POWERD-SUSPEND: POWERD-WOKE after 0s : 0 days, 0h-0m-0s
    2010-09-27T20:19:15.517944Z [376] palm-webos-device user.info powerd: {powerd}: POWERD-SUSPEND: Wakeup Source: [ 376.470000] GPIO (RINGER_SWITCH) omap3_wakeup_sources_save+0x114/0x144 (a004a690)
    2010-09-27T20:19:15.518249Z [376] palm-webos-device user.info powerd: {powerd}: POWERD-SUSPEND: Wakeup Source: [ 376.470000] BUTTON (POWER_BUTTON) omap3_wakeup_sources_save+0x114/0x144 (a004a690)

    My problem seems to be my power button and ringer switch are supposedly sending a signal. But, it isn't fully waking up like a button press would actually do. So it is probably some sort of intermittent hardware problem. Or powerd is just messed up.

    - mark
  5. #5  
    how do I copy and past the info I got from terminal?
  6. #6  
    Because mine just says powerd: system going to sleep

    powerd: system woke up

    It says that about 20+ times and I only turned the screen off and on once.
  7.    #7  
    Terminal can't copy text from the screen. You can take a snapshot with Option + Sym + P and then you have an image of the terminal in photos.

    if you see a lot of wake/sleep notices then I'd say you have the same bug I do. To be sure you need to get the messages log and the dmesg log (see above). Once you create the text files you can copy them off the phone via usb.

    - mark
  8. #8  
    I don't believe it's a bug though because it that's the case. Try this. Turn GPS off and put your phone in airplane mode and see if you still lose a lot of battery life.
  9. #9  
    @OP do you have Myclock installed?, I have had some users say that their screen would remain on after a call or sms and not turn off after 30seconds or a minute instead it would remain on permanantly. Draining the battery.
  10.    #10  
    @Black ... No GPS and in airplane mode I see the same problem in the kernal logs about the power button waking the system every second. And it is still draining the battery (no surprise if it can't sleep and is thrashing the log files). I don't see how this can be hardware if you see the same messages in the log. My daughter's Pre doesn't have this problem and the only diff is I upgraded Govnah and Preware last week (and this started last week).

    @abegee ... Nope.

    - mark
  11. #11  
    Quote Originally Posted by abegee View Post
    @OP do you have Myclock installed?, I have had some users say that their screen would remain on after a call or sms and not turn off after 30seconds or a minute instead it would remain on permanantly. Draining the battery.
    The screen turns off, but it doesnt go into sleep mode.
    Quote Originally Posted by arrasmith View Post
    @Black ... No GPS and in airplane mode I see the same problem in the kernal logs about the power button waking the system every second. And it is still draining the battery (no surprise if it can't sleep and is thrashing the log files). I don't see how this can be hardware if you see the same messages in the log. My daughter's Pre doesn't have this problem and the only diff is I upgraded Govnah and Preware last week (and this started last week).

    @abegee ... Nope.

    - mark
    Yeah. I also still experience the same problem. No wonder my battery has being dying. Im going to delete uberkernel and try to use the stock kernel. Maybe its the kernel thats making it act that way.
    If you want to buy a Palm Pre is great condition. Here's your chance.

    http://forums.precentral.net/showthr...91#post2782191
  12. #12  
    this is what i see
    Attached Images Attached Images
    If you want to buy a Palm Pre is great condition. Here's your chance.

    http://forums.precentral.net/showthr...91#post2782191
  13. #13  
    I have Nodoze(it prevents the system from going into sleep mode and turning the wifi off) installed. That might be one of the reasons. It annoys me when the Pre decides to just disconnect from the WiFi source and do its own thing.

    Also, a big reason might be the fact that you might have checked the setting to "Keep WiFi On". The phone is going to have to stay awake to keep your WiFi On.
    Last edited by Jason Black; 09/27/2010 at 07:01 PM.
    If you want to buy a Palm Pre is great condition. Here's your chance.

    http://forums.precentral.net/showthr...91#post2782191
  14.    #14  
    Uninstalling Preware, Govnah, and Uber didn't fix the problem for me. Just guessing here, but my feeling is that the new Govnah introduced a complexity bug in powerd. Specifically in the settings watching the power button. I could answer that idea if I was willing to use my daughter's Pre as a test case. And I'm not (don't feel like being smacked around by a teen girl).
  15. #15  
    I deleted govnah, uberkernel, nodoze and i also turned off the WiFi from staying on and im getting the proper results now.
    Attached Images Attached Images
    If you want to buy a Palm Pre is great condition. Here's your chance.

    http://forums.precentral.net/showthr...91#post2782191
  16.    #16  
    Mine is still not sleeping with stock kernel, etc. Onto Doctor it I suppose.
  17. #17  
    It could be that synergy is working. Or email is checking for something. I reinstalled F105 and now its not sleeping anymore
    If you want to buy a Palm Pre is great condition. Here's your chance.

    http://forums.precentral.net/showthr...91#post2782191
  18.    #18  
    Once I get my phone to stock 1.4.5 and slowly add items I hopefully will find the problem. Not fun. I like a working Pre.
  19. #19  
    keep me posted!
    If you want to buy a Palm Pre is great condition. Here's your chance.

    http://forums.precentral.net/showthr...91#post2782191
  20. #20  
    Just checked and same here.
    Sent from my favorite gadget!
Page 1 of 4 1234 LastLast

Posting Permissions