Results 1 to 9 of 9
  1.    #1  
    help anyone please!
    I charged my phone all night and the charging symbol appears on the phone it wont seem to turn on but the screen just flashes black. I have took the battery out multiple times and switch the top switch 3 times and nothing seems to work. Does anyone have any tips ?
  2. #2  
    Quote Originally Posted by nichole1011 View Post
    help anyone please!
    I charged my phone all night and the charging symbol appears on the phone it wont seem to turn on but the screen just flashes black. I have took the battery out multiple times and switch the top switch 3 times and nothing seems to work. Does anyone have any tips ?
    Is the symbol you see a white battery with a white question mark or a white battery outline with usb cable half filled with red?
  3. #3  
    A few more details will help. Are you charging it through your computer or directly through the AC outlet? Have you tried to charge it on other computer/AC outlet? Another microUSB cable?
  4. #4  
    Quote Originally Posted by nichole1011 View Post
    help anyone please!
    I charged my phone all night and the charging symbol appears on the phone it wont seem to turn on but the screen just flashes black. I have took the battery out multiple times and switch the top switch 3 times and nothing seems to work. Does anyone have any tips ?
    That more seems like a failure from the battery... Try replacing the battery!

    If it's not cause by the battery, then return the phone for repairs.
  5.    #5  
    ya... it is the white battery sign with the red line underneath it


    i have tried to charge it via the usb and the electrical outlet
  6. #6  
    Quote Originally Posted by nichole1011 View Post
    ya... it is the white battery sign with the red line underneath it


    i have tried to charge it via the usb and the electrical outlet
    Try charging it again. If it doesn't charge, you may need to replace the battery.
    "Patience, use the force, think." Obi-Wan


    Ready to try Preware? Get this first: Preware Homebrew Documentation
  7.    #7  
    i dont know what i did but it turned on out of no were. YAY!!! Strange
  8. #8  
    When the battery runs completely down, it has to charge for a while before it will boot up. Charging with a usb port takes longer than a wall socket.
  9. Trident's Avatar
    Posts
    337 Posts
    Global Posts
    343 Global Posts
    #9  
    My wife's Pre had this happen a bunch of times.
    I replaced the battery and it still kept happening.
    Took it in to a Sprint repair facility- the guy orders a battery that was manufactured in a different place and it all works perfectly now. He explained that it was a known, but not publicized, issue with a certain batch of batteries.
    The only way of discovering the limits of the possible is to venture a little way past them into the impossible.
    Any sufficiently advanced technology is indistinguishable from magic.

Posting Permissions