Page 1 of 2 12 LastLast
Results 1 to 20 of 21
  1.    #1  
    I am at a total loss and I've searched around and no one seems to be having the same trouble, not at least exactly like this one, so I figured I'd ask.

    I have a WPA2-personal network set up at my home. I am able to connect my two computers to it (a Windows PC and a dual boot MacBook). I can connect my iPod touch to it.

    The only thing that will not work is my Pre. It is able to connect to the wireless network, but is unable to download any information over the internet. EXCEPT I'm able to load a page in the first thirty seconds or so after connecting but that's about it. And that's only once and a while. The rest of the time, I get "Unable to resolve host" [2006] errors and [115] errors.

    I have rest the router, the modem, the phone, gave the Pre a static IP address, and nothing seems to work. It's not a huge deal, as I can use 3G if I need to, but I really have no idea what to do about this now.

    Any thoughts? Thanks.
    - Nathanielonfire
    Last edited by nathanielonfire; 07/05/2010 at 10:28 AM.
  2. #2  
    The WPA2-PSK password is case-sensitive. Also make sure if you are using MAC filtering then you should add the Pre to the white list. Is the router wireless-N?
    Last edited by Abyssul; 07/05/2010 at 10:52 AM.


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  3.    #3  
    Router is mixed g/b. The password has been typed in correctly, as the Pre still shows the blue check mark and full reception of the wireless router. I'm just unable to browse or download anything.
  4. #4  
    How long is your password? Also make sure if you are using MAC filtering then you should add the Pre to the white list.

    I know this link references to the old PalmOS PDA's, but the checklist is still useful.
    http://forums.palm.com/t5/Bluetooth-...help/m-p/87318

    Go down the list and see if what applies to you is set correctly.


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  5.    #5  
    Password is 26 characters. Would changing the password length change anything? There is no MAC filtering. Everything seems to be in order...at least according to the checklist and what I can manage. I have hit "Forget Network" in the Wi-Fi settings and re-entered the PSK several times...no go...
  6. #6  
    Try disabling your encryption and rebooting your router, then have the Pre forget the network. See if the Pre can obtain a data connection then.

    I know it sounds stupid, but make sure the password you type into the Pre is the same exact as the one posted in your router's settings (case sensitive and all). Double check it.


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  7. mauro1's Avatar
    Posts
    205 Posts
    Global Posts
    213 Global Posts
    #7  
    <quote> "Unable to resolve host" </quote> sounds like a problem with host name resolution (yes I know I'm Capt. Obvious). To test if this is indeed a problem, find out the address of a well-known website and try to use its address instead of its name. If you have success using the address where the name fails you have pretty compelling evidence that the DNS configuration is non-functional in your device.

    Since you mention that it does "work" under 3G, I wonder if your Internet setup works at other WiFi "islands". If it does then by the process of elimination the problem is to be found in the way that your WiFi router configures the DNS on the device, via the DHCP protocol.

    If the above logic makes sense to you, perform these steps.
    .- In a command line prompt on any computer run "nslookup www.google.com", or "ping www.google.com" (it doesn't matter if there is no response you care about the IP address only). In my case I just received an address of 74.125.47.99, but you will likely get a different one.

    .- On your device open the web browser and type in the address as "http://74.125.47.99/about.html" (no quotes) If you are successful, the About Google page should display.

    If this diagnosis is successful, go into WiFi settings and select the network you have defined, it should list the details including the DNS server that is in use. Does it match the DNS server that is configured on the other computers in your home?

    Good luck.
    Palm Pilot -> IBM WorkPad -> Handspring Visor -> Palm VIIx -> Palm T|X -> Palm Pre -> US GSM Palm Pre 2 [shelved] and 16GB HP TouchPad [died] -> (Samsung GNex and 32GB HP Touchpad with CM9)
  8.    #8  
    Pre is able to receive data on an unencrypted connection. Resetting to WPA does not work. Resetting to WPA2 does not work.

    Password has been double-checked. Inputting the wrong password gives me an "Unable to Sign in" error on the Wi-Fi preferences page.
  9.    #9  
    Tried using mauro1's tips:

    Google's about page loads...but extremely slowly, it took about two minutes for text to show up on my Pre.

    The DNS server matches that of the other computers I have connected.

    Thoughts? I have no issues connecting to my friend's WPA2 network or my school's WPA2 enterprise network.
  10. #10  
    Quote Originally Posted by nathanielonfire View Post
    Pre is able to receive data on an unencrypted connection. Resetting to WPA does not work. Resetting to WPA2 does not work.

    Password has been double-checked. Inputting the wrong password gives me an "Unable to Sign in" error on the Wi-Fi preferences page.
    There are two possibilities here.

    1: Your Pre has a hardware or software defect. Test it on another WiFi network, and if it displays the same error it's time for WebOS Doctor.

    2: Your WiFi network has an error. Try turning off ALL your other devices, rebooting the DHCP server, and go from there. There are wifi access points leased through ISP's that only connect a certain number of devices, and this may be your problem.
    Doug Meerschaert
    NoInsultSoftware.com

    Apps: Scratch, GasMath, CheckMath
  11. #11  
    Quote Originally Posted by Planesdragon View Post
    There are two possibilities here.

    1: Your Pre has a hardware or software defect. Test it on another WiFi network, and if it displays the same error it's time for WebOS Doctor.

    2: Your WiFi network has an error. Try turning off ALL your other devices, rebooting the DHCP server, and go from there. There are wifi access points leased through ISP's that only connect a certain number of devices, and this may be your problem.
    Hardware problem is unlikely seeing how his Pre can perfectly connect to other WPA2 networks except his own. The only software defect would be WebOS having a corrupt entry for his SSID network name that the "Forget Network" command can't relief.

    The Pre also connects when the encryption is down while the other devices are connected as well (assuming). That is something to look into though. When he changed the encryption to off, he could have set the Pre to the only device connected to the router since the other devices are unaware of the encryption change.

    Definitely a problem between the Pre and router settings. Compatibility issue most likely?


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  12.    #12  
    Changing the SSID made no effect - I'm guessing the issue is somewhere in my router encryption settings, but I don't know what. I reset the DCHP server, reset the lease time, they just don't want to get along.

    It's really strange because websites are loading, for example, I loaded Ars Technica mobile, but the site displayed as one of those hierarchical bullet trees with all-blue links, if that makes any sense.

    Like I said, I'm at a total loss. Hopefully comcast isn't going to go nuts because of all the IP address stuff. I can use 3G no problem, so I can stick with that. For the record, this router has never worked with the Pre, I finally finaggled enough of the settings to get it to actually connect to the wireless network, but actual downloading over the internet is a no-go.
  13. #13  
    What's your router's serial code? Try dropping your WPA2 passcode to 8 characters as well.


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  14.    #14  
    Do you mean the 8-digit pin on the bottom? Do you really need that?
  15. #15  
    I'm using a WPA2-PSK network with no problems. My password is only 8 characters though. I even have my SSID masked and I have no problems. Try changing the password length and see if that works. If not, either it's a hardware problem or a WiFi problem.

    Also, maybe you should try seeing if you can connect to a network with a WEP and see if it can connect and load pages.
  16. #16  
    Quote Originally Posted by nathanielonfire View Post
    Do you mean the 8-digit pin on the bottom? Do you really need that?
    Wanted to see if the router has any WPA2/DNS problems noted on the internet that are worth reading. Also, I get to visualize what settings you are working with.


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  17. Solen's Avatar
    Posts
    112 Posts
    Global Posts
    116 Global Posts
    #17  
    Hmmm...make sure you have a large enough DHCP IP address range(such as 192.168.1.100 through 192.168.1.110). Also, change the router's SSID name, since maybe your Pre is somehow remembering the faulty settings of the same SSID name you keep reusing(possible bug). Possibly try and change the wireless channel to something else, like channel 1, 6, or 11 or anything from the default. Not sure if these changes will do anything to help, but worth a try.
    Good Luck!
    Palm Pre on Sprint. WebOS 1.4.5
    If I helped you, a thanks would be much appreciated (Thanks button located on right side)
  18. blaidan's Avatar
    Posts
    145 Posts
    Global Posts
    267 Global Posts
    #18  
    You mentioned that you have your network set to mixed g/b. Might sound trivial, but have you tried setting your router to "802.11g-only"? I would have to imagine that you probably don't have anything necessitating the use of 802.11b as it is an older standard. If you do have 802.11b devices then obviously that would render this suggestion moot.
  19.    #19  
    FIXED IT!

    After googling about WPA2/DNS stuff for Belkin routers and smartphones, I finally got a tip.

    I went and manually managed the network on the Pre, entering the same IP address that it had been given automatically, but left the DNS server blank. And voila, it worked.

    So bizarre. All the other devices seem to be working fine, so hopefully that'll be the end of my problems.

    Thanks to everyone for all the tips. I tried so many of them, changing the SSID and changing the IP address, and changing the channel - no luck with any of them. But hopefully, I'm back in business again.

    Thanks again,
    - nathanielonfire
  20. #20  
    Quote Originally Posted by Solen View Post
    Hmmm...make sure you have a large enough DHCP IP address range(such as 192.168.1.100 through 192.168.1.110). Also, change the router's SSID name, since maybe your Pre is somehow remembering the faulty settings of the same SSID name you keep reusing(possible bug). Possibly try and change the wireless channel to something else, like channel 1, 6, or 11 or anything from the default. Not sure if these changes will do anything to help, but worth a try.
    Good Luck!
    He has a static IP address setup so the DHCP isn't the problem. He has already tested changing the SSID name and I've thought of telling him to change the channel number, but I'm sure this is a problem with the WPA2 encyption/DNS settings so the channel wouldn't matter. Anything is worth a shot though.


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
Page 1 of 2 12 LastLast

Posting Permissions