Results 1 to 3 of 3
  1.    #1  
    When on a trip yesterday, I tried to use Sprint Navigation, as I had many times before. But it would not connect and told me Telenav had "expired". Huh? Since when? Anyone else had this problem?
  2. #2  
    Happened to me. I got a pixi for my mom (when they were free online). When I got the phone in the mail, I called Sprint to have her phone number changed because she wanted a different area code.

    Apparently TeleNav (they are the 3rd party provider for GPS) didn't get the change from Sprint, so they didn't recognize the new phone number. After about 3 hours on the phone with various reps and a few resets, I finally got it to work.

    If you have the option to renew your subscription, I'd do that first (even though it might say it'll cost $10/mo). If that doesn't work try to udate your network settings and do a reset. If those don't work, call Sprint. (they may have you do a hard reset).
  3. ay
    ay is offline
    ay's Avatar
    Posts
    720 Posts
    Global Posts
    772 Global Posts
    #3  
    Quote Originally Posted by w8aq View Post
    When on a trip yesterday, I tried to use Sprint Navigation, as I had many times before. But it would not connect and told me Telenav had "expired". Huh? Since when? Anyone else had this problem?
    I had this occur once as well. I agree with ISU_phoria, but suggest that you start by having Sprint contact Telenav (or vice versa) via a conference call with you on the line. I did that, and the problem got resolved right away. I think you'll probably have more luck convincing a Telenav employee to make such a call, rather than a Sprint one, but you'll need to find that right Telenav employee since technically the request should be going from Sprint to Telenav, and not the other way.

Posting Permissions