Results 1 to 7 of 7
  1.    #1  
    hello
    i am trying to connect to my corporate wireless network, but I get a certificate error. I am choosing the security as ENTERPRISE (choices are WPA-personal, WEP, and Enterprise), and I fill in my AD user and password. After a few seconds of looking like it will connect, it gives me an error message:

    "I cannot accept the certificate to authenticate, and to contact my administrator."

    I checked with my IT dept, and someone suggesed that I disable certificate revocation check.

    Any ideas on how to make it work?
    Thanks
    Last edited by NABRIL15; 06/17/2010 at 07:38 PM.
  2. #2  
    Not sure if this the same thing or not, but my company's corporate wireless requires a certificate to be installed on my Pre. I created the certificate and installed it on my device. Then, when I went to connect to the network I selected the "Enterprise" security option and then was prompted for my username/password. It would then fail before asking me to select the security certificate. I would then change something and try again but couldn't get it to work.

    Finally, after getting frustrated, I entered my AD username/password as I originally did and got the same error. But, instead of changing something, I just hit the button to try connect again (without changing anything) and this time it properly prompted me for the certificate to use and it worked.
  3. Barebuns's Avatar
    Posts
    86 Posts
    Global Posts
    87 Global Posts
    #3  
    how did you create the certificate?

    Thanks
    Greg
  4.    #4  
    Yes please
  5. #5  
    The process will likely vary widely depending on the security set-up of your corporate network. But the basic process that I followed was as follows:

    1. Export the identity certificat that was installed on my work PC (start > Run > certmgr.msc > Personal > Certificates > Right-click > Export > ...). Then, email the resulting file to my Pre as an attachment. Then, when you open the certificate on the Pre, it will prompt you to install it.

    2. Next I created a CA certificate through a CA certificate manager server. That process creates the CA certificate which I again emailed to my Pre as an attachment.

    The process was very similar to some instructions that someone put together for configuring wireless access for iPhones on our corporate network. So, if your IT people know how to configure an iPhone, they should be able to step you through the process on your Pre.
  6. alexpatcas's Avatar
    Posts
    6 Posts
    Global Posts
    7 Global Posts
    #6  
    Quote Originally Posted by NABRIL15 View Post
    hello
    i am trying to connect to my corporate wireless network, but I get a certificate error. I am choosing the security as ENTERPRISE (choices are WPA-personal, WEP, and Enterprise), and I fill in my AD user and password. After a few seconds of looking like it will connect, it gives me an error message:

    "I cannot accept the certificate to authenticate, and to contact my administrator."

    I checked with my IT dept, and someone suggesed that I disable certificate revocation check.

    Any ideas on how to make it work?
    Thanks

    I am betting you guys use 802.11x identification with LEAP or PEAP. check that to make sure.
  7. LNWJ's Avatar
    Posts
    447 Posts
    Global Posts
    625 Global Posts
    #7  
    I work in IT and where I am employed we employ an 802.1x Auth via WPA2 Enterprise (Uses our Active Directory user/pass to authenticate PEAP).

    You will need to request the Root Certificate (Your ISO or Network Admin should have it) your IT department uses and import it in the Pre's "Device Info" app and from the Menu drop down select Certificate Manager.

    I used it for awhile, but our network is really wonky and so I usually just rely on 3G.

    Hope this helps!

Posting Permissions