Page 1 of 2 12 LastLast
Results 1 to 20 of 34
Like Tree2Likes
  1.    #1  
    Is there any way to get WebOS to allow more advanced menu options for WPA Enterprise configuration? At my university we use PEAP and MSCHAP for authentication and while the Pre sees the network, it won't authenticate with my credentials using whatever settings it's automatically detecting. I'm very tech savvy so If I have to get my hands dirty and edit a config file somewhere, I'll do it. I just got the AT&T Pre Plus and it's a great phone, but this is a bit annoying as I'm at work 8 hours a day and stuck with 3G instead of our network.
  2. theta8159's Avatar
    Posts
    3 Posts
    Global Posts
    7 Global Posts
    #2  
    It doesn't work with our network at work either. We run a similar network to your university. It won't work at all and I'm the one who maintains our wireless network! What is worse, is that I roam at my desk and I'm stuck at 1x speeds all day.
  3. #3  
    ugh, it's quite frustrating that this still hasn't been fixed a year later. Android is filling our office and it doesn't have a problem hooking on to wifi. this is becoming a make or break issue for me unfortunately. Being able to roam on the campus wifi would make life a lot easier.
  4. #4  
    Weird. The campus where I work runs PEAP, MSCHAPv2, and a hidden ESSID. I don't have any problems connecting to the Wi-Fi here.

    If you want to get down and dirty with it, latch on via the command line and see what processes are running. I would _guess_ it's NetworkManager, but that is just a guess.
  5. #5  
    Mine works here too. I had to copy the necessary certificate (from my Windows PC's certificate store) in order for it to work.
    "just like your rims still spin even after your car stops/ then where will you spend eternity after your heart stops huh?"
  6. kuoirad's Avatar
    Posts
    204 Posts
    Global Posts
    340 Global Posts
    #6  
    The problem (at least for me) is the version of PEAP being run on the network. Here at UT, they run a PEAPv1 network, and the phone appears only able to do PEAPv0. So it doesn't work.

    I've been working on and off with the main networking people here to get them in touch with Palm to try and get this resolved - webOS's 802.1x support is pretty bad as is anyway, what with no configuration options available and no easy way to manage certificates...
  7. Tigrao's Avatar
    Posts
    110 Posts
    Global Posts
    111 Global Posts
    #7  
    My work has both an unsecure wireless network and a WPA2 Enterprise encrypted network using PEAP and MSCHAP for sensitive information. I always used the unsecure one because I figured my Pre couldn't connect to the secure network. I just decided to give it a try and it connected up just fine. I was surprised. I will be using the encrypted network from now on.
  8. #8  
    The certificate may be the key
    Go to Device Info - Preferences - Certificate Manager
    It's easy to manage them, it's a bit difficult to find the app
  9. allonon's Avatar
    Posts
    372 Posts
    Global Posts
    373 Global Posts
    #9  
    Issue I have is that we use eap-tls at work with a nb-ssid. The wireless manager doesn't give me an option to select certificate, I'm assuming due to the manual addition of the network. The docs say it should.
  10. #10  
    Quote Originally Posted by allonon View Post
    Issue I have is that we use eap-tls at work with a nb-ssid. The wireless manager doesn't give me an option to select certificate, I'm assuming due to the manual addition of the network. The docs say it should.
    Are you referring to Pre docs? I've never been prompted for a certificate, but indeed had to install certs before email and wifi would connect. The Pre doesn't support Cisco EAP so you will have to see if your network accepts other authentication protocols.

    As for adding certs just find the correct cert (i.e. Windows cert store), copy it to Pre in USB mode then follow NuttyBunny's guidance in post #8 to manage (add/remove) certs. Then you can try re-adding the wireless network and see if it connects.
    Last edited by dagumcp; 08/18/2010 at 10:41 PM.
    "just like your rims still spin even after your car stops/ then where will you spend eternity after your heart stops huh?"
  11. allonon's Avatar
    Posts
    372 Posts
    Global Posts
    373 Global Posts
    #11  
    Quote Originally Posted by dagumcp View Post
    Are you referring to Pre docs? I've never been prompted for a certificate, but indeed had to install certs before email and wifi would connect. Just find the correct cert (i.e. Windows cert store), copy it to Pre in USB mode then follow NuttyBunny's guidance in post #8 to manage (add/remove) certs. Then you can try re-adding the wireless network and see if it connects.
    Yup, the certs are listed in cert manager.
  12. #12  
    Quote Originally Posted by allonon View Post
    Yup, the certs are listed in cert manager.
    Then besides being in a location with a nice strong signal and entering all of the proper credentials (i.e. inner/outer authentication) I would assume that the authentication methods available on the Pre are not compatible with your network. My campus offers a list of all possible authentication options. Hopefully you can find something that works!
    "just like your rims still spin even after your car stops/ then where will you spend eternity after your heart stops huh?"
  13. #13  
    Very odd ever since day one of my original sprint pre Enterprise wifi with login/pass worked fine but now it just reffuses connection. I am now on a frankin pre2 but none the less it worked for months with it but for about 3-4 weeks no go
    MatterOfFactJack
  14. #14  
    Quote Originally Posted by jack87 View Post
    Very odd ever since day one of my original sprint pre Enterprise wifi with login/pass worked fine but now it just reffuses connection. I am now on a frankin pre2 but none the less it worked for months with it but for about 3-4 weeks no go
    You should of course try having your phone 'forget' the network then try again. I would check with IT to see if things changed. I had this issue a few months ago and it was because they changed the authentication method along with hardware changes.
    "just like your rims still spin even after your car stops/ then where will you spend eternity after your heart stops huh?"
  15. #15  
    Quote Originally Posted by determinedd View Post
    You should of course try having your phone 'forget' the network then try again. I would check with IT to see if things changed. I had this issue a few months ago and it was because they changed the authentication method along with hardware changes.
    I cant seem to find the forget button anywhere anymore :-/... It very well could be changes to the network here to. Thanks. (that be annoying as i dont think they will care enough to make it work with webos)

    Edit...
    To "forget" you need to connect first. And it fails to authenticate to begin with so never connects. But i guess that means its forgotten already anyway.
    MatterOfFactJack
  16. #16  
    A month too late? Anyway, This was really bothering me, so I exported all of my certs from Firefox in "der" format (.cer). Copied all 174ish of them to the internal drive on my Pre- in a "Certs" folder. Then began importing them under "Device Info." (Yes, one at a time.) After importing in groups of 10 then attemting to connect, it finally worked. "DigiCert High Assurance CA-3" is what I narrowed it down to by removing them a few at a time. This is for the University of West Florida's uwf-argo-air, WPA2 Enterprise, PEAP, MSCHAPV2, "No CA certificate required." Good Luck.
  17. #17  
    Quote Originally Posted by Chriswhat21Pre View Post
    A month too late? Anyway, This was really bothering me, so I exported all of my certs from Firefox in "der" format (.cer). Copied all 174ish of them to the internal drive on my Pre- in a "Certs" folder. Then began importing them under "Device Info." (Yes, one at a time.) After importing in groups of 10 then attemting to connect, it finally worked. "DigiCert High Assurance CA-3" is what I narrowed it down to by removing them a few at a time. This is for the University of West Florida's uwf-argo-air, WPA2 Enterprise, PEAP, MSCHAPV2, "No CA certificate required." Good Luck.
    Too late? No freaking way. I and I'm sure many others are still suffering by this. I didn't even know you could manually insert you own certs in the device info section. And I consider myself as a WebOS expert, I been using it since June of 09 when it was released. Thanks so much for the helpful insight. I will try to figure out if I grab the right cert if it will work with the University of Utah Secure SPA network (it used to work without a hitch I dunno what changed).
    MatterOfFactJack
  18. #18  
    So I know the U of U uses an entrust.net cert. i exported it from chrome and installed it on the TP but am still unable to connect to the wifi
    MatterOfFactJack
  19. #19  
    Load of ****. I cant get the damn thing to connect to the network
    MatterOfFactJack
  20. #20  
    Sorry man, and I don't mean to rub it in, but I tried the same certificate on the Touchpad yesterday and now that's connecting to the school's wifi. The IT guy at UWF also told me that some Blackberry phones required the EnTrust certificate, so those were the first ones that I tried. I know it's time consuming, but I would just go though them a few at a time. Maybe one will eventually work. Patience, good luck.

    FYI - I triple boot my laptop: Fedora 15, Ubuntu 11.04, and Win7, none of those use any cert to connect to the wifi, just my student login. I also used the same one on a friend's Pre Plus and it connects fine now also.
Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions