Results 1 to 5 of 5
  1.    #1  
    It seems like the Pre is using 3G for sending email under certain circumstances, even if I am connected over WiFi.

    If the outgoing SMTP server for sending email, is not reachable through WiFi, then the Pre seem to try the 3G connection and sends mail through 3G. This is quite a reason to keep data roaming OFF, if one does not have a 3G data contract while traveling.

    This happens because SMTP servers often do not allow sending mail if they cannot identify the sender somehow. A 3G carrier however, knows that you are a client on their network, and allows sending email through their SMTP server. That server however, would often not allow being used through WiFi.

    You can test this by
    - use an SMTP server of the carrier in email preferences
    - disabe 3G data, leave WiFi on
    - send an email, wait and look in the outbox, see the error message.
    - enable 3G, it will not be visible in the top bar because WiFi prevails
    - wait what happens, or send a second email and the first one will be sent too
  2. #2  
    Normally I want it to do this, but I guess I'll keep it in airplane mode while I'm on my cruise. I think wifi can be turned on while in airplane mode.
  3. #3  
    This is correct. I just returned from the Bahamas and had the phone in airplane mode while using wifi and it worked without any hitches.
  4. #4  
    there seems to be more to the topic. i panned to wait posting anything untill i get the bill that will state exactly what happened. but until now i can say:

    the gsm pre will be using a gsm connection for smtp even when wlan is connected and under some circumstances wont even show an icon informing you what is going on.

    the original poster of this thread mentioned that there would by mail servers that somehow auth you via your very connection and will not let you smtp when you connect via a route other than the mobile carrier itself.

    there must be more to it as i (and i guess a lot of people) do not use a mailserver that is connected or referring to my carrier at all.

    what i did was:
    german gsm pre,
    roaming in japan,
    being on wlan (my brothers),
    syncing, surfing, imaping, perfectly having data-connection and data-roaming setting OFF in phone settings,
    exchange server sync also perfectly even sending out emails,
    BUT:
    smtp was not working (the mail server is hosted by a friend in germany) palm pre messages.log stating a "daily data throttle" problem each time the smtp wanted to send an email,
    suspecting this to be a bug i tested switching data-roaming and data-connection ON in phone settings...
    smtp then ran perfectly WITHOUT any data icon (2g/3g) displayed other than the wlan icon itself.

    so i assumed it was using wlan.

    so i sent out a few hundred MBs

    my carrier informed my the day after that there are a few hundred euros to pay ;)

    i still wait for the bill where i can verify exactly what happened and i will post here, but i suspect a major "flaw" to be a somewhere...

    i tested smtp in airplane mode and wlan back home then and it perfectly worked. so it cannot be auth problems i think because i can switch back and forth between gsm and wlan: my mailserver will accept smtp auths right away.

    i suspect it to be something wlan specific: time zone offset together with some handshake flaw or likewise? but using my netbook within the wlan of my brother in japan... smtp also was fine...

    so

    1) something prevents the pre to use smtp sometimes. but that might not be the problem of the device alone. still i suspect the "daily data throttle" message to point to something weird...

    2) the pre might go for gsm-data instead and for some strange reason it might happen that it will not show that it is doing so. but i will confirm that if i can prove 100% by verifying the billed connection table...
  5.    #5  
    There are 2 separate, but connected issues here:
    1. What does the Pre do when it cannot send email over an otherwise OK and connected WiFi network. This is a Pre issue.
    2. What are the reasons one cannot use an outgoing SMTP server for sending email. This is not a Pre issue in itself. Many travelers have experienced that they cannot use their usual SMTP server setting.


    ad 1) I think my original post addresses this. The Pre automatically falls back to the 3G connection even if WiFi is connected and shown as in use in the top status bar as 'the' connection used.

    ad 2) Just to give some background on the SMTP server issue,
    I'll use some typical examples:
    1. Pre -> Home WiFi -> Home Internet -> Prefs set to SMTP server of my Home Internet Service Provider
      This should work, no problemos.
      .
    2. Pre -> 3Gnet -> 3G provider's Internet -> Prefs set to 3G provider's SMTP server
      This should work.
      .
    3. Pre -> Friend's WiFi -> Friend's Internet -> SMTP server of my Home Internet Service Provider
      This does not work over WiFi (likely,European scene) because:
      • Everybody in the world could use the SMTP server to send spam
      • EU legislation requires providers to archive email
      In this case, after trying WiFi, the Pre will try to use the 3G connection. And since it is setup to use the home SMTP server, the 3G connection to the SMTP server will also be rejected. Same reason, the home ISP does not know who you are.
      No email sent.
      .
    4. Pre -> Friend's WiFi -> Friend's Internet -> SMTP server of my 3GInternet Service Provider
      This does not work over WiFi likely, same reasons as c)
      In this case, after trying WiFi, the Pre will try to use the 3G connection. And since the server setting and the 3G network used is OK for the 3G provider, the Pre will use 3G to send email.

    One can make it's own scheme and judge why it would/would not work. There is one other issue to consider. What if outgoing SMTP requires a password? (setting in email prefs). Would that solve much of this?

    Pre -> Home WiFi -> Home Internet -> SMTP server of my 3G Internet Service Provider with my password/user name for outgoing email
    or
    Pre -> Friend's WiFi -> Friend's Internet -> SMTP server of my Home with my password/user name for outgoing emailInternet Service Provider

    This would not work over WiFi. Because:
    Many (?) Internet Service Provider block usage of another /external SMTP server. Same reasoning as under a). SO even though the 3G provider would allow this connection to their SMTP server over every network, the home/friend Service provider would not.

Posting Permissions